1. vinndy's Avatar
    Just curious bc I cannot download it. I get an error stating that my device can't handle it. I recently had to wipe device due to data issue and vzw installed 4.5.0.89 on my curve. Now no bb maps. Any thoughts?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-18-08 01:50 PM
  2. TwinsX2Dad's Avatar
    I don't believe you can do OTA. You need to connect to your PC & do it there.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-18-08 01:56 PM
  3. vinndy's Avatar
    I went to BB website, went through steps to to dl the program, it tells me to connect my device, and as soon as I do it tells me that "Sorry, your device does not meet the system requirements that are needed to support BlackBerry Maps."
    I note that is says "BlackBerry Maps is only available on devices running device software v4.1 or v4.2.x"
    I have an 8330 running 4.5.0.89
    12-19-08 08:50 AM
  4. TwinsX2Dad's Avatar
    Did you use your Desktop Manager? I am running the same version & Maps was included. I even reinstalled it for someone else on their Berry yesterday - it was a new one that had some user caused issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-19-08 09:05 AM
  5. vinndy's Avatar
    no b/c Desktop Manager wants to load an OS than is a downgrade from that one that vzw just installed. Wied situation I know, but now since I am on BES, vzw and other policies won't let me download the same .89 os i have on my device.
    12-19-08 02:22 PM
  6. mchugh89's Avatar
    I get the same error with bb maps. I am running 4.5.0.77.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-08 10:29 PM
  7. vinndy's Avatar
    I get the same error with bb maps. I am running 4.5.0.77.

    Posted from my CrackBerry at wapforums.crackberry.com
    did you ever find a way around this? I haven't
    12-30-08 01:22 PM
  8. Mamaluka's Avatar
    You've got to install the same OS on your PC as you have on your BB. Go do a search for .89 and install it on your PC. Then plug your bb in and DM will function properly and will allow you to add BB Maps on your device.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-08 11:01 PM
  9. jeffh's Avatar
    The OTA downloadable version of BBMaps is only for obsolete versions of the OS. Current OS versions include BBMaps as part of the OS load, so you have to install BBMaps using the App Loader. Run Desktop Manager App Loader and check the box for BBMaps. That will install it.
    12-31-08 12:06 AM
LINK TO POST COPIED TO CLIPBOARD