1. jmgilliam's Avatar
    I have 4.3.0. on my bb and am trying to upgrade to 4.5. I have all the right software downloaded - 4.5 DM, the .77 downloaded and ran, but I open up DM and go to App Loader and nothing is found to upgrade.

    My 4.3 was from alltel or us cellular before vzw came out with it. I assume I deleted the vendor file to get that to work - do I have to add the vzw vendor file back to get the upgrade to work??
    11-05-08 03:17 PM
  2. sunkast's Avatar
    If you already have .77 installed on your device, then you already have the latest, regardless of the carrier. So installing VZW to your computer and expect it to update your phone which already has .77 won't work. You would need to wipe your device clear of the OS first. Not worth the bother if you already have .77 on it.
    11-05-08 03:24 PM
  3. jmgilliam's Avatar
    I don't have .77 on it. still 4.3 ... That's my problem, I've got all the steps done, but it doesn't update...
    11-05-08 03:48 PM
  4. LDubs's Avatar
    Which carrier's .77 version did you download? If it's Verizon's on you're on Verizon it couldn't hurt to reinstate the vendor file.

    anyway try this:

    open application loader
    choose "update applications" option
    choose "advanced" button under Device Application Selection
    Click "Next"

    might work.
    11-05-08 03:55 PM
  5. jmgilliam's Avatar
    I downloaded the vzw version
    11-05-08 03:59 PM
  6. sunkast's Avatar
    Open DM, go to Help > About > Device Software. Do you see 4.5 in the list? If you don't, then you need to install 4.5 on your computer.
    11-05-08 05:46 PM
LINK TO POST COPIED TO CLIPBOARD