1. BerryKid's Avatar
    Should I DL it or wait until the bugs get fixed? What exactly are the improvements? I got a text today from verizon to upgrade from their website and this is the version it listed to download "BlackBerry Device Software v4.5 (updated 10/31/2008)"
    11-12-08 11:52 PM
  2. MTXThunder9500's Avatar
    I was kinda forced to do it cuz my curve was wiggin out and actually I have no errors of any kind yet and I'm going on day two with it

    Posted from my CrackBerry at wapforums.crackberry.com
    11-12-08 11:54 PM
  3. cereal killer's Avatar
    I would keep 4.3. .77 had a huge memory leak for me and others as well.

    If you really want to upgrade get the .97 beta. Its a lot better. For me at least. Maybe others will back me up on that.

    Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-08 12:15 AM
  4. joe003's Avatar
    Here's a link that shows you what's new in 4.5:

    BlackBerry - BlackBerry Device Software
    11-13-08 06:33 AM
  5. amofiav's Avatar
    i have had no issues with 4.5... but i'm not running the official vzw software
    11-13-08 08:06 AM
  6. RicanMedic78's Avatar
    how do u know if ur running the beta or the official software? I'm running 4.5.0.77 but I did not get this off the vzw page. I DL'd it about a month prior from a leaked copy.
    11-13-08 10:22 AM
  7. monkeyboi's Avatar
    I'm running 4.5 with no issues whatsoever.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-08 10:36 AM
  8. bpatsy's Avatar
    I DL it yesterday from VZW and have no problems.
    11-13-08 11:06 AM
  9. newsome's Avatar
    The only problem I've had has been with GoogleTalk for BlackBerry. After I upgraded, it still worked great unless I was out of EVDO area and in 1X area. In a 1X area, it disconnects after a few seconds telling me that it cannot connect to the server. Never had this problem until after I upgraded. I broke down and bought BeeJive, and it works great on the GTalk network with no disconnect.

    The HTML e-mail is soooooo worth it for me. Been waiting for that for a long time.
    11-13-08 11:16 AM
  10. OdiiGis's Avatar
    I DL'd too. No probs for me(yet). What are the differences other than what VZW posted on their website? HTML email? where? I didn't see changes on the media player on the phone either. Maps works faster. I still like Google Map a little bit better. Guess I was expecting leaps and bounds type thing.
    11-13-08 11:23 AM
  11. JRSCCivic98's Avatar
    how do u know if ur running the beta or the official software? I'm running 4.5.0.77 but I did not get this off the vzw page. I DL'd it about a month prior from a leaked copy.
    Realize what you just said and you'll get your answer.
    11-13-08 11:45 AM
  12. cwcanty's Avatar
    I have it as well and it seems a little laggy sometimes, but that could be due to another issue.

    The html email is great and I like the upgraded camera interface, BBM, and media player.
    11-13-08 03:23 PM
  13. rlervin's Avatar
    I have had no problems since installing.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-08 05:29 PM
  14. firemedic45806's Avatar
    Just got my Curve and found out it is running 4.3. Where do I find the d/l from vzw? Sorry if it's a newbie question, but I am in fact, a newbie. Oh, and this curve ROCKS!!!!! sooooo glad I jumped to this.
    11-13-08 10:40 PM
  15. McSweede's Avatar
    I just installed 4.5, and though most wont care, its weird that the built in pics for the desktop are now gone, at least I cannot see them in the same place they were before. I'm still kinda a BB noob too.
    11-14-08 12:06 AM
  16. wwbobski's Avatar
    I have been using it since Vzw released it. Got my HTML email, after resending the service books, got docs to go and have done the update. I even think it might be just a bit faster too. I just followed the directions on the VZW site of course I did a complete backup before I installed the new OS. Working Good.
    11-14-08 09:59 AM
  17. on_a_stick's Avatar
    i just downloaded 4.5 from the verizon site because 4.3 was acting even buggierr then normal & now i have a freaking brick.

    Everything looked good then I disconnected from the computer and 20 seconds later nothing but a flashing red light.

    Yay me!!!!!!!!!!
    11-14-08 06:40 PM
  18. fineazzne1's Avatar
    The only problem I have is my pictures are not saving when I take them.. When I select save it says file system full.. any help with that
    11-16-08 10:19 PM
  19. timatl's Avatar
    4.5 runs great on my 8320

    Posted from my CrackBerry at wapforums.crackberry.com
    11-16-08 10:54 PM
  20. JRSCCivic98's Avatar
    The only problem I have is my pictures are not saving when I take them.. When I select save it says file system full.. any help with that
    You're out of memory. Delete some stuff. Also a memory card to save all your media to would help as well.
    11-17-08 12:14 AM
  21. JRSCCivic98's Avatar
    i just downloaded 4.5 from the verizon site because 4.3 was acting even buggierr then normal & now i have a freaking brick.

    Everything looked good then I disconnected from the computer and 20 seconds later nothing but a flashing red light.

    Yay me!!!!!!!!!!
    Yep, Yey you... you shouldn't have unplugged it until it said it was finished with the process... which it didn't because otherwise you wouldn't have a brick.

    Read this... http://forums.crackberry.com/f3/how-...ckberry-32322/
    11-17-08 12:15 AM
LINK TO POST COPIED TO CLIPBOARD