1. blessed2bamommie's Avatar
    I cant use Places with the FB upgrade! It say location unavailable and I can ck share location in options. I have my privacy settings for friends. I suspected the VZW blocking issue. It was brought up again in another thread. Is it somehow different from Poynt and 4Square?
    11-13-10 07:19 AM
  2. Deathcommand's Avatar
    That sucks.

    I can't confirm. But are you sure your version is 1.9.0.20?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-10 07:27 AM
  3. Motorcycle Mama's Avatar
    The GPS on the 8330 from Verizon will not work with third party applications. Time for a newer device.
    11-13-10 07:30 AM
  4. Deathcommand's Avatar
    Wait really? So 8330 sprint is okay right?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-10 09:16 AM
  5. Motorcycle Mama's Avatar
    Yes. And yes.
    11-13-10 10:09 AM
  6. blessed2bamommie's Avatar
    I upgrade at the beginning of next year. I'm done with BB and one of those wondering if the iphone rumor is true or pick up a Droid.

    And the fb places website? I'm gonna try it on Bolt. So far a no go on the native browser, which seems just about everything is a no go on that!
    11-13-10 07:45 PM
  7. jeffh's Avatar
    Changing the browser won't fix the GPS, but you may prefer Bolt for other reasons.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-13-10 08:24 PM
  8. i_hiker's Avatar
    The 8330 was a great device...2 years ago. Technology has rapidly advanced. Your app needs have outgrown your device capability. Looks like it's time for a new phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-10 10:07 AM
  9. davidnc's Avatar
    The 9650 used to be nice too but now its day has passed
    11-15-10 05:49 AM
  10. blessed2bamommie's Avatar
    Changing the browser won't fix the GPS, but you may prefer Bolt for other reasons.

    Posted from my CrackBerry at wapforums.crackberry.com
    I was trying the places site on Bolt.
    11-15-10 08:00 AM
  11. blessed2bamommie's Avatar
    The 8330 was a great device...2 years ago. Technology has rapidly advanced. Your app needs have outgrown your device capability. Looks like it's time for a new phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    No doubt! I'm due for an upgrade early next year! Ready to move on from BB to an Iphone or Droid
    11-15-10 08:02 AM
  12. jeffh's Avatar
    If you want to stay with BlackBerry, the GPSr works without any restrictions in the 9630 and 9650 and newer models from Verizon. Only in the older models does Verizon block the GPSr.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-15-10 08:07 AM
  13. blessed2bamommie's Avatar
    Nah! I like apps and reasonably priced ones!
    11-15-10 08:13 AM
  14. i_hiker's Avatar
    The 9650 used to be nice too but now its day has passed
    Actually...there are at least two good reasons to own a 9650: (1) Push email - easier on battery life, (2) SIM card - for international travel.

    You can tout the advantages of a Droid all day but it all boils down to priorities for the end user, and which device fits their personal needs. When LTE rolls out, both of our devices will be passed their prime.
    11-15-10 09:04 AM
  15. davidnc's Avatar
    Actually...there are at least two good reasons to own a 9650: (1) Push email - easier on battery life, (2) SIM card - for international travel.

    You can tout the advantages of a Droid all day but it all boils down to priorities for the end user, and which device fits their personal needs. When LTE rolls out, both of our devices will be passed their prime.
    I agree with the part of LTE making both devices pass their prime.

    But as far as battery life I get 30+ hrs on 1300 mah battery on incredible and 44+hrs on 2150 mah battery for the incredible,

    On the dx I get 26 hrs on stock 1540 mah battery(getting a 1750 mah battery today) .

    I would have to charge blackberry every night so avg , 15 hrs on it for its battery life .

    Of course push email both gmail and pop-server, but I quit syncing with google so now just pop-server(same as blackberry was)
    Last edited by DavidNC; 11-16-10 at 09:11 AM.
    11-16-10 09:01 AM
LINK TO POST COPIED TO CLIPBOARD