1. smilingdaisy's Avatar
    My Curve 8330 crapped out yesterday. All of the sudden it won't make any sounds. When I try to play a sound file (even a long one) it makes no noise and stops after less than a second. I called online BB support through VZW and I was told that there is nothing they can do and I need a new phone.

    I have two questions:
    1-is there any way to fix my phone?
    2-if not, what phone should I go to. I notice that there has been NOTHING new out from VZW in a while and was wondering what was the best of what was out there. Also, my upgrade date is not until November so I will be shelling out money for my new phone as well.

    Thanks!!!!
    04-28-10 07:00 AM
  2. pkcable's Avatar
    Have you tried a battery pull yet? Just the media player won't make a sound or no sound a all? Does it ring when people call? Can you hear them thru the phone? Can you do speaker phone or does that not work?

    There are newer BBs the updated curve 8530 (more mem and it has wifi) the Tour 9630 better every thing, the storm2 AND coming very soon is the Bold2 9650. At full retail though any of those will be expensive.
    04-28-10 07:12 AM
  3. smilingdaisy's Avatar
    I already tried a battery pull (at least 5 times...). Any other ideas?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-10 07:50 AM
  4. bluerskyes's Avatar
    Nothing new??
    04-28-10 09:59 AM
  5. smilingdaisy's Avatar
    I can hear throught the phone for a call and callers can hear me, my speaker phone also works too. It seems to only be my notifications that don't work. Also apps like iheartradio are not working either.
    Any ideas?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-10 10:45 AM
  6. Super_Mario's Avatar
    Did you try a wipe of the phone? Are you running the current approved software or a hybrid?
    04-28-10 11:49 AM
  7. smilingdaisy's Avatar
    I have not tried a wipe of the phone (honestly I don't know how) and I only have not downloaded any unapproved operating system.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-10 12:20 PM
  8. Super_Mario's Avatar
    Make sure you Back Up your phone or Sync using Desktop Manager and also make sure all your media (pictures, videos, music etc) are saved to a memory card. Then go to Options>Security Options>General Options or Settings>Menu Button>Wipe Handheld. Follow the prompts and it will erase your phone. After the wipe, test your phone, see if audio works. If it does, restore your phone. Test again.
    04-28-10 12:33 PM
  9. pkcable's Avatar
    Since the speaker phone and the headset are working, it's probably not hardware. So sounds like an issue with media player. I think we need to reload your OS. I am having a stress test today. I'm on lunch break. The others will help you. Do the wipe the suggest.
    04-28-10 01:24 PM
  10. davidnc's Avatar
    I lost my sound on not 1 but 2 8330 's when upgrading from the 4.5.0.138 OS to the 4.5.0.175 OS , all official from verzion. The first curve I was not sure about since I had downloaded themes and apps , etc.I did download the 4.5.0.175 os on it when it was avail for my curve and all was well for a while and after updating sound would go away( for some reason) and have to reboot . Took to store and they replaced.The second one though it was one of the first things I did and lost sound right off, I went back to 4.5.0.138 OS and all good again .But that was my case what OS is on your phone ?

    You said you did not have any unapproved operating systems but not which one you had?

    PS : the only way I could get sound back on my phone once it was gone was "ALT.+ right shift+del , and phone would reboot and I would have sound awhile then it would repeat after a few days or hours.
    Last edited by DavidNC; 04-28-10 at 01:30 PM. Reason: PS added
    04-28-10 01:25 PM
  11. smilingdaisy's Avatar
    I just wanted to update. This is apparently a common problem on the curve 8330 and here is the solution...

    Open up voice dialing the close it. You have to keep doing this over and over until you hear it say 'say a command' then it is fixed. Sometimes it fixes in 1 or 2 times, one time it took me 12 tries but it works every time.

    HTH.
    12-30-10 01:47 PM
LINK TO POST COPIED TO CLIPBOARD