1. stormydukefan's Avatar
    I have a s1, I got it in Aug, I know I an not up for a upgrade because I just had to use a multifur (or whatevere its called) in Oct. This is my 5th one, and is still just as bad as the others. I do have the new OS too.

    I see people talking about an option for storm users that let's you upgrade.
    My question is, is this true, and can I get a different phone?

    I don't mind redoing the two year I just want a phone that does what it is supposed to WHEN its supposed to. Thanx in advance.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-07-09 12:54 AM
  2. TwinsX2Dad's Avatar
    Not true.

    You can get a different phone by paying full price.

    Your two-years just restarted last month, so it has already been redone.

    BlackBerrys do what BlackBerrys do - they do well at being CrapBerrys.

    Sorry, but somewhere along the line, you may need to realize that with all of these problems, maybe it isn't the phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-07-09 12:58 AM
  3. stormydukefan's Avatar
    Sorry but I know the phone is not supposed to need a bat pull 2-3 times aday because it locks up. I could list the problems, but just know it is not user error.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-07-09 01:07 AM
  4. TwinsX2Dad's Avatar
    Sorry but I know the phone is not supposed to need a bat pull 2-3 times aday because it locks up. I could list the problems, but just know it is not user error.
    I could very easily get that behavior on a Curve, a Tour or a Bold. Run it out of memory, put the wrong apps on, download things to the wrong memory branch, get bad emails, operate it incorrectly... I could list the causes, but let's just say a betting man would get rich saying it is user error.

    The Storm is a piece of junk - but so are all BlackBerrys these days - but the return rate, paired with the actual defect rate... sorry, but the odds of having five defective units are so infinitesimal as to be mathematically nil.
    11-07-09 01:22 AM
  5. stormydukefan's Avatar
    I have to ask you, do you have or have you used a storm for more then three weeks?

    well you are right about one thing, the storm is a piece of junk. Good hardware but the OS needs some help. to be fair to the OS, I has to return two because they would not go into mass storage mode, one because the screen was flickering. I don't run the phone out of memory, I check it if it drops below 25mb I reset(that is counted in the 2-3 pulls aday). Is the phone defective? Probably not. The problem is the OS. After trying every is out there I am sick of it. I did not go upgrade to the storm for this. When I got the phone they said the new OS(148) fixed all the problems.

    I just want a phone that works, don't mind a few glitchs. when the glitchs interfere with uses the phone, something has to give. Either the phone or me, I don't think I should have to live with these problems.

    I see your point, but if vzw is just going to leave people that are truly haveing problems with there phones out in the cold, then maybe I need to leave vzw. I really don't want to but then again if I have to pay that much for a working phone, I am not giving it to vzw.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-07-09 01:54 AM
  6. HardcorePooka's Avatar
    I've had a Storm since March. It's worked great since I got it. I used to have to reset it once every few days, and then with OS5 I hardly ever have to reset it. I don't know why you are pulling the battery when it drops below 25... My phone works perfect even with 9mb left. To me it really sounds like this is user error in some way. How many and what apps do you have installed? If this really is your fifth phone go in to Verizon and talk to them. I'm sure if you've been a good customer and don't act like a jacka** to them they'll help you out in some way.
    11-07-09 06:21 AM
  7. lastraid's Avatar
    If you are having the same issue with the once you just got and it has 5.0 on it. I doubt it is the device as well. You really need to look at your habits and the software you are installing.

    You may need to bite the bullet and wipe the device and bring up bare min on the device. Run it for a day or so and start adding apps back one at a time and test after installing each. When you install the one causing the problem, you will know. Of course it could might a combination of apps.

    I know lots as well that run the S1 and do not have these problems.

    Hope all works out for you.
    11-07-09 07:46 AM
  8. IDsweetcheeks's Avatar
    I could very easily get that behavior on a Curve, a Tour or a Bold. Run it out of memory, put the wrong apps on, download things to the wrong memory branch, get bad emails, operate it incorrectly... I could list the causes, but let's just say a betting man would get rich saying it is user error.
    Whole heartedly agree with this statement.
    I've caused nothing but problems for my Curve this past week. I like to see what I can dish out and still have the phone function. At one point, it was bricked.
    Most of the things I did ( in a pure attempt to re-create customer issues )
    resulted in lag and freezing... even this one point where my speaker didnt work and I couldnt hear the person on the other line then started getting this loud screechy feedback noise.
    It was AWSOME...
    but I'm sorry... no one can really have that many phones and NOT have it be user error at some point. PEBKAC!
    11-07-09 08:08 AM
LINK TO POST COPIED TO CLIPBOARD