1. kbushnaq's Avatar
    I have a BB storm from Verizon I have unlocked it to use it during my stay in Canada and I now I have a Fido chip in it. Yesterday my BB was perfectly fine until the screen stopped responding ! It is still working fine, I get phone calls, the call menu and end buttons are active and my alarm is working on time however the screen is not responding what so ever. I downloaded the new OS 5.0 and checked water damage but nothing. Anyone knows what on earth is going on ? Any help ?
    11-07-09 09:43 AM
  2. lastraid's Avatar
    Did you try a battery reset? pull battery with the device turned on.
    11-07-09 09:57 AM
  3. IDsweetcheeks's Avatar
    If that doesnt work it was probobly a hardware failure. Might also want to try a low level install of the s/w just in case cause I know the it has something to do with the touch screen sometimes.
    11-07-09 10:06 AM
  4. kbushnaq's Avatar
    what do u mean by a low level install of the s/w ?
    11-07-09 12:24 PM
  5. bluerskyes's Avatar
    This should be on the Storm boards.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-07-09 02:13 PM
  6. IDsweetcheeks's Avatar
    yep... you can do it w/ desktop manager... old s/w should still be archived there.
    11-07-09 03:36 PM
  7. GidgetGadget's Avatar
    Call customer service and they'll ship out a warranty replacement.
    11-08-09 12:07 AM
  8. IDsweetcheeks's Avatar
    They'll want to try the low level install first... its a required t/s step enless you get a lazy rep.
    Sides its not as easy as just "shipping out a replacement"
    If it DOES have something to do with software.. ( highly doubt it but we need to rule it out )
    The customer will be charged for the replacement full retail. NO bueno!
    11-08-09 09:23 AM
LINK TO POST COPIED TO CLIPBOARD