1. drkildrum's Avatar
    Howdy
    My headphone jack stopped working on my curve, worked fine yesturday, did a batt. Pull 2x and still nothing, is there a setting I may have hit? Or is it just done?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-09 09:19 AM
  2. lastraid's Avatar
    Try running the jack plug though port 3-4 quickly to see if this helps. the little spring like parts in side wear over time.
    04-10-09 09:51 AM
  3. drkildrum's Avatar
    Is this jack sotterd or is it a plug?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-09 10:29 AM
  4. lastraid's Avatar
    I am not 100% sure of this. Look in 8330 forum for tutorials that vtsang started. vtsang is going to write instructions on how to replace the jack. you want to PM and he might be able to help further.
    04-10-09 10:32 AM
  5. TwinsX2Dad's Avatar
    All BlackBerry jacks are soldered to the main board. The area is tight and difficult to do even if you're expert with an iron as the pads are small & hard to reach. If you do try it yourself, staying as far below 25W as possible, using heat sinks is recommended as the area isn't tolerant to a lot of heat.

    Never jiggle headphone or charger/data plugs on these things. Pretty much the only thing holding them to the board is the solder points. Gentle pulls & pushes are best. I even treat mine to an occasional dielectric lubrication.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-10-09 02:03 PM
LINK TO POST COPIED TO CLIPBOARD