02-16-10 07:54 AM
31 12
tools
  1. dancingcrab's Avatar
    Follow-up:

    Miraculously, my BIS started working this morning at about 530AM. I had about 28 messages pushed at once. I registered my handset and did the #22890 thing again, and my browser suddenly appeared.

    I called VZW to discuss getting a credit for the week's worth of absent data coverage, plus replacing the handset yet again because of the click issue. The first representative wouldn't credit me, but the tech guy did after I explained the problem for the nth time. Alledgedly my account shows data usage occurring, so I had to fight my case because I definitely hadn't had access to push email or browsing capabilities.

    I still love the concept of the Storm2, so I'm going to give a fourth one a go (I do not have much choice, as discussed above). If this one has, or develops, the screen issue that the previous ones have suffered, I will attempt to let VZW know how unhappy I am once more. Fingers crossed the replacement will be great.
    02-06-10 04:31 PM
  2. markhunsaker's Avatar
    Sorry man, sounds like you're having crappy phones, (I won't mention user error...), I am on my first and loving it still. No issues.
    02-06-10 09:52 PM
  3. dancingcrab's Avatar
    Sorry man, sounds like you're having crappy phones, (I won't mention user error...), I am on my first and loving it still. No issues.
    What user error might you refer to?
    02-07-10 12:08 PM
  4. dancingcrab's Avatar
    It won't happen at all.
    Update:

    After my fifth Storm2, VZW has quite happily swapped it for a Droid at no cost to me. I'll be receiving it on Wednesday.

    Thank you VZW!
    02-15-10 06:23 PM
  5. Super_Mario's Avatar
    Update:

    After my fifth Storm2, VZW has quite happily swapped it for a Droid at no cost to me. I'll be receiving it on Wednesday.

    Thank you VZW!
    So what happened with the Storm that was just sent to you?
    02-15-10 10:46 PM
  6. dancingcrab's Avatar
    So what happened with the Storm that was just sent to you?
    We didn't even activate it. The send/end keys would still stick when flat on my desk, and the left side of the screen was very hard to push. When looking sidewards at it, you could see that the left side was almost 2mm below the edge of the handset, whilst the right was virtually flush.

    I suggested to a rep that I be sent a model other than one labelled 'Mexico 5' (which all five have been), but she said that they couldn't control that. She tried to mix it up by getting this last device from a CA warehouse rather than somewhere around here (ATL).

    All in all, despite having to talk with many different reps, I'm very happy with VZW. I understand that exchanging a device for another model is not regular policy, and I feel they went out of their way for me on this one, and it's greatly appreciated.
    Last edited by dancingcrab; 02-16-10 at 07:56 AM.
    02-16-10 07:54 AM
31 12
LINK TO POST COPIED TO CLIPBOARD