03-14-15 11:15 AM
100 1234
tools
  1. jelp2's Avatar
    Compass has never been accurate on my STL100-4. Furthermore, apps that use it don't match. Meaning Startracker will think east is north while the compass itself points due south.

    Posted via CB10
    Yea, that's one of my paid apps too that's useless now. ARKick is another one that I cant use!!
    03-22-14 09:52 AM
  2. MMDDZZ's Avatar
    Yup I've had this issue since update before the current one: Z10STL100-4/10.2.1.2174
    On VZW.


    MDZ
    03-22-14 10:04 AM
  3. AnimalPak200's Avatar
    I imagine the STL 100-4 probably has slightly different component placement due to CDMA hardware that causes this interference. Remember when they had that wide-spread sensor issue they chalked up to corrupted calibration data being pushed to the devices? I wonder if it's just a matter of them pushing out different calibration data for the 100-4 compass.

    Posted via CB10
    03-22-14 10:10 AM
  4. bobshine's Avatar
    Is it mostly the verizon model that is having problems? My my STL-003 bad been pretty much bang on with the compass. Star trekker had been really precise.



    Posted via CB10
    03-22-14 10:19 AM
  5. Dave Bourque's Avatar
    I imagine the STL 100-4 probably has slightly different component placement due to CDMA hardware that causes this interference. Remember when they had that wide-spread sensor issue they chalked up to corrupted calibration data being pushed to the devices? I wonder if it's just a matter of them pushing out different calibration data for the 100-4 compass.

    Posted via CB10
    But if BlackBerry doesn't know about the issue because nobody reports it to them. How is this going to be resolved.

    Z10STL100-3/10.2.1.2141
    03-22-14 11:34 AM
  6. jelp2's Avatar
    But if BlackBerry doesn't know about the issue because nobody reports it to them. How is this going to be resolved.

    Z10STL100-3/10.2.1.2141
    I've lost count how many times I've emailed BBRY through the Help app, Feedback from BBWorld, Tweeted. I don't know who reads the emails etc. or if the comments get moved along to programmers etc.?. That's why I was hoping to get as much feedback as possible in this thread and maybe use it as a little evidence to try to send to VZ or BBRY.
    I should have put a poll at the beginning of this thread to see some actual numbers.
    Dave Bourque likes this.
    03-22-14 12:13 PM
  7. Slamminsammy90's Avatar
    It works well, if your not in an area which a lot of tall buildings (Times Square, NYC), otherwise it works fine for me.
    03-22-14 08:08 PM
  8. Fret Madden's Avatar
    But if BlackBerry doesn't know about the issue because nobody reports it to them. How is this going to be resolved.

    Z10STL100-3/10.2.1.2141
    I've reported it via the on-device help utility but who knows how far that will go.
    03-22-14 08:43 PM
  9. Fret Madden's Avatar
    It works well, if your not in an area which a lot of tall buildings (Times Square, NYC), otherwise it works fine for me.
    I live so far away from tall buildings there's fields on the other side of the land being developed. In my case at least it's definitely the device (STL100-4).
    jelp2 likes this.
    03-22-14 08:50 PM
  10. AnimalPak200's Avatar
    It works well, if your not in an area which a lot of tall buildings (Times Square, NYC), otherwise it works fine for me.
    I live in a relatively rural area... no street lights, etc. And the Compass is a disaster.

    Posted via CB10
    03-22-14 09:05 PM
  11. jelp2's Avatar
    It works well, if your not in an area which a lot of tall buildings (Times Square, NYC), otherwise it works fine for me.
    It seems to be related solely to STL100-4. You have a Q10 listed as your device. Others with Q10 also reported no issue.
    03-23-14 01:21 AM
  12. jelp2's Avatar
    Is it mostly the verizon model that is having problems? My my STL-003 bad been pretty much bang on with the compass. Star trekker had been really precise.



    Posted via CB10
    It seems to be coming down to Verizon Z10s. VZ Q10's are not reporting any problems.
    03-23-14 06:01 PM
  13. jelp2's Avatar
    I got a reply from a Tweet I sent to @BlackBerryHelp, nothing special, but maybe if more people Tweet them they will look deeper into the issue??


    Compass issue....still!!-img_20140324_090243.png
    03-24-14 08:16 AM
  14. Dave Bourque's Avatar
    I got a reply from a Tweet I sent to @BlackBerryHelp, nothing special, but maybe if more people Tweet them they will look deeper into the issue??


    Click image for larger version. 

Name:	IMG_20140324_090243.png 
Views:	285 
Size:	107.8 KB 
ID:	257852
    If not enough people demand a fix there is definitely going to be less resources put into it. Give them as much detail as possible model number OS carrier, etc.

    Z10STL100-3/10.2.1.2141
    03-24-14 11:48 AM
  15. Fret Madden's Avatar
    I got a reply from a Tweet I sent to @BlackBerryHelp, nothing special, but maybe if more people Tweet them they will look deeper into the issue??


    Click image for larger version. 

Name:	IMG_20140324_090243.png 
Views:	285 
Size:	107.8 KB 
ID:	257852
    If not enough people demand a fix there is definitely going to be less resources put into it. Give them as much detail as possible model number OS carrier, etc.

    Z10STL100-3/10.2.1.2141
    It definitely won't go anywhere if they think the problem lies with software or OS version. Somehow they need to be made aware it's the hardware of the STL100-4, and I also don't see that going anywhere because, well, it's hardware. BlackBerry (then RIM) silently updated whatever was making the 9550 screens stiff and/or outright malfunction 4 years ago; we had to go through carriers to get them though, some people had to do it repeatedly to get the new ones because the carriers and insurance companies didn't know plus had no control over what was sent out as they were all refurbished. So it may be that BlackBerry could fix the problem but they won't be making new ones - they'll need to have all returned STL100-4 models shipped to them, fixed, and slipped back into inventory. Then we report problems with the handset, and if insurance is carried, get a refurbished device sent out that hopefully has the upgrade. I really don't feel like repeating that; if it's a problem with CDMA radios that would explain why my 9930 had problems locking on as well and that tells me they just can't do it.
    03-24-14 02:19 PM
  16. jelp2's Avatar
    It definitely won't go anywhere if they think the problem lies with software or OS version. Somehow they need to be made aware it's the hardware of the STL100-4, and I also don't see that going anywhere because, well, it's hardware. BlackBerry (then RIM) silently updated whatever was making the 9550 screens stiff and/or outright malfunction 4 years ago; we had to go through carriers to get them though, some people had to do it repeatedly to get the new ones because the carriers and insurance companies didn't know plus had no control over what was sent out as they were all refurbished. So it may be that BlackBerry could fix the problem but they won't be making new ones - they'll need to have all returned STL100-4 models shipped to them, fixed, and slipped back into inventory. Then we report problems with the handset, and if insurance is carried, get a refurbished device sent out that hopefully has the upgrade. I really don't feel like repeating that; if it's a problem with CDMA radios that would explain why my 9930 had problems locking on as well and that tells me they just can't do it.
    I'm not quite sure it is hardware. It used to work when I first got the phone. After the updates it all went goofy. I've had two replacements and not until the second one did I think I'd trying the compass before updating. It worked!! After the update, it was broke again.
    03-24-14 04:55 PM
  17. Dave Bourque's Avatar
    I'm not quite sure it is hardware. It used to work when I first got the phone. After the updates it all went goofy. I've had two replacements and not until the second one did I think I'd trying the compass before updating. It worked!! After the update, it was broke again.
    It almost seems like the radio software is breaking it.

    Z10STL100-3/10.2.1.2141
    03-24-14 06:30 PM
  18. jelp2's Avatar
    It almost seems like the radio software is breaking it.

    Z10STL100-3/10.2.1.2141
    I don't know what's included in the radio file, but that is a great thought! I never thought of that. I wish I knew what radio I had back in May or June of 2013 and try to load it. If it would work with the new OS.
    03-24-14 07:04 PM
  19. LibertarianFreethinker's Avatar
    It almost seems like the radio software is breaking it.

    Z10STL100-3/10.2.1.2141
    My thoughts exactly!

    Posted via CB10
    03-24-14 11:04 PM
  20. jelp2's Avatar
    @BlackBerryHelp sent another message asking for my PIN. So maybe it will move along. Hopefully more people will tweet them and they will get this straightened out. It's a quest now!
    03-25-14 02:42 PM
  21. jelp2's Avatar
    So, after several hours on the phone with BB Tech, we created and sent log file to BBRY so they can officially escalate the issue. Let's wait and see.
    04-02-14 02:03 PM
  22. LibertarianFreethinker's Avatar
    Well, at least BlackBerry knows about the issue now. Let's see if they actually release an update for the compass.

    Posted via CB10
    04-03-14 12:25 AM
  23. jelp2's Avatar
    Yea let's see. Who knows, maybe the amount of VZW Z10 owners is too low for them to worry about it? I hope not. I did reference this thread to them when we spoke, so any others who have the issue should post here.
    Last edited by jelp2; 04-06-14 at 11:00 AM.
    04-06-14 09:49 AM
  24. MMDDZZ's Avatar
    I'm on Z10STL100-4/10.2.1.2174 and have had this problem since the first os upgrade. Original os, compass worked fine. First and subsequent upgrades - compass and most apps that use compass (star tracker) are useless due to random and incorrect compass readings.

    MDZ
    04-06-14 10:17 AM
  25. kbz1960's Avatar
    I have a Z30. How do you check how accurate it is?
    04-06-14 10:48 AM
100 1234

Similar Threads

  1. Spotify login issue
    By Oscar Petlund in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 03-22-14, 06:12 PM
  2. Moved from Z10 to Z30 Having Issues with Snap
    By walabe16 in forum BlackBerry Z30
    Replies: 10
    Last Post: 03-21-14, 05:28 AM
  3. WiFi issues with 2228
    By kfehling in forum BlackBerry Z30
    Replies: 17
    Last Post: 03-20-14, 11:34 PM
  4. Weird. Installed 2102 but still shows 1925
    By prplhze2000 in forum BlackBerry Z10
    Replies: 13
    Last Post: 03-20-14, 07:01 PM
  5. Issues backing up videos, all I see is green
    By Runs_With_Scissors in forum BlackBerry Q10
    Replies: 5
    Last Post: 03-20-14, 05:40 PM
LINK TO POST COPIED TO CLIPBOARD