1. M.J.H.'s Avatar
    If so, what link did you use to download the application to your Curve?

    I have tried and tried and tried and I had it on my Pearl with no issues.
    05-08-08 01:41 PM
  2. briankeith513's Avatar
    If so, what link did you use to download the application to your Curve?

    I have tried and tried and tried and I had it on my Pearl with no issues.

    http://solutions.vzwshop.com/vzstart/bb/

    Try that link from your blackberry's browser. It is the one for the 8830, and works perfectly. you can use it until VZ Nav is available for the Curve 8330.
    05-08-08 02:53 PM
  3. jpw16's Avatar
    thks. It worked.
    05-08-08 07:03 PM
  4. davesax36's Avatar
    so I put in that address, scrolled down to VZ Navigator and downloaded it. It seems to be the one for the Pearl... at least that's what I'm guessing because it had soft key shortcuts, displays in a "pearl-sized" restricted window and none of my keys lined up with what they should have been. Is there a step I'm missing?

    I even went back to the 8830 "get applications" thing and it wasn't even able to find navigator with a search. i really want to try it out a bit (since I already have it and am paying for it from my regular phone bill) to decide whether I get a GPS puck or not. thanks from a BB newbie
    05-08-08 11:17 PM
  5. overmydeadberry's Avatar
    Yup its the one for the pearl

    Posted from my CrackBerry at wapforums.crackberry.com
    05-10-08 01:32 AM
  6. davesax36's Avatar
    if you put bb8830 at the end instead of just bb, it will work. i redowned it tonight from

    http:// solutions.vzwshop.com /vzstart/ bb8830 (take out the spaces--I stole this from another posting)

    and it seems to work. Only thing I can't figure out now is why it can see the canadian street that I want to map to, but can't search for it.
    05-10-08 01:38 AM
  7. briankeith513's Avatar
    Hopefully the 8330's version will be out shortly.
    05-10-08 11:29 AM
  8. overmydeadberry's Avatar
    Hey well its up and running now... Saw it on the start page downloaded and is working.... Best of luck2 da rest of yall

    Posted from my CrackBerry at wapforums.crackberry.com
    05-12-08 12:11 AM
LINK TO POST COPIED TO CLIPBOARD