View Poll Results: Was this article helpful?

Voters
74. You may not vote on this poll
  • Yes

    52 70.27%
  • No

    11 14.86%
  • Sort of

    11 14.86%
12-27-13 12:16 PM
77 123 ...
tools
  1. 3CISSBB's Avatar
    ****UPDATE 7/17/2009****


    After seeing so many people posting UMA questions and problems I figured it was time to create a how-to thread explaining the setup.

    These settings are for newer Linksys routers. I hope this revision helps. I am not planning on any tutorials for any other brand of router since I only use Linksys and would only recommend them. I have used Linksys for over 15 years and have never had any problems and if it ain't broke...don't fix it.

    So here it goes.
    • Port Range Forwarding needs to be enabled to allow port 4101 (to and from) for both TCP and UDP and QoS should also be enabled to allow for high or highest priority to your Curve's MAC address. See example below:

    Port Range Forwarding




    QoS




    **Also, as seen in the example above, if your router has a 'WMM' option (Wi-Fi MultiMedia), enable it as well. This helps your router determine which network traffic takes priority.

    The HotSpot@Home service relies on the IPSec security protocol to provide secure calling over Wi-Fi. T-Mobile-branded wireless routers are configured to permit IPSec communications by default, but other devices can / may be configured to block IPSec. The firewall policy on your router may have been configured (intentionally or otherwise) to prevent IPSec communications.
    In order for IPSec to work, the following ports need to be allowed through the firewall in both directions:
    (Note: these only need to be configured manually if you do not have the IPSec Passthrough option on your router)
    • UDP port 500 (Internet Key Exchange or IKE)
    • UDP port 4500 (IPSec/IKE NAT-T)
    Many consumer-grade routers, including the T-Mobile branded Wi-Fi router, include a simple check-box that will enable IPSec communications. This option is typically named Enable IPSec passthrough or something similar.

    IPSec

    • Next you need to configure the Blackberry Device Manager. You can find this by right clicking on 'Blackberry Device Manager' which should be located next to the DM icon in your system tray. Choose 'Properties' then go to the 'Blackberry Router Configuration', click 'Add Router' and type in as shown in the example below.
    • Last, if there is more than one access point or wireless router and your phone can pick up more than one signal, it may be constantly trying to switch between them. You should go into your Wi-Fi options and UNCHECK allow inter-access point handover.



    Following these settings should provide you with the 'seemless' UMA calling as advertised. I have been using these settings since the 8320 was released along with my 8900 and I have never experienced any UMA calling problems.

    Some of you may be questioning where I came up with port numbers mentioned in the post. They came from an extensive knowledge of ports and protocols and network engineering experience.

    **Explanation about Port 4101**

    The port number 4101 is identified with the execution of the BlackBerry Enterprise Server (BES) used by the mobile device to communicate with the users computer. This software is used for synchronization of data between the two devices. It also allows the user to perform various functions such as emailing and management of contacts, folders and calendars.

    NewOak, prior to its acquisition by Bay Networks, has also been identified to utilize this network communication port in relation to its VPN (Virtual Private Networking) implementation.
    This system was in place before the VPN products of NewOak that catered to the IPSec connections.

    Port 4101 is still utilized by Blackberry devices for certain data protocols and therefor I still implement it on my network. The settings that I use may or may not work for every user but as a network professional, I find all the settings used have provided me with flawless UMA since T-Mo rolled out the service. I make no guarantees or promises, I simply provide advice (free of charge mind you).

    ****UPDATE 7/17/2009****

    I am adding some screen shots from a newer Linksys router (WRT310N) since there have been some questions about the Blackberry and 'N' routers. In most of the newer Linksys routers, you have an option to allocate an IP address for certain device MAC addresses on the network once connected. You should set one up for your BB so that acquiring an IP address will be smooth when Wi-Fi is turned on.

    Here is the first example:



    Next is the Basic wireless section. Here is where you'll select G-only for the network mode:



    Next is the wireless security. In orer for the Blackberry to operate correctly and securely, the best method of encryption is AES (Advanced Encryption Standard). I use WPA2 Personal on my network:



    Last is the QoS section. The newer Linksys routers have several new settings that older models do not. You can now specify specific MAC address for bandwidth allocation. Your BB MAC can be found under

    Option --> Status --> WLAN MAC





    One other thing you can do if you experience interference or calls dropping is to change the broadcast channel on your router. Most are set to six (6) by default but you can change that and try 11, or any other channel.

    Last edited by 3CISSBB; 10-09-09 at 12:37 PM.
    bbman93 likes this.
    04-14-09 09:55 AM
  2. aristile's Avatar
    Thanks for the guide! Maybe you can get with bmcclure937 and add this to the WiFi Guide that is already in place:

    http://forums.crackberry.com/f65/com...wifi-how-47229
    04-14-09 10:41 AM
  3. CeluGeek's Avatar
    I guess this will help those who only use one BlackBerry as their UMA device. I rather leave my router settings untouched, until I can find a more device-agnostic guide. I don't know how the proposed changes will affect UMA access on the T-Mobile Shadow, in addition to the fact that in my household we have 2 phones connected to UMA at the same time.
    04-14-09 11:29 AM
  4. ClintRo's Avatar
    You can set the phones up as 1 and 2 in priority... but if it is running well, I don't know why you would change your settings.
    04-14-09 11:31 AM
  5. dzl03's Avatar
    Thanks for the guide. I've been having UMA problems since I upgraded to .199 but then again I called my ISP and they tested my line and said my router is defective. They sent me a new one and ill see if its better. If not I'm definately gonna use this guide! Thx again

    Posted from my CrackBerry at wapforums.crackberry.com
    04-23-09 12:23 PM
  6. ryan7977's Avatar
    i have to admit, i'm not sure why this guide even exists. you can just connect to the router on the curve, and UMA works. what is this for exactly?
    04-23-09 12:26 PM
  7. cheezz's Avatar
    i have to admit, i'm not sure why this guide even exists. you can just connect to the router on the curve, and UMA works. what is this for exactly?
    For those not in the know! Otherwise there won't be questions about UMA in these forums.
    04-23-09 01:27 PM
  8. ryan7977's Avatar
    For those not in the know! Otherwise there won't be questions about UMA in these forums.
    understood...however, all of the router config. it's unnecessary.
    04-23-09 02:28 PM
  9. ClintRo's Avatar
    On the T-mobile routers... maybe, sometimes settings get changed and will not work with UMA. Hence this guide!!
    04-23-09 02:31 PM
  10. thebignewt's Avatar
    Then I'm glad I don't have the Tmob router if I have to worry about/setup all that stuff. To use UMA all I had to do was turn on the phone (and type in the little code if the router was locked). No ports for me!
    04-23-09 03:03 PM
  11. ClintRo's Avatar
    the T-mo router is configured properly.....Some routers out of the box work well also.....Others not so much, or maybe have been reconfigured at some point and don't work well....but it is asinine to think because you didn't have any issues no one does....
    04-23-09 03:08 PM
  12. earhog's Avatar
    Has anyone noticed during calls on UMA there will be skips in the connection.. Like ill be talking to someone and there will be random blips of silence... I've noticed this on .114 and .204
    ogmike likes this.
    04-23-09 05:13 PM
  13. charliec#CB's Avatar
    Wow.......................

    You sure is smart ...
    04-23-09 05:15 PM
  14. 3CISSBB's Avatar
    Well, I prepared this guide for those people who seem to have UMA problems. As stated; not everyone has problems (like me), but I seem to come here often and see thread after thread concerning issues so I made this guide to assist members who were having/experiencing difficulties.

    The settings shown are using a Linksys router so they will be referred to differently depending on your brand, but most are universal settings that can be found within the menus of your device setup.

    These settings and ports listed are the result of extensive searching and knowledge from years of networking experience and have proved to work 'flawlessly' with my 8320 as well as my 8900.

    This guide was listed in the 8900 forum because that is what it is put together for, not a sidekick or any other device. I don't know about other devices and haven't made claim to. Hence why it is posted here.

    I hope this helps those who are experiencing problems. To those it has helped I am happy. To those it hasn't helped, my apologies.
    04-23-09 06:09 PM
  15. ryan7977's Avatar
    here is what i'm saying. out of the box, if you connect the wifi phone to your wireless router...UMA connects by default, and works. if it for some reason doesn't work, 99 percent of the time, it's not the router so much as it may be a phone issue, or an internet issue. but you don't have to configure the router to get UMA working whatsoever. so rather than a guide that shows you how to configure a router...perhaps a guide on how to connect to the router using the phone? and apologies are not needed...i see what your doing there, but this is not about apologies...just some constructive criticism.
    04-24-09 07:16 AM
  16. ClintRo's Avatar
    here is what i'm saying. out of the box, if you connect the wifi phone to your wireless router...UMA connects by default, and works. if it for some reason doesn't work, 99 percent of the time, it's not the router so much as it may be a phone issue, or an internet issue. but you don't have to configure the router to get UMA working whatsoever. so rather than a guide that shows you how to configure a router...perhaps a guide on how to connect to the router using the phone? and apologies are not needed...i see what your doing there, but this is not about apologies...just some constructive criticism.
    This IMO is not necessarily correct..... when UMA connects to one hotspot perfectly and another like crap.... more than likely it is the router and not the phone.
    04-24-09 07:18 AM
  17. ryan7977's Avatar
    how is that even possible? let's say on that same very router, all of your home computers are connected to the internet just fine. now your phone is not connecting normally...well then how is that a router issue? i mean, if i am wrong, and someone can validate their point....then i'll stand corrected, and even learn something in the process.
    04-24-09 07:30 AM
  18. ClintRo's Avatar
    I can assure you it is possible and does happen..... when I am at a friends house with open access or at Starbucks I have no issues with UMA, but at home I do. (I have a great EDGE signal at home and just have not had the time to set it up properly, spend to much time making video reviews for people here...LOL)


    Part of the issue has to do with priority....If your laptop is set to have top priority on the network, then the phone will get the leftover scraps of bandwidth, UMA is a very data sensitive function, and the leftovers are not enough for a steady signal.

    There are other pieces of the puzzle...that I don't nor want to type up right now..some routers come out of the box optimized for it, that is why some, like yourself, just plug and play.
    04-24-09 07:38 AM
  19. ryan7977's Avatar
    I can assure you it is possible and does happen..... when I am at a friends house with open access or at Starbucks I have no issues with UMA, but at home I do. (I have a great EDGE signal at home and just have not had the time to set it up properly, spend to much time making video reviews for people here...LOL)


    Part of the issue has to do with priority....If your laptop is set to have top priority on the network, then the phone will get the leftover scraps of bandwidth, UMA is a very data sensitive function, and the leftovers are not enough for a steady signal.

    There are other pieces of the puzzle...that I don't nor want to type up right now..some routers come out of the box optimized for it, that is why some, like yourself, just plug and play.
    ok, fair enough. i'll consider myself corrected. i may even look at my router when i get home today to just poke around
    04-24-09 07:45 AM
  20. ClintRo's Avatar
    why?!?!?!?!

    If it aint broke......
    04-24-09 07:47 AM
  21. ryan7977's Avatar
    why?!?!?!?!

    If it aint broke......
    can't hurt to take a look
    04-24-09 08:03 AM
  22. ClintRo's Avatar
    You say that now.....

    hahahahaha....
    04-24-09 08:04 AM
  23. shadysprings's Avatar
    here is what i'm saying. out of the box, if you connect the wifi phone to your wireless router...UMA connects by default, and works. if it for some reason doesn't work, 99 percent of the time, it's not the router so much as it may be a phone issue, or an internet issue. but you don't have to configure the router to get UMA working whatsoever. so rather than a guide that shows you how to configure a router...perhaps a guide on how to connect to the router using the phone? and apologies are not needed...i see what your doing there, but this is not about apologies...just some constructive criticism.
    Not 99% of the time. I have a brand new 8900 that I started testing with. I've tried in over 20 locations and about half work "out of the box" and the other half it doesn't.
    So far, Netgear and Linksys seem to not work, and cheap-o routers and Dlink do work.
    I'll go back and start documenting model#'s and settings.
    So far, I am not finding any pattern or logic behind which wireless routers work or don't work. And the only router that work in everycase is the junky one that Verizon DSL uses.
    04-25-09 04:04 AM
  24. Daz_Mann's Avatar
    my netgear doesn't really like working with uma looks like a new router for me now
    04-25-09 06:48 AM
  25. ryan7977's Avatar
    And the only router that work in everycase is the junky one that Verizon DSL uses.
    which is the one i have..good call
    04-25-09 10:33 AM
77 123 ...
LINK TO POST COPIED TO CLIPBOARD