1. jelp2's Avatar
    I just recently noticed that BlackBerry Maps or any app I have that use gps will not locate gps satellites. I'm sure it worked before. I'm running 10.3.1 and of course TMO and BlackBerry reps both tell me to downgrade to an official release. Is anyone else on 10.3.1 and maps work? I have a Z10.
    12-30-14 05:02 PM
  2. Drew Oswalt's Avatar
    I'm fine. Used BlackBerry maps today. Running 10.3.1.1151 on a Z10 on tmobile.

    Posted from my Z10 running on 10.3.1
    jelp2 likes this.
    12-30-14 09:08 PM
  3. jelp2's Avatar
    I'm fine. Used BlackBerry maps today. Running 10.3.1.1151 on a Z10 on tmobile.

    Posted from my Z10 running on 10.3.1
    Thanks for the reply. I knew I wasn't going goofy! I thought maybe I needed a sim card refresh (new to sim cards since coming from VZ) but they told me on the phone that since I'm not having any problems with data there's no reason to refresh. I guess I'll try reloading my OS.
    12-31-14 12:13 PM
  4. TheQuietRioter's Avatar
    No!! I have this problem too!!! And I am not on 10.3.

    My phone detection of locations through GPS via maps is horrid.


    Posted via CB10
    01-02-15 07:02 AM
  5. MADBRADNYC's Avatar
    Works fine for me on both my T-Mobile Z10 and Q10. Both unlocked by them and running their latest official Z10STL100-3/10.2.1.2228.

    Posted via CB10
    01-02-15 07:22 AM
  6. andreirad's Avatar
    I don't have any problems. I'm on Verizon using the newest leak 10.3.1.1949 . Worked well for me on any other OS I used before. Did you try to reboot your phone?

    Visit my BBM Channel - C000E96F6
    01-02-15 07:26 AM
  7. bbmtna's Avatar
    Hey guys,
    Give your phone a reboot. I've had this happen on all three of my bb10 devices since launch. I use maps daily (mon-fri) and every now and then this happens.

    A standard reboot gets it going again.

    Posted via CB10
    01-02-15 07:40 AM
  8. grumpyaeroguy's Avatar
    Mine seems ok. I agree with previous posters---maps goes bezerk every so often. A reboot every now and then seems to bring everything back to normal.
    01-03-15 03:41 PM
  9. jelp2's Avatar
    Unfortunately, its beyond a reboot for me. I've wiped and reloaded various OS's over the past few days to no avail.
    01-03-15 06:21 PM
  10. Drew Oswalt's Avatar
    Uninstall, reboot, reinstall and allow all permissions.

    Posted from my Z10 running on 10.3.1
    01-03-15 11:12 PM
  11. bbmtna's Avatar
    You've mentioned all apps that require the usage of GPS. Can't the Blackberry Virtual Assistant diagnose this?

    Posted via CB10
    01-04-15 10:18 AM
  12. jelp2's Avatar
    Sensors tests come back unavailable for gyroscope, accelerometer and magnetometer.
    01-04-15 08:41 PM
  13. jelp2's Avatar
    Turned out to be a hardware issue. Got another Z10 today, and everything works great on it!! Back in action!
    01-05-15 07:24 PM
  14. bbmtna's Avatar
    Good to hear! Thanks for the update!

    Posted via CB10
    jelp2 likes this.
    01-05-15 08:14 PM
  15. TheQuietRioter's Avatar
    Unfortunately, its beyond a reboot for me. I've wiped and reloaded various OS's over the past few days to no avail.
    Same here....GPS just doesn't work. Reboots, uninstall/reinstall....does not work. Don't know if its the phone or something to do with TMobile.

    I always get a prompt telling me my location cannot be detected.
    Maps are useless on my Z30. I have tried 3rd party map apps too and still a failure.

    Posted via CB10
    01-07-15 12:02 PM
  16. raino's Avatar
    T-Mobile, 10.2.1...3062 on an unlocked Q10. I'm having trouble with Maps as well. GPS lock is late, and location search is not working.

    "Problem communicating with the server. Try again later (2001.)"

    "My Places content is currently unavailable."
    01-07-15 07:40 PM
  17. scrannel's Avatar
    Hey Raino, running same OS as you, but on Z10. No issues with Maps. Search works, my places, etc.
    01-08-15 10:52 AM
  18. raino's Avatar
    Hey Raino, running same OS as you, but on Z10. No issues with Maps. Search works, my places, etc.
    Thanks. Just tried again, and it's fine now.

    I thought being indoors might have had something to do with the delayed GPS lock, but that wouldn't have explained the delay in finding an address. I'm sitting in the same spot now, and both things (GPS lock and locating that same address) happened instantly. I too will keep an eye on it.
    01-08-15 12:44 PM

Similar Threads

  1. How do I get OneDrive to auto upload photos?
    By junxs in forum Android Apps (Amazon Store & APK Files)
    Replies: 8
    Last Post: 03-29-15, 09:07 PM
  2. Does PokerStars Work on the BlackBerry classic?
    By sixpounder in forum BlackBerry Classic
    Replies: 2
    Last Post: 01-04-15, 12:13 AM
  3. Issue with end button not turning phone on
    By transportin in forum BlackBerry Classic
    Replies: 20
    Last Post: 12-30-14, 11:29 PM
  4. BlackBerry Knowledge Base explains the removal of Adobe Flash from OS 10.3.1
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 12-30-14, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD