1. gobroncos's Avatar
    Um my phone is F'ing up big time, the screen will now never go black meaning it's always on and always running down my battery, it's a big and very annoying issue. .83 is a terrible upgrade, my phone was awesome before this. I cannot downgrade, not my computer nor desktop manager recognize my blackberry, I can't change anything it also...

    *It freezes a lot, it never has once before.

    *it locks up, if I lock the phone half the time it wont unlock at all, hello battery pull

    *I constantly get sim card error messages

    *My buttons change sizes on my qwerty keyboard

    * turn it on and it goes the Verizon screen with black and it just stays their til a battery pull, if I touch a button it goes to the home screen but right back to the verizon screen instantly.

    *It somehow lost my internet password and told me it was invalid when it wasn't ever even changed...

    Please please please just tell me how to get it downgraded because I'm extremely annoyed!!
    12-24-08 12:26 AM
  2. cmgeek's Avatar
    uninstalled .83 off your machine. Make sure .75 is installed. Walk through the same thing you did to upgrade. Or just wipe the device and install .75 from scratch which works much better.
    12-24-08 12:29 AM
  3. jkunk's Avatar
    same as above, wipe ur phone, uninstall all blackberry crap from control panel add/delete, install 4.7 DM from blackberry.com, install .75 OS from verizon, hook phone back up is what i did
    12-24-08 12:31 AM
  4. thedannelson's Avatar
    First, pull the memory card out and then do a battery pull (keep the memory card out during this whole process).

    Once the phone had booted up properly (It will without the memory card in it) you should be able to connect it to the computer and DM will recognize it.

    Then you can go to Application Loader and select the old OS to load.

    Let me know how it goes
    12-24-08 12:32 AM
  5. Roll3r's Avatar
    If you eventually do get your PC to recognize it, It whack the OS with jl_commander to ensure that nothing from .83 is hiding around in memory.
    12-24-08 12:46 AM
  6. gobroncos's Avatar
    ok thank you guys, this is driving me nuts!! I had to pull the battery just to get the damn thing to turn off, the power button wouldn't work
    12-24-08 01:59 AM
  7. cowens677's Avatar
    Mine did the same thing as yours.... I had to reinstall .83 and it worked for a while. But when I went to charge it in the evening it froze and the screen went to snow. That is when I went back to .75; but the browser, when it worked on .83, was definitely an improved version. I really hope they fix the bugs and get the update out soon.
    12-24-08 02:17 AM
  8. Jaysus Cutler6's Avatar
    Glad I didn't update. I'll gladly wait for the official release.
    12-24-08 03:06 AM
  9. BuckChoklit's Avatar
    mine works great. i say give it a few days
    12-24-08 03:18 AM
  10. cray1000's Avatar
    Is it possible the keys changing size on the keyboard is something new rim is testing to help typing on the device?

    I hope so the landscape keyboard is worthless for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-24-08 03:21 AM
  11. gobroncos's Avatar
    Ok I'm back, I waited til this morning to do it because I was annoyed last night, thanks for all the insight but none of it worked, pulling the memory card and rebooting didn't get my computer to recognize it, I can't JL Wipe it, nothing happens when I try (probably because my computer wont recognize) I'm at a loss for words right now, this phone is almost unusable and getting steadily worse.
    12-24-08 11:03 AM
  12. StormTrooperVZW's Avatar
    Ok I'm back, I waited til this morning to do it because I was annoyed last night, thanks for all the insight but none of it worked, pulling the memory card and rebooting didn't get my computer to recognize it, I can't JL Wipe it, nothing happens when I try (probably because my computer wont recognize) I'm at a loss for words right now, this phone is almost unusable and getting steadily worse.

    The same thing happened to me.. delete the upgraded OS from your add/remove programs on your PC, then restart everything.

    Your BB Desktop should detect the device now and want to downgrade it on the next sync.
    12-24-08 11:21 AM
  13. neolantis's Avatar
    Glad I didn't update. I'll gladly wait for the official release.
    official will be no different if it's .83...if you want to wait, wait for the next higher version #
    12-24-08 11:27 AM
  14. gobroncos's Avatar
    Oh wow thanks to everyone for your help but I'm the moron. Apparently my computer was the one screwing up, I plugged in my phone the other day and apparently I didn't "Safely remove Hardware" and I just saw that so I closed it and than plugged in my phone and it worked instantly...wow just wow, thank god now I can downgrade
    12-24-08 11:34 AM
  15. imann101's Avatar
    i had the same problem -- not sure if that could have fixed it.

    If you still cant downgrade/have your phone recognized this is what I did:

    Uninstalled DM then reinstalled it. Once that came up I went into update, then I couldn't downgrade to .75 directly so I did .65 then back up to .75
    12-24-08 12:10 PM
  16. fecurtis's Avatar
    Glad I didn't update. I'll gladly wait for the official release.
    When VZW releases an official OS upgrade...it WON'T be .83, it'll be a higher number. If it were, it'd be the exact same as the "leaked" version.

    Leaked isn't to be mistaken as a beta, leaked means its out before VZW can test and approve it for mass distribution.

    Given the many issues users have had, I don't think VZW's testers will give this OS the green light.

    To the OP, glad you found why your computer wasn't recognizing your phone.
    12-24-08 12:17 PM
  17. bryank's Avatar
    /\ correct

    .83 worked great for me until I plugged headphones in, its now a know issue that once they are plugged in, you cant make a call without them in. So now im stuck trying to downgrade
    12-24-08 09:00 PM
  18. mikenycom's Avatar
    not sure if anyone has had this problem: none of my video messages i receive are viewable, all i get is a black image, if i pause i can see the the video, once i resume the screen goes black again.
    12-26-08 01:05 AM
LINK TO POST COPIED TO CLIPBOARD