Built for Business - Learn more about BlackBerry KEY2
  1. red914's Avatar
    I just did a fresh install of .230 on my 9530. Most everything works great but I noticed the BlackBerry browser will only work in WAP mode. When I go to Options > Advanced Options > Browser, all that shows up is Default browser configuration and the only option in the drop-down list is "WAP Browser". I'm pretty sure I could choose "Internet Browser" or something like that before in .148.

    Everything else works, data, email (although I think email only comes through as text and will not render html).

    Any ideas on what I can do to fix this?

    Thanks
    Last edited by red914; 10-10-09 at 04:13 PM.
    10-10-09 04:11 PM
  2. patches152's Avatar
    are you on BIS or BES?

    for the record mine only has "Internet browser" for the choices...

    are you talking about the browser identification setting? blackberry/firefox/internet browser?
    10-10-09 07:51 PM
  3. red914's Avatar
    Just BIS. There is no browser identification option, probably because WAP mode doesn't support that option.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-10-09 08:02 PM
  4. patches152's Avatar
    browser identification isn't in that location, just wanted to clarify and make sure we were on the same page. battery pull and see what you get?
    10-10-09 08:04 PM
  5. red914's Avatar
    My bad. Browser ID is in that menu but it just shows BlackBerry with a lock symbol. One interesting thing is when I edit a bookmark I can change browser ID just for that bookmark. In the bookmark edit page there's also a drop down box for browser type but only WAP shows up. it seems to render full pages so maybe it is just a bug in the setting selection? How do I tell if it is rendering HTML?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-10-09 08:14 PM
  6. patches152's Avatar
    it sounds like somehow you have BES browser service books....


    delete browser service books, then resend service books and re-register HRT

    options>advanced options>host routing table>bb button>register now
    10-10-09 08:15 PM
  7. red914's Avatar
    I tried deleting those service books and re-registering HRT (and battery pull after) and still no luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-10-09 11:41 PM
  8. sudo#CB's Avatar
    I tried deleting those service books and re-registering HRT (and battery pull after) and still no luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    I have exact same problem. I tried explaining it at http://forums.crackberry.com/f86/not...y-post-333232/ before i saw your post, but no one replied. Were you able to resolve your problem?
    10-11-09 12:04 AM
  9. Walshy701's Avatar
    It might be a carrier problem. when I first installed 5.0.191 I could only get the WAP browser (im with Telus FYI). I fixed the problem by replacing the service books with AT & T Service books, there is a thread around here somewhere on how to do it. After I replaced the service books I got my full browser back.

    A couple of weeks later I read that the problem with Telus had been fixed because they acquired the 5.0 OS candidate for testing and updated their service books accordingly. I am running .230 now and the browser worked correctly right from the start. Im not sure if the 5.0 candidate story is true, but it makes sense.
    10-11-09 12:12 AM
  10. red914's Avatar
    Yeah I'm with SaskTel and I'm betting they haven't got their side up to date yet since their last official release was .148. I'll have to look into a work-around when I get back home from my Thanksgiving holiday.

    I also noticed I have no option to send emails. I can type up my email but there is no way to send it. I saw a thread on this so I'll have to check that out.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-11-09 01:22 AM
LINK TO POST COPIED TO CLIPBOARD