Prime Day Deals:FireTV Stick $15 | Echo Dot $23
12-21-14 01:04 AM
255 123 ...
tools
  1. stikemup's Avatar


    Lock your screen while in a phone call.

    To unlock the screen, hit the 'ESCAPE' button.
    To re-lock the screen, hit 'MENU' > 'ScreenLock'

    Current Version: 1.8.3 (Without Global Locking) & 1.8.4 (With Global Locking)
    OTA: Download

    [1.8.4 Notes]
    -Added Global Locking

    [1.8.3 Notes]
    -Now hides the keyboard when re-locking the screen
    -Dims the screen upon first initial lock
    -Sets back light timer to 10 seconds while in a call, then back to previous setting after call has ended

    [1.7.1 Notes]
    -Restricted menu item to call screen

    [1.7 Notes]
    -Added functionality to re-lock your phone


    With Global Locking: Lock the phone via the menu from anywhere on the phone.
    Without Global Locking: Lock menu item is restricted to the Phone application only.
    Last edited by stikemup; 04-16-09 at 05:14 PM.
    01-29-09 08:35 PM
  2. y2bandit's Avatar
    01-29-09 08:39 PM
  3. natedizzle775's Avatar
    Awesome. Just downloaded. Hope to see more outta you!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 08:42 PM
  4. stikemup's Avatar
    ToDo List: (besides the focus issue)
    -Lock/Unlock screen with the Lock button while in a call
    -Customize your own message to be displayed
    -Ability to ignore ScreenLock when using BlueTooth

    Let me know if I missed anything ;D
    01-29-09 08:46 PM
  5. chuckh0308's Avatar
    ToDo List: (besides the focus issue)
    -Lock/Unlock screen with the Lock button while in a call
    -Customize your own message to be displayed
    -Ability to ignore ScreenLock when using BlueTooth

    Let me know if I missed anything ;D
    So, I'm assuming that as it is now you can't disable it after calling? I need to be able to bring up my keypad sometimes to work through menus after connecting. Do I have to wait for the lock/unlock with lock button feature before I can do that? Thanks!
    01-29-09 08:50 PM
  6. stikemup's Avatar
    So, I'm assuming that as it is now you can't disable it after calling? I need to be able to bring up my keypad sometimes to work through menus after connecting. Do I have to wait for the lock/unlock with lock button feature before I can do that? Thanks!
    Yes you can disable the window after a call, sorry, hit the back/escape button.
    Last edited by stikemup; 01-29-09 at 08:54 PM.
    01-29-09 08:52 PM
  7. natedizzle775's Avatar
    So, I'm assuming that as it is now you can't disable it after calling? I need to be able to bring up my keypad sometimes to work through menus after connecting. Do I have to wait for the lock/unlock with lock button feature before I can do that? Thanks!
    Just have to hit the back button and it disables. So then you can work the menus.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 08:53 PM
  8. natedizzle775's Avatar
    Is there no folder for the app? Or am I just missing it cuz it works during a call but I have no folder. Don't really care,just wondering for future updates and what not.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 09:01 PM
  9. y2bandit's Avatar
    Called myself and screen doesnt lock.
    01-29-09 09:03 PM
  10. stikemup's Avatar
    Is there no folder for the app? Or am I just missing it cuz it works during a call but I have no folder. Don't really care,just wondering for future updates and what not.

    Posted from my CrackBerry at wapforums.crackberry.com
    App runs in the background. There are no settings for it yet so there is no icon.
    01-29-09 09:04 PM
  11. stikemup's Avatar
    Called myself and screen doesnt lock.
    Did you set permissions?
    01-29-09 09:05 PM
  12. y2bandit's Avatar
    Did you set permissions?
    Yes I did. I set it to ALLOW on all of them. Let me reboot and try again
    01-29-09 09:06 PM
  13. chuckh0308's Avatar
    Yes you can disable the window after a call, sorry, hit the back/escape button.
    Awesome...thanks! My apologies if that was mentioned somewhere and I missed it!
    01-29-09 09:07 PM
  14. natedizzle775's Avatar
    App runs in the background. There are no settings for it yet so there is no icon.
    That's what I figured.. Just thought I'd ask. And one more thing as of right now does the lock toggle..cuz it locks and if I unlock ot I can't figure out how to lock it again.. Or is that what your working on now? Sorry to be a pain in the ****.
    Thanks stikemup

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 09:07 PM
  15. stikemup's Avatar
    That's what I figured.. Just thought I'd ask. And one more thing as of right now does the lock toggle..cuz it locks and if I unlock ot I can't figure out how to lock it again.. Or is that what your working on now? Sorry to be a pain in the ****.
    Thanks stikemup

    Posted from my CrackBerry at wapforums.crackberry.com
    LoL, no I should apologize for the app not being flawless yet =\
    The Lock/Unlock option is next in line
    01-29-09 09:09 PM
  16. y2bandit's Avatar
    Yes I did. I set it to ALLOW on all of them. Let me reboot and try again
    Rebooted and doesnt lock my calls.
    01-29-09 09:12 PM
  17. natedizzle775's Avatar
    LoL, no I should apologize for the app not being flawless yet =\
    The Lock/Unlock option is next in line
    Not flawless but great. Cuz its better than talklock and just as good as stormlock. And even better cheaper than stormlock. Haha fits my budget.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 09:14 PM
  18. stikemup's Avatar
    Rebooted and doesnt lock my calls.
    Maybe try reinstalling.. Seems to work for others

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 09:15 PM
  19. weasel123's Avatar
    thank you for the app. i dowloaded and tried it several times without any issues. just hit backspace and it works fine. i set all permissions and i did not do a battery pull.

    thanks
    01-29-09 09:19 PM
  20. dan.wright's Avatar
    I'm having the same problem as y2bandit. Screen locks fine on an outbound call from my Storm, but doesn't lock at all on inbound calls.

    And thanks much for this ...
    01-29-09 09:20 PM
  21. y2bandit's Avatar
    I'm having the same problem as y2bandit. Screen locks fine on an outbound call from my Storm, but doesn't lock at all on inbound calls.

    And thanks much for this ...
    At first I couldnt get it on both incoming or outgoing.

    I got outgoing working but incoming doesnt work

    Also, when I call my voicemail, I have it set up to automatically enter my password and ScreenLock prevents the phone from entering my password. Maybe that is why TalkLock pauses for 3-4 seconds?
    Last edited by y2bandit; 01-29-09 at 09:27 PM.
    01-29-09 09:22 PM
  22. stikemup's Avatar
    I'm having the same problem as y2bandit. Screen locks fine on an outbound call from my Storm, but doesn't lock at all on inbound calls.

    And thanks much for this ...
    Thank you for letting me know. I'll look into this

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 09:23 PM
  23. delta_foxtrot2's Avatar
    Erm once you unlock with the lock button I doubt you'd be able to lock again with it since the OS would take over.

    Also to fix the display/focus issue, why not just make the dialog box fill the screen?
    01-29-09 09:51 PM
  24. 0mie's Avatar
    Some of the new features from ScreenLock 2.0 would be nice hahahaha
    01-29-09 09:55 PM
  25. stikemup's Avatar
    Erm once you unlock with the lock button I doubt you'd be able to lock again with it since the OS would take over.

    Also to fix the display/focus issue, why not just make the dialog box fill the screen?
    Its not a dialog box

    Posted from my CrackBerry at wapforums.crackberry.com
    01-29-09 10:00 PM
255 123 ...
LINK TO POST COPIED TO CLIPBOARD