04-09-15 07:06 PM
53 123
tools
  1. Deathcommand's Avatar
    I am currently having the Incorrect MSL and no 3G problems that a lot of people are having.
    My Q10 cannot get 3G signal, so it has to bounce between 1X and 4G all the time. (literally at least 20 times while I'm on the road for 5 minutes)

    My battery is draining and I can't call someone without dropping the call unless I disable 4G.

    What can I do to let BlackBerry know that Sprint is refusing many of the BlackBerry users service?
    08-20-14 03:10 PM
  2. Jon Tessler's Avatar
    I don't know if there is anything you can do. Maybe hit up blackberry on twitter about it. My phone goes out as well when I ride to work I know exactly where all the dead signal spots are. Sprint needs to fix their network, cuz what they are doing now has made things worse.

    Posted via CB10
    08-20-14 06:55 PM
  3. Deathcommand's Avatar
    See the thing is that It's not that I drop 3G.

    I literally can never connect to it. Dropping 3G means the signal sucks. Not getting it and having the phone tell you that the MSL number is incorrect means they aren't letting me get it.

    Twitter it is.
    08-20-14 07:38 PM
  4. Mistik's Avatar
    Who have you talked to as that means your phone is not programmed properly. There are systems at Sprint that register all your access settings depending on plan/device. There are 2 identical ones in case one gets destroyed by disaster. If those 2 don't match you get errors like above.

    Have you spoken to advanced tech support?
    08-20-14 09:31 PM
  5. Deathcommand's Avatar
    Who have you talked to as that means your phone is not programmed properly. There are systems at Sprint that register all your access settings depending on plan/device. There are 2 identical ones in case one gets destroyed by disaster. If those 2 don't match you get errors like above.

    Have you spoken to advanced tech support?
    I have talked to advanced tech support. Twice. They ask me to add the MSL and it never works.

    Q10
    08-21-14 01:27 AM
  6. zocster's Avatar
    That sucks! Hope you get a solution. Even on the latest OS released?

    Sent from 2AD743B7 via Tapatalk Pro
    08-21-14 01:29 AM
  7. Jon Tessler's Avatar
    That sucks! Hope you get a solution. Even on the latest OS released?

    Sent from 2AD743B7 via Tapatalk Pro
    Even with the latest OS I have signal problems. Funny thing is I can be sitting next to my gf(who has a nexus 5) and she will have 3G or LTE and my Q10 will be on 1X

    Posted via CB10
    08-21-14 06:25 AM
  8. Deathcommand's Avatar
    That sucks! Hope you get a solution. Even on the latest OS released?

    Sent from 2AD743B7 via Tapatalk Pro
    I tried the lastest 10.2.1.xxxx 2 weeks ago.
    I also tried Sprint's second latest.
    then I tried Sprint's latest latest.

    None of them get 3G. Lucky me.
    08-21-14 03:42 PM
  9. smelly914's Avatar
    Maybe it's the device?

    Posted via CB10
    08-21-14 08:32 PM
  10. Deathcommand's Avatar
    Maybe it's the device?

    Posted via CB10
    Tried on 2 Devices.
    I will get another one though. The one I have has scratches(like it came with a large scrape on the top.
    08-21-14 08:47 PM
  11. opteron7's Avatar
    With this last update I get dropped calls and loss of connectivity when streaming. really sucks.

    Posted via CB10
    08-22-14 02:12 AM
  12. Mistik's Avatar
    I would suggest taking it into a service and repair center.
    08-22-14 09:09 AM
  13. CaliforniaJimbo's Avatar
    Ask for an Airvana, portable microcell tower, without it I am roaming at 1x, with it I get 3G service at home.

    Posted via CB10
    08-24-14 11:55 AM
  14. ddale340's Avatar
    I'm having the same problem. 2 months in, 6 devices later. The Q10 I had broke, the store couldn't repair it so I ended up with a refurb. All 6 phones, none will connect to 3G. The local sprint store is of no help, 4G is available in the store and they don't know blackberries anymore. Advanced technical support has 'tried everything'. I'm working with escalation advanced tech support now, so far no success. When I connect an android device to my account, 3G works flawless immediately. When we activate the Q10 same result, 4G is great, outside of 4G, 3g to 1x to 3g to 1x to finally 1X data, until it decided to look for 3g again, but never connect to 3G data. In the engineering screens i've had to set it to CDMA1X+LTE in order to keep the phone from driving me nuts constantly dropping signal, but that means 1X data which is terrible. I have an open ticket with blackberry, they have essentially said since it's a network issue, it's Sprint's problem, since all the software is up to date on the device. I sent them another message the other day asking them to contact Sprint to figure it out, but I haven't heard back yet. The MSL issue - nobody had been able to fix or explain that one to me. Each of the phone i've had the MSL Sprint has in their system does not work on the phone to get to advanced settings or even wipe the device per the self service app. Sprint has 'wiped' and recreated my account several times, never makes a difference. The phone behavior is not tied to a location, happens all over the country.

    If anyone has figured out how to resolve this (other than switch carriers or devices) i'd also love to know how. Everyone at Sprint seems to have never heard of this issue before, but clearly there are more of us out there that are either dealing with it or have dealt with it.
    pungster likes this.
    08-25-14 04:24 PM
  15. Jon Tessler's Avatar
    I'm having the same problem. 2 months in, 6 devices later. The Q10 I had broke, the store couldn't repair it so I ended up with a refurb. All 6 phones, none will connect to 3G. The local sprint store is of no help, 4G is available in the store and they don't know blackberries anymore. Advanced technical support has 'tried everything'. I'm working with escalation advanced tech support now, so far no success. When I connect an android device to my account, 3G works flawless immediately. When we activate the Q10 same result, 4G is great, outside of 4G, 3g to 1x to 3g to 1x to finally 1X data, until it decided to look for 3g again, but never connect to 3G data. In the engineering screens i've had to set it to CDMA1X+LTE in order to keep the phone from driving me nuts constantly dropping signal, but that means 1X data which is terrible. I have an open ticket with blackberry, they have essentially said since it's a network issue, it's Sprint's problem, since all the software is up to date on the device. I sent them another message the other day asking them to contact Sprint to figure it out, but I haven't heard back yet. The MSL issue - nobody had been able to fix or explain that one to me. Each of the phone i've had the MSL Sprint has in their system does not work on the phone to get to advanced settings or even wipe the device per the self service app. Sprint has 'wiped' and recreated my account several times, never makes a difference. The phone behavior is not tied to a location, happens all over the country.

    If anyone has figured out how to resolve this (other than switch carriers or devices) i'd also love to know how. Everyone at Sprint seems to have never heard of this issue before, but clearly there are more of us out there that are either dealing with it or have dealt with it.
    i have the same kind of signal problems with my Q10 in Norfolk, VA. Sprints customer care forum, told me that they are having cell tower problems in Norfolk. I really think the problems are because of Sprints upgrading their system. they are trying to catch up to Verizon and ATT at such a fast pace, that they are actually doing more harm than good. in my apartment, i just leave the phone hooked up to my wifi network, so i have data full time.
    08-25-14 05:08 PM
  16. smelly914's Avatar
    Does bbve show any issues with your radio?

    Posted via CB10
    08-25-14 05:40 PM
  17. ddale340's Avatar
    No issues with the radio in BBVE for me. Everything appears normal. The phone can "see" 3G, for lack of a better way of putting it. It just won't lock onto 3G for data. At times on the AirRave repeater if I have wifi on it will lock onto 3g voice only, but when I turn the wifi off it shows monentarily 3g (no bb icon for data and small g) then it will drop to 1x, try 3g again, then settle on 1X w/the bb symbol for data. Something somewhere is wrong with provisioning I figure, which is odd since other devices will provision just fine, it's just a bb issue. I was hoping the latest update would fix it, but no luck. I tried downgrading to os 10.1 at one point, made no difference. The really odd thing is the Q10 I had until late July worked perfect, no issues, but every replacement they've sent me does the same thing and won't connect. After 6 devices I would think the chances of it being a hardware issue are slim to none, but that's what Sprint keeps coming back to (although BlackBerry says it's a network issue).
    08-25-14 08:51 PM
  18. Mistik's Avatar
    So that's in your home. If you have an Airave it's meant to help out with voice and text. The Airave can only give 3G data signal. If you have an Airave it means there are coverage issues at that location. That is voice, txt and data. So obviously when you turn the airave off your phone will try to connect to the weak cell signal.

    If you have an Airave it means you also have wifi. Wifi is always preferred above cell signal if available.
    08-26-14 08:42 AM
  19. jdcbomb's Avatar
    I also experienced a stretch of highway in WV that contained no data service whatsoever. I-77 from Ohio all the way to NC. This issue has been going on for 1.2 years since I first reported the issue.

    Only recently did a rep to look at the tower situation on this stretch (all other ones before blamed me for having an out of date data profile even though I had the most recent one). Apparently there are sections of the country where data has not been activated or are having issues (not sure what). The rep said by the end of this year they will have these issues resolved. Quite sad it can take this long to fix a "no data" issue!

    Otherwise. In NC, CA, MD, and several other states I have had solid 4G, 3G, and 1X data. I believe the issues reporting here are directly related to delays in resolving tower issues which does not just affect BB devices. I had a HTC One next to me that also had the identical data drop out.

    Yet I will stay with Sprint, as my home area and almost everywhere I travel it works great...while saving tons of money compared th ATT and VZW. ($55 Unlimited EVRYthing).

    Posted via CB10
    08-27-14 05:56 PM
  20. Deathcommand's Avatar
    Still not working. They are sending me a new Q10 because the one I got from them had a scratch on the bezel but I doubt it will help. I'm sad boy.

    Q10
    08-28-14 04:59 PM
  21. o4liberty's Avatar
    Sounds like it's time to switch carriers, had sprint many years ago and they haven't changed much.

    Posted via CB10
    08-31-14 04:32 PM
  22. opteron7's Avatar
    Just leave sprint or get another phone.

    Posted via CB10
    10-03-14 10:46 AM
  23. Jon Tessler's Avatar
    Just leave sprint or get another phone.

    Posted via CB10
    Sure, are you gonna pay for my 3 lines, so i am able to go to another carrier, plus pay to purchase the phones and the ETF? everyone thinks it is so easy just to switch carriers at a drop of a hat....well ummmm its not, that takes money, and i have bills like rent and stuff to think of first.
    MobileMadness002 likes this.
    10-04-14 12:55 PM
  24. opteron7's Avatar
    Buy on ebay, great phones for under 60 dollars.

    Posted via CB10
    10-05-14 08:25 AM
  25. opteron7's Avatar
    BTW I was able to fix my 3g issue. I chatted withe sprint from their website. I told them my phone goes in to roaming when it switches to 3g and trying to make a call. And have missed call when in 3g and no data.

    They made me turn off my phone, they did something on their end. When I turned it back on they me made clear cellular setting and it went through an auto configuration. Bam problem resolved.

    The only issue I have is when the phone switche to 3g to 4g data stops for about 10 to 15 seconds. But that has that has an been an issue since I got the phone. I still think it's a BlackBerry issue on cdma phones only. I think that's why Sprint wont't release any other BlackBerry, but who knows I'm just saying (while wearing my tin foil hat).

    Posted via CB10
    10-05-14 08:36 AM
53 123

Similar Threads

  1. Do you use a legacy BlackBerry because you want to?
    By Newfangled in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 08-26-14, 07:18 AM
  2. Can You Use PlayOn with YouTube Videos?
    By Yoox_II in forum BlackBerry Z10
    Replies: 3
    Last Post: 08-22-14, 08:16 AM
  3. Replies: 10
    Last Post: 08-21-14, 09:58 PM
  4. Have ex blackberry users become unproductive away from the office?
    By Hello Blackberry World in forum BlackBerry 10 OS
    Replies: 28
    Last Post: 08-21-14, 06:06 AM
  5. security wipe for blackberry z 10
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-20-14, 03:35 PM
LINK TO POST COPIED TO CLIPBOARD