1. Cruz372's Avatar
    I was prompted to upgraded the CB app store client on my device.
    After I did so, the icon for the app store disappeared. I have
    attempted to d/l the client from the link on m.crackberry.com
    however it just takes me to the online store. I finally got to d/l the client on my tour,but when i attempt to open the app store it says Error starting MHAppStore:Module 'MHApp Store' attempts to access a secure API. What does this mean? I've tried to contact CB support,but i haven't got any reply yet.Any advice?

    P.S. if i this posted in wrong location i'm sorry...have a Tour,so i figured the Tour section is where i should post question.....
    Last edited by Cruz372; 11-30-09 at 04:52 PM.
    11-30-09 04:48 PM
  2. xraytedjim's Avatar
    I have the exact same problem. I have a Bold 9700. I wonder if its a problem with OS 5.0??? I'm running .351. Tried a battery pull, but got the same error. Any help would be appreciated.
    11-30-09 09:07 PM
  3. blahh's Avatar
    same thing for me. also have the bold 9700. reported the problem a few hours ago.
    12-01-09 12:15 AM
  4. stalkie's Avatar
    got the same problem for my 8520 os4.6...
    12-01-09 12:58 AM
  5. byakush's Avatar
    I had the same problem today with my Tour. After my BB bricked and I re-installed all my apps, I had this problem with CB's App. Help????
    12-01-09 01:05 AM
  6. davidnc's Avatar
    I'm glad I saw this thread before I did the same thing
    12-01-09 05:04 AM
  7. CrackBerry Kevin's Avatar
    Escalating to the app store dev team.... stay tuned. thx for the patience!
    12-01-09 06:06 AM
  8. sotypical's Avatar
    I just downloaded and installed the app... getting this error too.
    12-01-09 11:29 AM
  9. fmax3000's Avatar
    Just istalled App Store to try it on my Bold9000. It installed perfectly but when I click on its ico I get the same error message "Error starting MHAppStore: Module 'MHAppStore' attempts to access a secure API"!
    I changed all permissios to ALLOW, re-install then restarted phone couple times but nothing seems to work. My O.S. is 4.6...266. I am in Dubai and the carrier is ^&$%$# Etisalat!!!
    12-01-09 11:30 AM
  10. adriano72's Avatar
    Hi,

    we have been able to reproduce the issue -- we are working on isolating the cause.

    Stand by for news -- in the meantime if you have any additional info which you think might help us better understand the cause we'd appreciate if you could follow-up here.

    Thanks and sorry for the trouble.

    - Adriano
    12-01-09 01:21 PM
  11. pkcable's Avatar
    Sounds like they are working on it, sit tight folks, and in the meantime use the mobile web store...

    App Store
    12-01-09 02:49 PM
  12. adriano72's Avatar
    As a temporary workaround, we replaced the "non-touch" version of the app store (the storm version appears unaffected by the problem) with a slightly older build, which starts without issues.

    Please clear your bb browser's cache (just to make sure you'll get the correct files) and visit the CrackBerry app store download link from your BB to install it again.

    Installing over what you currently have is ok -- worst case if what you get still doesn't start, try a uninstall -> reboot -> reinstall sequence.

    Keep an eye on this thread for updates.

    - Adriano
    12-01-09 05:10 PM
  13. adriano72's Avatar
    closing the loop on this -- we found the problem, and addressed it. To download the very latest build available please visit again the crackberry app store ota download link and overwrite what you currently have installed.

    - Adriano
    12-02-09 07:11 AM
  14. pkcable's Avatar
    Muchos Gracias!
    12-02-09 10:30 AM
  15. fmax3000's Avatar
    Working perfectly now on the BOLD9000, OS4.6.
    Downloaded OTA. Thanks a ton!
    12-03-09 09:03 AM
  16. kathrynnaomi's Avatar
    the app store still goes missing everytime I reboot....getting a bit annoying now!
    12-10-09 12:13 PM
LINK TO POST COPIED TO CLIPBOARD