1. InGearX's Avatar
    What procedure would you advise to address this:

    all was working fine ... until today I took out my 1TB WD laptop HDs and put it into a SATA reader as I do all my other drives and it reads them just fine

    but it failed to show up properly on any reader and any computer I tried - Disk Management just keeps hanging or shows the Drive and partitions - but doesn't show the File Systems on the/contents

    when I put it back into my laptop - it does seem to alive - but OS loader GRUB said it's misconfigured and the OS failed to boot up

    when I try to boot windows it tried to VERY VERY slowly never making it for hours...

    entire drive seems to be very very slow...

    I tried a number of recovery boot CDs like Acronis True Image and they report that they fail to read from many sectors and do not show the files/data...

    <b>I'm curious as to what went wrong? is it physical damage?

    how could this have had happened?

    and what possible steps I can take to obtain the data and revive the drive?</b>

    thank you...
    12-28-11 10:32 PM
  2. Rootbrian's Avatar
    Try a linux Live CD if you haven't already done so and copy everything from the disk to an external drive. Then format it to NTFS, then EXT4, or the filesystem you originally had it on. I had a similar problem where the bios, unless updated, wouldn't work with any drive except a 20GB WD.
    01-01-12 08:37 PM