1. vbev84's Avatar
    I rented a movie from the video store and it has been sitting in "pending" mode for about an hour now. I contacted support and, and haven't herd anything yet. I'm sure they will get back to me but maybe someone out there knows what to do. I have reset my PlayBook and open and closed the app multiple times and still sits at pending. Any ideas?
    02-29-12 01:48 AM
  2. Swirlz's Avatar
    I'm sorry, I don't have any ideas for you but I just wanted to point out in case you were waiting around, the reason you haven't heard back yet is Roxio support is only open from 9am to midnight EST. They'll probably email you in the morning.

    Good luck though.
    vbev84 likes this.
    02-29-12 02:30 AM
  3. vbev84's Avatar
    Received a response from roxio support, the gave me a refund with no further information. No reason why this happened, no explanation, and I never got to watch the movie. It is now gone from my download tab.
    02-29-12 10:48 AM
  4. Swirlz's Avatar
    Huh....Does seem like they could be a bit more customer service-y, at least give you some kind of guidance as to what you might do if it happened again while they were closed. Well, glad to hear you were able to get a refund.

    Honestly, I haven't been impressed by the customer support from Rovi either. I've received conflicting information on basic questions and have been waiting for days for a response on a follow up question.

    I would love to support the store, but they're making it kinda hard.
    02-29-12 03:27 PM
  5. SMusser87's Avatar
    I know I'm a couple days late with this response, but I wanted to give a little input into this issue in case anyone else is having problems.

    When the 2.0 update came out, I tried to purchase an episode of Looney Tunes for my son to watch and I had the same result, the download was stuck at pending for over an hour. I contacted the support via the live chat option and the customer service rep was able to give me a refund, apologized and claimed it may have been a glitch. After receiving the refund I tried the purchase again, with the same result. At that point I was wondering what could cause this glitch so I did a security wipe on my PlayBook and attempted the purchase one final time. The download went through right away and I have been renting and downloading videos since without an issue. I'm not sure if this is the answer for everyone's issues as I am sure that most have already done a security wipe after the update, but it solved all my issues. Hope this helps!
    03-03-12 12:44 PM
  6. nanddm98's Avatar
    I'm having the same issue. Says that it is unable to contact the license server.
    03-08-12 11:49 PM
LINK TO POST COPIED TO CLIPBOARD