1. jenks5150's Avatar
    Hey Guys,

    Not often a BB problem that I can't solve myself but I've come across one it seems, so I shall enlist the help of CrackBerry nation.

    I'm on a 9900, 7.0.0.540. Have never had any problems with it other than maybe lackluster battery life due to my ridiculously heavy use. I just picked up a new router the other day for my wireless network, was running an old Linksys unit until picking up this new Netgear router, now capable of dual band 2.4/5GHz, and draft-N.

    Connected all my devices to it no problem, laptop, tablets, PBs, iToys, Xbox, TV etc - My 9900 connects to it no problem (to both 2.4 GHz and 5 GHz bands). But once I'm connected, it blocks BBM and E-mails (All BB services other than browsing, strangely) from both sending and receiving. It's ridiculously annoying as I have to turn off wi-fi, re-send, and then turn Wi-Fi back on if I'm downloading something etc.

    My router is set to automatically assign IP addresses, WPA2-Personal security, no port-forwarding or anything kinky.

    I'm confused as to why there is an issue as I set it up the same way as my older router, the only difference being it's capable of N now, which the 9900 should be fine with.

    Anyone else experienced this issue before or have any ideas as to where to start? I feel I've tried all of the obvious fixes. I doubt re-sending service books would do much but that might be worth a shot.

    PS for those wondering, the ROI on the router for my PlayBook was astronomical. Performance/speed literally doubled from 15-17 mbps to 30-32 mbps on wireless. (previously could only get that plugged in).


    Thanks in advance for any tips/troubleshooting ideas you guys might have. Cheers.
    12-20-11 03:12 AM
  2. hanto's Avatar
    Try to:
    1. Turn off the firewall if you suspect it causing it.
    2. If you suspect the N cause it, you can set the router to do N or if cannot do G. (or just set it to G for testing purposes).
    12-20-11 05:10 AM
  3. claykin's Avatar
    N has been a standard (not draft) since October 2009. I hope you didn't buy a new router that still says draft N on the carton. That would be some seriously old inventory.

    Which model did you buy? Did you upgrade firmware to latest? I have a Netgear WNDR3700V2 and it works OK on Wifi with my 9900.
    12-20-11 07:47 AM
  4. lcohen999's Avatar
    I have seen this randomly happen (it could be your ISP as well) and yes, upgrade firmware, do a factory rest and give it a few days.

    Sometimes, it takes a while (I have no reason why)
    12-20-11 10:18 AM
  5. Rootbrian's Avatar
    Never had any issues with my D-Link Dir-615 at all. It works fine, bis just jumps between that and the mobile network on it's own and it's not bothersome at all. It could be service books if nobody has mentioned it.

    Sent from my Crackberry @ wapforums.crackberry.com using Tapatalk
    12-20-11 11:11 AM
  6. jenks5150's Avatar
    N has been a standard (not draft) since October 2009. I hope you didn't buy a new router that still says draft N on the carton. That would be some seriously old inventory.

    Which model did you buy? Did you upgrade firmware to latest? I have a Netgear WNDR3700V2 and it works OK on Wifi with my 9900.

    It is of course N and not draft-N. That's what I get for posting in the middle of the night when my brain isn't firing on all cylinders lol.


    The router is a Netgear AV series WNDR37AV. It has the latest firmware, too. I suppose I'll try service books but I don't see how that effects Wifi connectivity.
    12-20-11 11:31 AM
LINK TO POST COPIED TO CLIPBOARD