1. EdY's Avatar
    Hey folks,

    I downloaded "Party Factory" but when it launched it asked for permission to access files, microphone and GPS I think.

    So I thought that was a bit too much privacy invasive so I unchecked all of them, so I can try the app and then see if worth giving it permission if I trust it.

    Obviously the app doesn't load any music files, probably because I denied it permission. So I went into settings > security and looking in my application permissions at least to turn on file access, and that app is NOT LISTED! So I can't adjust the permissions.

    So I uninstalled the app and tried to reinstall, but now it doesn't ask me on first launch to set any permissions like it did the first time, and so it still remembers the permission settings from before which were denied.

    How do I get this app and any history of its permissions reset, so when I install it again it asks?

    Help!


    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    08-20-12 11:03 PM
  2. gkl's Avatar
    hit the gear icon, choose settings, application permissions. choose your app and youre good to go.

    Via my PlayBook and Tapatalk
    08-20-12 11:41 PM
  3. jeroen_13's Avatar
    Uninstall the app -> Reboot your playbook -> Re-install
    08-21-12 04:36 AM
  4. pacoman03's Avatar
    I downloaded the app, and it also doesn't appear in my apps permissions list. FWIW, I can say that it's an app that I will not likely be using much. For one thing, the app only reads song file titles, not the actual file's tags. This means that it doesn't list music by artist. album or song title- it only lists songs by file name. I don't know about you, but my song file names are all over the place. For example, a file name may be "The Beatles A day in the Life", or it may be "A Day in the Life", or it may be "04 A Day in the L:ife". Years ago, I converted all of my CD's to MP3s, using Itunes, and itunes named all files in the last format listed, but I have plenty of tunes listed in one of the other formats. Compounding this problem is that there is no search function, and coupled with the fact that songs are only kinda listed in alphabetical order, finding a particular tune can be quite frustrating. Also a problem is that there is no "next" button when playing a tune, so if you don't really like a tune that's playing, it's a bit of a chore to get to the next cued tune.

    On the upside, the app does have a working 3 band EQ and some effects, if that matters to you.
    08-21-12 06:39 AM
  5. FF22's Avatar
    Could it be listed under a different name in the Permissions list? Is it an Android or native app?
    08-21-12 09:52 AM
  6. pacoman03's Avatar
    Could it be listed under a different name in the Permissions list? Is it an Android or native app?
    It's native, and I went though all my apps listed in the permissions settings, and there was nothing there that it could be.
    08-21-12 10:50 AM
  7. Maestrodog's Avatar
    Same exact issue with another application. Just astonishing lameness. I uninstalled, restarted, etc. I registered with the dev's forum and never got a confirmation email to let me in. How on earth can Blackberry allows applications that require permissions to function at all, then not have the application populate the permissions list?

    This is what is killing them.

    Then again, not as if they keep releasing OS updates, pull them back, and then tell people they were never issued, and then issue nothing further for another two weeks.

    ...and hey, what's $5 after I threw $700 at this thing?

    Seems to be the RIM position.

    I suppose I'll eventually get a refund for this, because a dollar to your donut this requires a security wipe, and that's not the wipe I have in mind.
    08-22-12 08:07 PM
  8. FF22's Avatar
    Yup, I am looking for the Permissions for Photo Editor Ultimate (free) since it wanted Inet access to run. I granted it but wanted to now change that to DENY but I can't find it in the Permissions list. It is an Appworld Android app.
    08-22-12 08:50 PM
  9. peter9477's Avatar
    Photo Editor Ultimate (free), at least in the latest version (6.9.6) which I just downloaded, does not ask for internet access permission. (Which is good, because as far as I know all apps are automatically granted that permission for now. It's always been available to devs to include in their app's set of required permissions, but has never yet been shown to users.)

    PARTY FACTORY should show up in the permissions list, under that name and with author Gustavo Bonilla.

    If you don't see it, make sure you have actually run the app once... they do NOT appear in that permission list until you've run them the first time. Also make sure that you EXIT that list if you were already viewing that particular page in the settings when you ran the app. At least the last time I checked, it does NOT update dynamically while you're viewing it.

    Note that I'm using the 2.1 beta here, and when I installed PARTY FACTORY I actually saw the permissions dialog once during the install, while App World was still running and before installation completed. (It said 50% done, I think.) Then, after checking that it did not yet appear in Permissions, I ran the app and it showed me the same dialog again.

    Only after I closed that dialog and let the app run was I then able to go back into the list of permissions and see it.

    Hope that helps someone. It's also quite possible there is a bug, but with several ways for things to not show up in the list, as described here, maybe everyone can get it to show up now.
    Heavens1 likes this.
    08-22-12 09:27 PM
  10. FF22's Avatar
    Can you find Photo Editor in the Permissions list? I thought it was the one that had asked for permissions but I could be wrong. I've also seen that Permission question appear while INSTALLATION was still occurring.
    08-22-12 11:31 PM
  11. Heavens1's Avatar
    OK i've got Photo Editor Ultimate and have used it a little bit since I bought it a couple of days ago.

    It doesn't show up in my Application Permissions.

    I recall granting it permission to access what it wanted because when I initially refused access the App would open and shut down immediately.

    Quite frankly I'm not impressed with this App because it does not perform well - it isn't particularly user friendly and it's quite clear that it's not been made for the PB platform.

    I'm uninstalling now!!
    08-23-12 01:05 AM
  12. Maestrodog's Avatar
    Thanks for responses, not working for me. Dev got back to me and has no idea, offered a refund.

    Another day in Rimburgh for me.
    08-23-12 07:04 AM
  13. peter9477's Avatar
    F2, no, Photo Editor Ultimate (Free) did not show up in the permissions list at all. It didn't ask for any permissions, and apps that don't ask for any will not appear there.

    I don't know about the non-free versions though.
    08-23-12 12:08 PM
  14. pacoman03's Avatar
    Photo Editor Ultimate does ask for permission to access the internet, files, and the camera during setup. That being said, it is an android app, and, as far as I can tell, none of the android apps show up in the permissions list.
    08-23-12 01:23 PM
  15. FF22's Avatar
    I am pretty certain the Photo Editor FREE did ask me for permissions - 3, if I recall, Files and the Internet and something else that I don't recall. I denied it all at first. It would not load. I denied the Internet and it would NOT load. I granted and it loaded.
    08-23-12 09:03 PM
  16. EdY's Avatar
    To answer some suggestions before...

    I did uninstall.
    I did reboot.
    I reinstalled the program.
    It did not ask to set permissions again, and no sign of it in the list for settings.

    Basically, it was a "one shot" deal and if you screwed it up, I guess unless you do a complete security wipe, there is no way to get to those settings again.

    Maybe someone could make an app that lets you modify the permissions file/flags. My BB phone has a very extensive list of permission settings for all apps, with subcategories. We need that on the Playbook.

    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    FF22 likes this.
    08-23-12 09:30 PM
  17. Maestrodog's Avatar
    Rim told me to get a refund from dev.

    Dev reports no way to refund me through dev/vendor interface.

    Called RIM who said "We don't take responsibility for third party applications"

    I said, don't take responsibility, just tell me how to help dev give me a refund.

    RIM said "we don't take repsonsibility"

    I said, "I'll never buy a third party app again, probably never buy anything from you again. How do you let anyone onto AppWorld and not give them a way to refund, especially when that's the way to fix bugs, by your own reckoning to me yesterday?"

    Rim said, "I know, but we don't responsibility in AppWorld for third party applications"

    Have a great day shareholders, you just lost more money, one of your most loyal customers, and someone who used to go around saying, "Buy Blackberry".

    Totally pathetic. Absolutely for complete shame.
    08-24-12 07:30 AM
  18. FF22's Avatar
    Has Rim changed its policies. I've gotten refunds from them. How did you contact them?

    I and others have used:

    appworldbilling@rim.com

    And I apologize if that's the route you took.
    08-24-12 10:46 AM
  19. Maestrodog's Avatar
    I spoke with them by phone. All they would do is repeat the third party line. Didn't even provide a way for me to help the developer help me.

    I pressed and pressed, with three agents.... nothing.

    They were also clueless about the issue, couldn't advise if a security wipe would even address it---unless of course I torched all my data and didn't restore, which they've had me do before to solve an issue---and had a defeatist sense about everything.

    In other words, they have no idea how the permissions work, why a permission would persist even though it says all data will be wiped when you delete an application, nor what the path is for a third-party refund.

    I asked if this might be addressed in the OS update and they said "We never know what will be in there until a day, maybe two days before."

    I'm just blown away by their dysfunction.

    You can't let your customers brick their applications and just have NOTHING to offer but a complete device wipe without restore.

    RIM yet is light years away from survival.

    The new CEO should have installed a protocol whereby anybody who can document a bug or issue that can't be solved gets credit in AppWorld. You always want to help your customers when you let them down.

    One of the lamest customer service experiences of all time, top five... and for this former Dell, Delta and Time Warner customer, that is REALLY saying something.
    08-25-12 09:52 AM
  20. FF22's Avatar
    Did you send an email to the address posted above. It may be different from the support people for the general pb issues.

    But if permissions are messed up internally there may only be the wipe or debrick method.
    08-27-12 12:16 AM
LINK TO POST COPIED TO CLIPBOARD