1. ndon70's Avatar
    upgraded to 2.0.0.6149 beta and purchased eternal legacy thru app world and after it installed, i could not get the game to start. when i touch the icon and it appeared to open then suddenly the shut down(just the program). after several attempts, i rebooted to see if that would help, but didn't. so i deleted it, rebooted again, then tried to reinstall it, but now it's asking me to purchase it again. if this has been covered in the forums, please post the link or advise of a solution. thanks!
    12-17-11 01:36 AM
  2. vgwillm's Avatar
    I am not using OS 2. 0 but i have had the same issue. I rebooted and it said the same thing. I had to shut it down completely for 5 minutes then leave wifi off until it fulling turned back on. Once everything was loaded i conected to wifi and it allowed reinstall without purchasing again. Not sure it will work for 2.0 but worth a try.
    12-17-11 03:58 AM
  3. Megacharge's Avatar
    Odd, I was able to, I just went into the App World under the "uninstalled" section, and re-downloaded them.

    You might want to try that if you haven't already.
    12-17-11 04:51 AM
  4. ndon70's Avatar
    thanks vg and mega, however none of those options worked for me. i'll prolly downgrade back to 1.0.8 and see what happens. thanks again!
    12-17-11 11:33 AM
  5. ignites's Avatar
    once you click purchase and log in, it will authenticate your id and you can redownload the apps you paid for, without charge. Its just a physical bug u wont get charged.
    12-17-11 11:59 AM
  6. FF22's Avatar
    If you continue to have issues:

    appworldbilling@rim.com

    I had an issue, sent an email and they actually called me by phone.
    ndon70 likes this.
    12-17-11 12:44 PM
  7. ndon70's Avatar
    darn it ignites! i 've already downgraded and voila, the option to reinstall eternal legacy was available. now at least i know if i decide to go beta again! thanks!!
    12-17-11 12:46 PM
LINK TO POST COPIED TO CLIPBOARD