1. je2345's Avatar
    Ever since the latest OTA update I can no longer download or update any apps from the Playbook's App World. It keeps giving me Blackberry ID invalid. Never had an issue prior to the latest update. I've rebooted the device several times but still no luck. Don't want to have to wipe the device to get it working again. Anyone else having this issue and know how to fix?
    08-01-11 05:04 PM
  2. dasDestruktion's Avatar
    Weird. It seems that over the last few day more and more issues are being reported as stemming from the latest 1.0.7.XXXX builds. i would suggest calling into RIM's PlayBook support lines and see what they have to say. Perhaps they can do something from their side of things.

    Don't worry though, nothing good has been added to AppWorld for the PlayBook in a while. :/
    08-01-11 07:15 PM
  3. wellard's Avatar
    Download a chargeable app, not a free one. Enter your password and cancel at the payment screen. Happens to me a lot and this fixes it every time.
    je2345 likes this.
    08-01-11 07:43 PM
  4. je2345's Avatar
    Thanks man that worked for me. Was getting so pissed.


    Sent from my HP Touchpad
    08-01-11 10:28 PM
LINK TO POST COPIED TO CLIPBOARD