1. bjacob's Avatar
    when i try opening this app, it just gets stuck at the opening screen, is this a known issue?
    01-20-12 03:51 AM
  2. Fenrir26's Avatar
    I just tried on my PB and it seems to be working fine. Maybe try a reboot or reinstall?
    01-20-12 03:54 AM
  3. TheScionicMan's Avatar
    Nope, that one's on you alone...
    01-20-12 04:03 AM
  4. Superfly_FR's Avatar
    No, I was even surprised of its quality while testing yesterday.
    01-20-12 04:10 AM
  5. bjacob's Avatar
    i just reinstalled it, works now but i lost my playlists this sucks
    01-20-12 04:39 AM
  6. 3Athlete's Avatar
    This app is buggy at the best of times. It does play this game with me once and a while but a restart usually resolves the start issue.
    01-20-12 09:27 AM
  7. NaijaBerry's Avatar
    Funny, i was just about to write a review of how apps like that don't work as well as accessing via your browser as experienced with the youtube app, i downloaded the vevo app a couple of weeks ago and i found it to perform in a similar way to the youtube app, but its working so well today, just thought i'd try it out and its smooth and fast, could it be because of the latest OS2 beta update i wonder?
    01-20-12 09:36 AM
  8. nico2004's Avatar
    I have lots of issues with it, I re-install it and me too I lost my playlists.
    01-20-12 09:37 AM
  9. sk8er_tor's Avatar
    The VEVO app does not feel like a native app whatsoever. I love the 720p and audio but the app is not the best.
    01-20-12 09:43 AM
LINK TO POST COPIED TO CLIPBOARD