1. eprklims's Avatar
    Hi all
    I am having trouble with Android apps on PB (sideloaded or otherwise). I've posted specific problems on other threads but I'm not really seeing any answers or if others are experiencing this.

    My main problem boils down to the Android apps 'forgetting' their information every time I start them. I have to go through the 'accept terms' screens every time on many apps, and none of the defaults I change seem to stay.

    Examples:
    1) Overdrive - forgets that I've accepted the terms each time, and won't store my library selection.
    2) qPDF - seems like a great app but the same thing with 'terms' appearing each time and defaults I set for annotations don't persist - so I have to set them each time.
    3) Kindle - I must login each time - and set reading preferences every time

    Also, on a separate, but related topic regarding Android apps - particularly pdf ones like repligo and qpdf - they don't seem to be able to use the file system properly so I can't 'save as' without issues, and when I try to send from them an attached file it gives the file name to the native mail app but doesn't attach the file. (see here for even more info: http://forums.crackberry.com/android...-files-702396/ )

    Is this affecting everyone, or are some of you able to use these apps 'properly'... Right now they are making me pine even more for their native counterparts : )

    Thanks in advance
    03-08-12 06:02 PM
  2. carrickfergus's Avatar
    I only have kindle and it remembers my settings every time I open it, including my book setting, etc. Same for Words With Friends.
    03-08-12 07:27 PM
  3. Ntario's Avatar
    I don't seem to be having this problem
    03-08-12 08:03 PM
  4. rimaddicted's Avatar
    I have kindle and don't have this problem
    03-08-12 08:08 PM
  5. eprklims's Avatar
    Thanks for the responses... Is anyone having this issue? I'd backup and reinstall but app backup doesn't work for me...
    03-08-12 08:41 PM
  6. rjedge54's Avatar
    It sounds like you need to do a security wipe and reinstall. For your backup issue, have you tried a selective backup and backed up each option by itself?
    03-08-12 09:04 PM
  7. eprklims's Avatar
    @rjedge54
    I've tried everything on the backup including selective (settings works) and several hrs with rim 2nd level tech support... The last they said was that they were investigating it but didn't have a solution...
    OK... If no one comes up with a better solution I will do the wipe tomorrow... Painful.
    Thx
    03-08-12 09:09 PM
  8. greatwiseone's Avatar
    It's the way the Android player is architectured. If you restart your PlayBook, you will lose all settings and things stored in the Android apps. That's why you need to relogin to kindle every time after you restarted the PlayBook.
    KermEd likes this.
    03-09-12 12:09 AM
  9. carrickfergus's Avatar
    It's the way the Android player is architectured. If you restart your PlayBook, you will lose all settings and things stored in the Android apps. That's why you need to relogin to kindle every time after you restarted the PlayBook.
    I've done a hard reset on my PlayBook several times and never had to relogin to kindle.
    03-09-12 06:19 AM
  10. kbz1960's Avatar
    OP did you ever root, install the beta or load the old old player? If so a wipe is in order.
    03-09-12 06:40 AM
  11. eprklims's Avatar
    I sideloaded the android player way back but I thought that was on the original one I had before a warranty return for another issue... But maybe not... I pulled the trigger last night and did the security wipe (I'm hoping that is all I have to do to wipe it clean) ... Going to be a fun day reloading 300+ apps individually...
    So far I've tested qpdf and the 'save as' function makes an unreadable file so I'm sorry still having that issue... Save works fine... Odd.
    I'm going to try a backup now that I've downloaded around 30 apps then I will try out a reboot to see if memory is retained... I will report back. Hopefully those things work so I can at least pay it forward to someone having this issue and worried about gaining anything from a wipe...
    One thing I did notice right away was after the wipe and fresh os install the android player started like lightning compared to the past... Hope that keeps up... I was waiting sometimes several minutes after loading android apps in the past...
    03-09-12 07:09 AM
  12. eprklims's Avatar
    Ok... so a quick update.
    1) the android memory IS persistent now between reboots. I made some changes in qpdf and rebooted, and the changes are still there. WOOHOO!
    2) first successful app backup EVER for me. WOOHOO!

    I am now going to test sideloading an app and see if that changes anything. One of the reasons I did the wipe was because I was concerned the sideloading process might have caused some of the issues - and I wanted to make sure I was doing everything the RIM supported way so I had a right to complain.

    After sideloading I will try another backup and another reboot and report back... I will do that later today when I have time. The good news is the wipe seems (so far) to be paying off.
    03-09-12 08:01 AM
  13. LuayS's Avatar
    Let me know what happens, because everytime I reboot playbook I lose all android settings (stumbleupon requires a relogin etc) but if i just close app player settings are maintained. I've come across this with all sideloaded apps. (dont have any app world android downloaded apps) I've also wiped and tried it with same issues.
    03-09-12 09:57 AM
  14. eprklims's Avatar
    @LuayS.
    The wipe seems to have fixed my 'persistent memory' issue in Android.
    My next step was to try to email a PDF from qPDF and I still have the issue where only the filename gets transferred to the subject line in the native mail app... No file gets attached. Also I can't save-as otherwise the file becomes unreadable (and doesn't even show up in the directory in Win7 when I view the directory from there). Only save works. To me those things seems like a bug consistent with the Android player not having full access to the filesystem. It can't create new content AND it can't provide files to the native apps. Two big disappointments for me. Is ANYONE able to get qPDF to mail the actual attachment?
    As my next test I sideloaded Kindle. I then made some settings changes (and of course logged in) and after a reboot the changes (including the downloaded book and dictionary) stayed! WOOHOO!
    I will start a backup now. Cross your fingers!
    03-09-12 10:43 AM
  15. eprklims's Avatar
    Ok. I have backed up AFTER sideloading so hopefully that answers the question around whether sideloading mucks anything up. Applications AND settings worked.
    If I can just figure out the issue with 'save-as' versus 'save' and being able to attach files to emails from within Android I'm golden. As a plus the Android player is about 1000x faster now after the wipe. Completely different experience.
    Now on to loading the rest of the apps individually from app world. Exciting
    03-09-12 11:01 AM
  16. LuayS's Avatar
    So to verify, you wiped your PB sideloaded an app and rebooted your pb that sideloaded app maintained your settings?

    because for me i consisntently need to relogin to twitter/linkedin and my android game saves never save if i reboot.
    03-09-12 11:19 AM
  17. eprklims's Avatar
    @luayS
    For some reason I see your response to the thread on my BB but not in the thread above... for others, luayS asked if since the wipe my android 'memory' was persistent between reboots and the answer is a glorious YES! : )
    Tested on Kindle (sideloaded) and qPDF (from app world) and both 'remembered' after a reboot. For the record, qPDF is awesome - they responded to my request about the issues already and have promised some cool features in their next major release!!
    03-09-12 02:24 PM
  18. KermEd's Avatar
    Meh i have the persistent data issue even after a fresh wipe last week it just took a few days to show. But it took 2 days to download my 200+ apps and a lot ofnwork pushing data around...

    ... So im just going to leave it as is
    03-14-12 12:07 AM
LINK TO POST COPIED TO CLIPBOARD