06-26-12 09:14 AM
233 ... 45678 ...
tools
  1. HaTaX's Avatar
    Is there any way to have stand alone icon for a downloaded Market app appear on the PlayBook? I've got the Android App loader running great (thanks HaTax!) but would ultimately like to have separate icons for each downloaded app.

    Probably just need to wait on RIM
    Yeah, the portion of the player that installs shortcuts on the PB is currently not used, but it is included. There's all kinds of scripts that get installed with the Android player and some of them are responsible for mapping icons in the PB ui to android applications. This looks like it's meant to be used once RIM starts distributing Android apps through app world, and the bar files will probably be packaged differently and that will kick off those scripts.

    I'd say wait for RIM's move on the UI integration, otherwise all we're doing is putting lipstick on this pig. The version we've got now is nice to tide us over until we have the final version, but it's not done baking yet...

    BTW, Calgary is a beautiful piece of the world! Was there for a week long vacation about a year ago. Wanted to setup a shack near Lake Louise and spend a few years off the grid.
    08-09-11 12:18 AM
  2. bbbeliever's Avatar
    Also, when opening Gmail- main screen opens, but when you select an e-mail, it resets the app. Any suggestions? I followed the steps exactly how the video showed... THANKS!
    08-09-11 09:07 AM
  3. bbbeliever's Avatar
    also, when I open ASTRO, i get the following message: "error creating external cache"... again, any ideas?
    08-09-11 09:13 AM
  4. HaTaX's Avatar
    Also, when opening Gmail- main screen opens, but when you select an e-mail, it resets the app. Any suggestions? I followed the steps exactly how the video showed... THANKS!
    Take a look at the OP of this thread again and look at the bottom of that post. Gmail has some known issues for now. If you want to read your Gmail in the android player, I'd recommend K-9 mail for the time being.

    also, when I open ASTRO, i get the following message: "error creating external cache"... again, any ideas?
    Normal error message, the cache file system in the android player is wonky. This is just a side effect of it and won't cause any problems in the operation of the app.
    08-09-11 10:57 AM
  5. stesyl's Avatar
    Android player and Marked installed fine, but is very very unstable. I know it's a leaked version, but is anyone else having to reboot due to numerous freezes?
    08-09-11 11:55 AM
  6. HaTaX's Avatar
    Hmm, sounds like you're moving too quickly when it starts up. If you start going into apps before it's ready for that you'll run into problems. When I start it up I get to the application list quickly, then I wait to be notified of email, and I make sure that the list is done "resetting to the top of the list" by scrolling down a few lines and keeping an eye on it.

    If you let it startup at it's own pace and don't rush it at first, I've had a pretty stable experience with it...
    08-09-11 11:57 AM
  7. djdesloges's Avatar
    WooHoo! I got it all working Thanks so much HaTaX!!
    I was stuck on "Insufficient Storage" as well when installing.
    My download folder also had d-- permissions but I couldn't delete or move the folder.
    I had to close the Android Player and use PlayBook's Airbrowser to rename it.
    I then connected to the Playbook via wifi this time and created the folder.
    Checked the permissions in Astro and it was correctly listed with drw.
    Install worked successfully.
    08-09-11 12:00 PM
  8. Rasta-j's Avatar
    I've gotten that error before when I try to rush into the marketplace after starting the player up. Let the player settle in for a minute or two before you launch marketplace. Otherwise the background services aren't ready yet and you'll get some funky errors until you reboot the device.

    Give it a reboot, load up the player, wait a min or two, and then give market another shot and see what happens.
    Hi HaTaX,

    Thanks, but I have now started from scratch again following all the steps and waited 5 to 10 minutes between all the steps just to be sure that everything initializes.

    I get all the messages and the notifications as in your Video but it just goes to the same screens as given in the screenshots.

    If I load .apk files manualy all seems to work without the player crashing but just cant get Market to work while everybody is enjoying
    08-09-11 12:09 PM
  9. PatrickMJS's Avatar
    hey AshDrizzle: gosh aw shucks! Thx for offsetting my self-deprecating language.

    And Hatax, you're right - Lake Louise is one of the sweetest places I know. If youre headed back up this way, I'd be happy to give you a few tips on our other local sweetspots.

    Now back to the android market...
    08-09-11 12:24 PM
  10. sterling_bandit's Avatar
    Hi Hatax, may I start of by thanking you for your hard work over the last few weeks on andriod player. I have read your advice to others and am still at a snag point.

    Via USB I have the following
    Misc>android>where I find>alarms>apks>google>notifications>ringtones. I deleted the download folder that was located here.

    And created one within the apks folder, was this correct? I was having an insufficient storage notification prior to creating download folder within apks, that's no longer popping up as I download, however, when I attempt to download an app, I get a notification in the top left corner of PB that says "installation" and that it.

    I have look for the downloaded apps in the new folder location and its empty?

    However in the market place, when I select my apps all the apps I attempted to download are here but not installed in android player.

    Could you tell me how file structure is supposed to be please? and location of download folder.

    On opening Astro I have 2 download folders in /sdcard and another with apks, tried deleting the other 2 folders but they just pop back on closing android player.
    08-09-11 12:41 PM
  11. KES16's Avatar
    When I go to accounts and sync and setup a new account, it does not come up with corporate or Google. It just trys to get me to setup an Exchange account... Any help?
    08-09-11 12:43 PM
  12. HaTaX's Avatar
    When I go to accounts and sync and setup a new account, it does not come up with corporate or Google. It just trys to get me to setup an Exchange account... Any help?
    That means the framework files from my zip file weren't properly installed. Did you load them in order in Astro as shown in the video?
    08-09-11 12:54 PM
  13. IvanAMANation's Avatar
    Hey HaTa, sorry to bother you again. But do you know why I cant open my emails from gmail? It shows the notification and i can see all the messages in my inbox, but I cant open them. Does Calenders work? I can see the days months ect, but i cant put a apointment.

    When I have my browser and APlayer open sometimes my browser would crash, probablh due to low ram.. The AP takes up a lot of ram right?
    08-09-11 01:54 PM
  14. HaTaX's Avatar
    Hey HaTa, sorry to bother you again. But do you know why I cant open my emails from gmail? It shows the notification and i can see all the messages in my inbox, but I cant open them. Does Calenders work? I can see the days months ect, but i cant put a apointment.

    When I have my browser and APlayer open sometimes my browser would crash, probablh due to low ram.. The AP takes up a lot of ram right?
    In the OP down at the bottom of the post there's a notice that GMail doesn't work properly right now. Easiest workaround is K-9 mail until I have a chance to tear into it.

    And yeah, I have about 250mb free memory with the android player open, it's kind of a hog. They also increased the memory available in the player beyond a normal android device, so that may have something to do with it.

    If you downloaded my Playbook_tools.zip file there should be an app called SimpleBrowser in there. It's a bit more frugal with memory then the stock browser, so it might be worth a shot to see if it would stay running. It looks like they're in the final stages of the review process now, so it might even be on app world shortly.
    IvanAMANation likes this.
    08-09-11 02:02 PM
  15. IvanAMANation's Avatar
    Cool, thanks, H.
    08-09-11 02:14 PM
  16. FrankSeg's Avatar
    I am having troubles installing Astro.apk. When I type "file://sdcard/apks/Astro.apk" in the browser and hit "go", it returns an error: "Problem with file The requested file was not found/ /accounts/1000/appdata/sys./android<longcode>.ns/sdcard/apks/astro.apk (No such file or directory". I checked on the network share and the file astro.apk is in the apks folder, but the Android-browser seems to miss it. Any solutions?
    08-09-11 02:56 PM
  17. HaTaX's Avatar
    I am having troubles installing Astro.apk. When I type "file://sdcard/apks/Astro.apk" in the browser and hit "go", it returns an error: "Problem with file The requested file was not found/ /accounts/1000/appdata/sys./android<longcode>.ns/sdcard/apks/astro.apk (No such file or directory". I checked on the network share and the file astro.apk is in the apks folder, but the Android-browser seems to miss it. Any solutions?
    See the difference in bold? Try "astro.apk" in the browser, all lower case. Remember, anything but windows is picky with letter case!
    08-09-11 03:05 PM
  18. FrankSeg's Avatar
    Actually, I noticed the difference. At first I had a "astro.apk" in that folder and I typed it with lower case. Got the same error message. After browsing another topic, I came across GApps-GB-Rev1.zip, which contained "Astro.apk". I copied that over the astro.apk and retried, now with "file://sdcard/apks/Astro.apk", so in both cases I got the same error. I also checked with the Air Browser if the file was on the PB - and it was - but the Android-browser cannot find it.
    08-09-11 03:10 PM
  19. FrankSeg's Avatar
    I attached 2 screenshots, one with the error, the other one showing that the file is on the PB.
    08-09-11 03:21 PM
  20. HaTaX's Avatar
    I attached 2 screenshots, one with the error, the other one showing that the file is on the PB.
    Now I see it, you need "file:///" (Three "/"s).
    FrankSeg likes this.
    08-09-11 03:28 PM
  21. pchan8888's Avatar
    Hey HaTaX- Excellent Job!!!
    I had several issues that were listed already by other users ie. d-- folder, the gmail, and some occasional crashes/force quit or wait when navigating too fast. Thus far, the Android player seems a bit slow to reboot (choosing the Set Home View- Installed Applications)... it needs to have a very good wifi connection, gmail need to sync properly before the market would load, and to give the Android Player some time to have it "settle in" before choosing and pressing the next menu. I hope this will not be the case with the official release.

    Questions: When the "official" Android Player gets released. What would be the correct way to delete this version? Will it be a Security Wipe? or can it be just trashing it? and will that pesky "download" folder that had to be renamed and moved because of the lack of permission (d--) can be deleted properly?
    08-09-11 03:31 PM
  22. FrankSeg's Avatar
    That's it! Thanks a lot. I should have seen that myself...
    08-09-11 03:33 PM
  23. HaTaX's Avatar
    Hey HaTaX- Excellent Job!!!
    I had several issues that were listed already by other users ie. d-- folder, the gmail, and some occasional crashes/force quit or wait when navigating too fast. Thus far, the Android player seems a bit slow to reboot (choosing the Set Home View- Installed Applications)... it needs to have a very good wifi connection, gmail need to sync properly before the market would load, and to give the Android Player some time to have it "settle in" before choosing and pressing the next menu. I hope this will not be the case with the official release.

    Questions: When the "official" Android Player gets released. What would be the correct way to delete this version? Will it be a Security Wipe? or can it be just trashing it? and will that pesky "download" folder that had to be renamed and moved because of the lack of permission (d--) can be deleted properly?
    The pesky download folder will most likely remain. Best way to get rid of it in my opinion is to make sure you have a copy of everything available over the file share, do a backup of just apps and settings, NO media. And then do a wipe and restore the backup you just made. The android folder is part of the media backup, so if you leave it behind you should have a clean slate, and then you can copy all of the stuff you manually copied earlier.

    Just trashing the player app is enough to get rid of it, but it might take a reboot, and then deleting the ghost icon left behind. After that it's gone for good. And the final product should be much better performing. Currently lots of logging is turned on and the file structure isn't complete (missing /cache is the cause of lots of apps not working). That stuff should be cleaned up in the final version, and of course not having the google framework in there will speed things up a bit.
    pchan8888 likes this.
    08-09-11 03:40 PM
  24. pchan8888's Avatar
    Thanks HaTaX for the quick response!!
    When I had to reinstall a fresh copy of the Android Player, I deleted the old one by going into the Setting/Applications/Manage applications then unstalling the individual Android apps first and then trashing the Android Player on the Playbook's main screen. Didn't want to wipe the Playbook clean due to me being lazy. When the Android Player was reinstalled, I did find empty folders that were still around belonging to the deleted apps that were sideloaded previously. Was this the same situation for you? I assume I can manually delete these folders via file share (I have not tried this yet). Have you heard anything yet from RIM???
    08-09-11 04:26 PM
  25. jugs's Avatar
    Thank you for the tutorial! It worked great with the troubleshooting tips.
    08-09-11 04:43 PM
233 ... 45678 ...
LINK TO POST COPIED TO CLIPBOARD