06-26-12 09:14 AM
233 12345 ...
tools
  1. HaTaX's Avatar
    FIRst I wonna say thanks for taking the time to create these instructions....

    I think I did everything correctly, APLAYER and my email is working. But, when I go to browser and type the sdcarfile astro address thingy, nothing pops up.

    It says "The requested file was not found. /sdcard/apks/astro.apk (no such directory)" Any clue on why?

    UPDATE: I see the astro.apk in the APK folder on my pc in the Misc file but for some rason my PB doesnt havent installed.maybe I didnt install it correctly?
    If it's just in the "misc" folder then you won't be able to find it, it needs to be in the "android" folder underneath that for the player to see it. Additionally, it should be in a "apks" folder in the "android" folder, that's where the instructions expect it to be placed.
    08-07-11 01:46 PM
  2. IvanAMANation's Avatar
    When I view it on the Explorer this is how it looks...

    Playbook>Media> Misc>Android>GApps-pb-rv2>apks> then its a paper icon that named astro.apk

    Is that the correct order?...

    TY for your patience, I know you must be going nuts
    08-07-11 01:57 PM
  3. HaTaX's Avatar
    When I view it on the Explorer this is how it looks...

    Playbook>Media> Misc>Android>GApps-pb-rv2>apks> then its a paper icon that named astro.apk

    Is that the correct order?...

    TY for your patience, I know you must be going nuts
    There's the problem in bold above, it should be just:
    Playbook>Media> Misc>Android>apks>
    08-07-11 02:00 PM
  4. IvanAMANation's Avatar
    should I delete it and reinstall it?
    08-07-11 02:04 PM
  5. HaTaX's Avatar
    should I delete it and reinstall it?
    Nah, just move the "download", "apks", and "google" folders down a level through the file share. (Select them all and cut and paste them under the "Android" folder)
    08-07-11 02:09 PM
  6. IvanAMANation's Avatar
    U mean put them IN the "Android" folder right, where the Notifications, and Ringtones folders are at?
    08-07-11 02:13 PM
  7. HaTaX's Avatar
    U mean put them IN the "Android" folder right, where the Notifications, and Ringtones folders are at?
    Correct.
    08-07-11 02:14 PM
  8. Wolfgan's Avatar
    Is gmail working properly for everyone?

    I cannot read emails. All my mail is present. I can send email too. But, when I try to read an email, the message appears to pop up in a flash and then close. If it is a new email, it does not change from unread to read. So, there is some obstacle about viewing email for me.


    This happened with the old version of the install also. I did a complete reinstallation of the bar file and it still happens.

    Any ideas?
    Same here, can't read as the content window just flashes in and out returning to the email list...

    BTW, thanks HaTaX for the hard work in putting this all together.
    Wolf
    08-07-11 02:18 PM
  9. IvanAMANation's Avatar
    shoot, still nothing. IDK whats going on
    08-07-11 02:25 PM
  10. IvanAMANation's Avatar
    for some reason the file that was in the apk folder is gone, cant find it anywhere
    slyder3d likes this.
    08-07-11 02:27 PM
  11. HaTaX's Avatar
    for some reason the file that was in the apk folder is gone, cant find it anywhere
    Just start over with the instructions and re-extract the GApps-PB-rev2.zip file where they belong. If you're right click dragging it to that folder and using winrar, you want to choose "Extract files here" when right click dragging to the "Android" folder.
    08-07-11 02:31 PM
  12. HaTaX's Avatar
    Also, just a note on the GMail app not working properly. It's kind of a lower level issue with HTML panes. I'll look into why the GMail app does this and possibly release a patched version that just displays plain text for now. RIM probably did something goofy in there and maybe they've done something crazy like try to use the QNX html rendering engine instead of the Android one.
    08-07-11 02:33 PM
  13. lawguyman's Avatar
    I've installed the K-9 email client and it works just fine with gmail.
    08-07-11 02:35 PM
  14. IvanAMANation's Avatar
    It worked bro, thanks a million, for real. If u had or are going to develop some apps, let me know, I'll support u.


    *Bonus Question*... Whats the best and quickest way to learn how to develop Apps? I know nothing at all, I just need someone to pint the way..

    Thanks again
    HaTaX likes this.
    08-07-11 02:37 PM
  15. dana_lopez's Avatar
    Hey HaTaX,

    First, thanks for the great instructions. I was able to get the player load in the first shot and had none of the errors previously reported.

    My only question is on the apps. I haven't been able to get a single one to run other than Jewels from the demo. Angry Birds, Scrabble and Wordfeud all give an error that the process had stopped and they force close. CBS Big Brother runs but then tells me I need Flash 10 installed, which I do.

    So, is it just hit and miss with apps working in the player or do you think something actually did go wrong with my install?

    Thanks!!
    Last edited by dana_lopez; 08-07-11 at 03:51 PM.
    08-07-11 02:41 PM
  16. HaTaX's Avatar
    It's hit or miss with apps, most of them that rely on hardware graphics acceleration don't work. Also quite a few apps with "lib" dependencies seem to have problems.

    All of the apps you've listed I've tried and had issues with. FWIW, words with friends works quite well. Also, flash doesn't work right inside the Android player currently, not sure if that's something they'll fix or not honestly...
    rbe1733 and dana_lopez like this.
    08-07-11 03:54 PM
  17. rbe1733's Avatar
    Hi HataX,

    Thanks a lot for this great feature.
    I had waited for a long time RIM with this update, but you did it before, even if it's experimental. Thanks to you, i have now an SSH client (none exists in AppWorld) to connect to my servers.

    SSH client works like a charm into the player (ConnectBot).

    Have noticed several things playing this android emulator :

    - before rebooting the PB, the changes on the parameters (language for example) were not saved when you exited and load the Android Player. After a soft reboot, parameters are ok.

    - some applications (using network like streaming audio) failed with a weird error when i was far from my wi-fi router. Getting closiest, and it works fine. It also applies to Android Market.

    - when i use Astro, i have a lot of duplicated folders on the root (base, bin, ..). It looks like a fusion display between the playbook tree and the one from the android player (i guess).

    Some questions :

    - Does the PB GPS works in Google Maps or other software using GPS ? Very rainy today and run my tests inside.

    - Has someone tried the VPN feature of the Android Player (it enables PPTP VPN - RIM doesn't :=((( As for me, i haven't yet succeeded in establishing a connection.

    Great work HataX, again thank you a lot.
    HaTaX likes this.
    08-07-11 04:58 PM
  18. Jerry Hildenbrand's Avatar
    Tip for hanging downloads from Market (and Google account sync in general)

    Before you attempt to use the Market or any Google services, always open Talk and sign in.
    08-07-11 05:07 PM
  19. HaTaX's Avatar
    Quite a few of the settings don't take right until the player is restarted, just seems to be the way it is for now. At least it's a simple fix and takes under a minute.

    The entire Android player doesn't work right if wifi is off or not connected. They've built a lot of dependencies on having an active wifi connection that really causes problems when it's not there.

    Astro shows duplicates because of the asynchronous file system used on the PB. Android normally uses a different file system and because of that you'll see duplicates listed. They point to the same place, it's just not reading that they're the same folder correctly. Purely aesthetics right there.

    GPS does work in the Android player! I've done this little trick to get it working every time. Open up google maps / nav so it's looking for a GPS signal, then minimize the android player and go open bing maps. Have bing locate you, once it has you can go back to the android player and it will be loading your location.

    Haven't tried vpn, but I would guess it would have trouble passing the GRE packet needed for pptp. Maybe give L2TP a shot? It only uses TCP/UDP traffic and might actually work.
    08-07-11 05:08 PM
  20. HaTaX's Avatar
    Tip for hanging downloads from Market (and Google account sync in general)

    Before you attempt to use the Market or any Google services, always open Talk and sign in.
    Good advice, Talk is actually a pretty integral service for this all working. Google divided up the framework tasks across these apps and a good portion of the download management is in the Talk app.
    08-07-11 05:09 PM
  21. chmb1's Avatar
    This worked perfectly. Thanks!

    "Figured it out. For those of you having the issue, this is what I did, I am sure some of these steps are unnecessary but it worked and fixed the issue:


    1. Close market place and the android app player
    2. Send a test email to your gmail account (from a different account).
    3. Open the test email from the notification.
    4. It will probably glitch (mine did) swipe back to the home screen of app player.
    5. Next open the Gmail app and view the email.
    6. Now close the email and go to the Market Place.

    That got mine working, kind of weird maybe the google sync needed to be verified or something but I am in operation. Should also add make sure you follow Hatax's procedures to a tee because I did that as well."
    Last edited by chmb1; 08-07-11 at 05:14 PM.
    08-07-11 05:12 PM
  22. Erandhawa's Avatar
    Hey HaTaX,

    First, thanks for the great instructions. I was able to get the player load in the first shot and had none of the errors previously reported.

    My only question is on the apps. I haven't been able to get a single one to run other than Jewels from the demo. Angry Birds, Scrabble and Wordfeud all give an error that the process had stopped and they force close. CBS Big Brother runs but then tells me I need Flash 10 installed, which I do.

    So, is it just hit and miss with apps working in the player or do you think something actually did go wrong with my install?

    Thanks!!

    Not all apps will work, its hit and miss you just have to try it and see. Thats an issue with compatibility and the apps not being able access the hardware fully yet. Its more of the app player development that needs to be fixed, i am sure rim is going to try to make things more compatible.
    08-07-11 05:28 PM
  23. pkcable's Avatar
    Got it working!!!!!!!!
    HaTaX likes this.
    08-07-11 05:50 PM
  24. HaTaX's Avatar
    Got it working!!!!!!!!
    Good to hear! And thanks for the sticky! Heh, I actually was looking for it after a refresh going, "wtf, did it get moved to the other forum?" Then I noticed it up near the top.
    ericlc2 likes this.
    08-07-11 06:02 PM
  25. pkcable's Avatar
    08-07-11 06:11 PM
233 12345 ...
LINK TO POST COPIED TO CLIPBOARD