1. FF22's Avatar
    When Air Browser is running in the foreground it appears that my pb does not enter Standby mode. The screen remains on.

    Anyone else notice this behavior?
    09-07-11 08:03 PM
  2. peter9477's Avatar
    F2, I haven't seen that yet, but will test. If it's because of the standard "keep awake" mechanism, and for some bizarre reason they've turned that on, you can test for it the following way:

    1. Put PlayBook in either Default or Showcase mode, but not Paused mode.
    2. Run AIR Browser.
    3. Minimize it by doing a bottom-swipe, but leave it visible and do not switch to another app.

    If it's the standard "keep awake" provided by the AIR API, which is currently the only known way to prevent Standby mode other than running videos, it works when the app is both active and visible. All apps are "active" even when minimized in Showcase mode, and in Default mode the last app that was fullscreen stays as the "active" app until any other is made fullscreen. The above sequence should be an adequate test to confirm the "keep awake" setting is the cause.
    09-08-11 07:21 AM
  3. FF22's Avatar
    Okay, did a series of tests leaving my PB in Showcase mode.

    Starting from nothing running - standby and screen off worked in my 3 minute setting. Opened Air Browser and running full-screen, standby/screen did not turn off after 17 minutes. Reduced Airbrowser to "shrunk" but only thing running. Again, NO standby after about 9 minutes.

    Opened Internet Browser full screen with Air Browser still in background - no Standby. Shrunk Browser so both it and AirB were small. No standby.

    Closed AirBrowser - Standby kicked in after 3 minutes.

    Curious if others have tested in any fashion.
    09-08-11 12:01 PM
  4. peter9477's Avatar
    F2, what you've described is almost, but not, consistent with the keep-awake setting. When you had the browser fullscreen and Air Browser is not visible, it should have gone to sleep.

    What you're seeing is inexplicable if your measurements are correct, unless you had something in the browser (video playing?) that was also keeping it awake.

    I just tried it myself, however, with backlight timeout on 10s and standby on 30s (the minimums). With any portion of the AIR Browser's window visible, it prevents the timeout, but if I launch the web browser and have it fullscreen, the tablet DOES go to sleep. (It's much faster testing with backlight on 10s, because with the keep-awake setting, it even prevents the backlight from going off.)
    09-08-11 12:28 PM
  5. FF22's Avatar
    The only thing running in the browser was my homepage - just an html table of links that I visit frequently. I just left that showing and did not use the browser in any other way.

    I will do more testing.
    09-08-11 01:22 PM
LINK TO POST COPIED TO CLIPBOARD