1. Wilson7777's Avatar
    Has anyone had any luck with running the Android version of Citrix Receiver? I am currently running version: 3.2.36. I can see my apps but can't run any of them.
    The reason I am not using the native PlayBook app is because we only have Citrix standard version, not Enterprise. Citrix Receiver for PlayBook can only work with Enterprise (which sucks!)

    I am currently trying to launch apps on my PlayBook but it keeps telling me that the server certificate is not trusted. I press the Accept button and it tries to launch the citrix app, but then it gives me another error stating: "cannot verify this server's certificate". I tried importing the certificates to the PlayBook that we are using, but that did nothing.
    We have some Android tablets and they all work with the same version of Citrix Receiver without an issue. Same with iPad's. I'm dying to get this working since it would be a super powerful app to have, plus I'm pro PlayBook =))

    Any help you can provide would be great!
    12-28-12 09:14 AM
  2. Sysgen's Avatar
    Where did you read that it only works with enterprise edition of citrix? I'm pretty sure that we do not have enterprise at the office and I'm using citrix quite often. You also need a valid certificate, I could not make it work without that. We have citrix 4.5 by the way, that might be the difference.

    Good luck
    12-28-12 10:59 AM
  3. Wilson7777's Avatar
    Thanks for the quick response!

    I have the native app installed still as well. When I press add an account and type in the URL of the Access Gateway. https://ssl.xxxxxxxx.com, it returns the following error:
    "Access to Gateway Standard Edition server is not supported. Please contact your help desk (which is me, lol)" I believe we are running either 4.5 or 4.6.3 but I did not install it originally. Citrix Receiver version:

    I have imported 2 certificates on the PlayBook. The "web certificate" and the "intermediate" and "root" certificates.
    12-28-12 11:22 AM
  4. Sysgen's Avatar
    I do not use the access gateway, do have that? That usually is an appliance separate from the citrix server,

    What I did is install the Citrix secure gateway on the citrix server itself. then in Citrix receiver when it asks for the server I type in the https://address of my citrix server
    Username, password, domain, I leave Use Citrix Access Gateway and Web Interface unchecked and that's it.
    12-28-12 02:37 PM
  5. Wilson7777's Avatar
    I do have the Citrix Secure Gateway installed on the server and did the same steps on the Android app I sideloaded. I can't even get that far on the native app.

    It has something to do with the Certificates on the server but I don't want to start playing around with them since every other device works except the PlayBook. It's extremely annoying!!

    Did you import any certificates to your PlayBook?
    12-28-12 02:53 PM
  6. Sysgen's Avatar
    Are you using self signed certificates? If you do then yes, you need to install the root and intermediate certs on the PlayBook, if you have an official cert then you dont need to install anything on the playbook.

    Are you checking "use access gateway" on on the client? It wasn't clear in your answer, uncheck that if you are using then secure gateway.
    Last edited by Sysgen; 12-28-12 at 03:48 PM.
    12-28-12 03:20 PM
  7. Wilson7777's Avatar
    I installed both certificates on the PlayBook as well as a bunch of other ones that I thought might help.

    I have tried changing the "type". By default its set to Access Gateway but I don't have an option for "Secure Gateway". Here are my other options:

    XenApp Services
    Web Interface
    Access Gateway

    I tried them all. Storefront doesn't work at all and neither do the other ones, they all give me the same error.

    When I choose Access Gateway for the type, it gives me the choice to pick Standard, Advanced, or Enterprise. So I pick Standard.
    It also give me Authentication Type: Domain Only, Domain + Security Token. I choose Domain Only.
    12-28-12 03:34 PM
  8. Sysgen's Avatar
    Is this with the android client, i've never seen these options !

    Uncheck them all and that should give you secure gateway. After that i'm out of ideas, but it works for me no problem so somethings missing on your citrix server.
    12-28-12 03:47 PM
  9. Wilson7777's Avatar
    Yeah, it's with Citrix Receiver for Android. As I said, Citrix Receiver app for PlayBook only works with Enterprise versions which I don't have....as soon as I enter the citrix server address it tells me to go F myself because I don't have Enterprise. I'm not sure how you got it to work unless your Citrix is Enterprise version.

    Personally, I think I'm screwed. I think my only hope is Citrix comes out with a new Receiver for BB 10 and hopefully I can update the PlayBook to BB 10 as well....

    Thanks for your help.
    12-28-12 04:00 PM
  10. Sysgen's Avatar
    Do you know how to check what version of citrix you have, like i said i'd be surprised if that's what i have.
    ,have you tried with the native one to enter the server and uncheck use access gateway?
    12-28-12 04:14 PM
  11. Sysgen's Avatar
    Ok, just checked and I do have enterprise
    12-28-12 04:18 PM
  12. Wilson7777's Avatar
    Wish I had Enterprise too! It's too bad I can't figure out this certificate problem for the Android app, but I don't know enough about certificates to really get into it......
    12-28-12 04:20 PM
  13. Sysgen's Avatar
    What steps are you using to import the certificates? Do they now appear under settings-security-certificates?
    12-28-12 05:32 PM
  14. Wilson7777's Avatar
    I imported the certificates using usb. I put them in the certs folder, and then used import. They both imported as intermediate certificates. Onewas called sites bundle which I assume contains the verisign certificates. Also put the ssl certificate on for the actual server website. I don't know. I must be doing something wrong, but not sure what. Both did import but as intermediate certificates.
    12-29-12 11:51 AM
  15. Sysgen's Avatar
    That seems correct as far as I can tell. Maybe others can chime in.
    12-29-12 01:40 PM
  16. Wilson7777's Avatar
    I hope so. There must be others who have run into similar issues like this.
    12-29-12 02:29 PM
  17. Wilson7777's Avatar
    Can anyone else help me with this please?
    12-31-12 12:02 PM
  18. ShvartzBerry's Avatar
    I'm pretty sure I know why this is happening. I had the same problem myself. While Googling around I found someone saying to make sure that the time on your device is correct or you will get the certificate error. No, my experience with Waze - a lousy Android port at best - as well as others is that the ETA is shown in GMT time. That leads me to believe that there is an error/bug that does not allow Android apps to get the right time in BB10's Android environment. If that's the case, I don't think there's anything you'll be able to do about it. Just one of the BB10/Android quirks. Just for fun I tried messing around with the time and time zones but not fool the app into working.
    06-17-13 04:48 PM

Similar Threads

  1. Citrix Receiver for BlackBerry PlayBook - Now Available
    By Buzz_Dengue in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 09-13-11, 03:15 PM
  2. Citrix Receiver for Blackberry now available
    By thehawkins in forum BlackBerry OS Apps
    Replies: 2
    Last Post: 07-08-10, 03:33 AM
  3. Citrix Receiver for Blackberry
    By NetworkGuy in forum BlackBerry OS Apps
    Replies: 2
    Last Post: 05-27-10, 10:29 AM
  4. Want to get a GPS receiver for my Pearl 8100...
    By jacaranda1 in forum General BlackBerry Discussion
    Replies: 0
    Last Post: 11-08-07, 07:26 PM
  5. GPS receiver for 8830
    By MOFO in forum BlackBerry Curve 83xx
    Replies: 1
    Last Post: 09-22-07, 12:57 AM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.