1. bgalakazam's Avatar
    The Q10 is offered officially by 2 of the 3 operators in Bulgaria. Mtel and Vivacom don't have this problem. I have an unlocked Q10 from T-Mobile USA, SQN-5.

    With Globul, when you enable data, it takes 5-10 minutes to connect to the network. In this time it jumps between h and H and really drains the battery. (problem occurs for gprs and edge). If your connection drops due to tower change or elevator, you wait again. Additionally. H really drains the battery fast in a few hours and phone is always hot. (os 10.2.1). I was told by their reps it's a problem they reported with RIM. Strange how the other 2 operators don't show this issue.

    Only reason I'm with them is they will supposedly have LTE by January 2015 and I hope the problem will be resolved by then. I also signed a contract so...

    Sent from my Q10
    08-11-14 11:44 PM
  2. masterscarhead1's Avatar
    When the phone works with every network BUT yours, it means it's something wrong with YOU and not RIM
    Then again, carrier customer support usually have no idea what is going on. I would switch carriers if you are not under contract.
    It's just like some carriers won't get BB services while others will. The carriers who don't aren't setting something up correctly. Telling RIM about it and wanting them to fix an issue on your end just won't happen
    08-12-14 01:13 AM
  3. zhekov's Avatar
    I'm globul Bulgaria costumer, I don't have any problem with the carrier, I currently use BlackBerry Q10

    Posted via CB10
    08-29-14 06:03 AM
  4. bgalakazam's Avatar
    Zhekov, I assume you have the European version SQN100-3, is this correct? If that is true, thhen the problem _may_ be related to my USA version SQN100-5. However, there is no problem with Mtel or Vivacom, so I doubt it.

    Can you please also tell me your APN settings under 'Networks and connections' - 'Mobile netwrok'? I use globul in the fields, but altering doesn't help.

    Posted via CB10
    09-10-14 07:00 AM

Similar Threads

  1. case for bb z10 with extended battery
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 08-14-14, 03:43 PM
  2. 10.2.2 and BlackBerry Link sync problem.
    By akavbb in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 08-12-14, 01:40 PM
  3. Replies: 3
    Last Post: 08-12-14, 08:03 AM
  4. Replies: 5
    Last Post: 08-12-14, 12:11 AM
  5. Help with Gmail on Sprint 9350
    By Hvacmanjc in forum BlackBerry Curve 9370/9360/9350
    Replies: 1
    Last Post: 08-11-14, 07:52 PM
LINK TO POST COPIED TO CLIPBOARD