1. ScreenProtectors's Avatar
    We keep having signal issues since switching from Orange to EE...

    The signal keeps dropping off all the time during calls, Is anyone else having the same issue?
    04-03-13 05:05 AM
  2. pkcable's Avatar
    We keep having signal issues since switching from Orange to EE...

    The signal keeps dropping off all the time during calls, Is anyone else having the same issue?

    Can anyone help here?
    04-09-13 01:36 PM
  3. Yandar's Avatar
    I have the same problem as well on Orange/EE.
    05-26-13 06:08 PM
  4. TallPaul86's Avatar
    I wouldn't say I've had problems with the signal itself dropping however I do notice the data connection swapping about a lot for no apparent reason...

    For example, when I'm in Glasgow City Centre I receive 4G however the slightest movement loses it and then it's a constant change between H+ to 3G to E and then all the way back up to 4G again

    And when I'm at work in Livingston then there are days where the data connection is totally fine then one day it just drops to Edge connection... the only way for me to get back my 3G or H+ connection is to either connect to a WiFi signal then disconnect from it or switching the phone into airplane mode and then back on again

    Posted via CB10
    06-01-13 04:00 AM
  5. Craigash's Avatar
    Thus is the reason I'm not on EE. EE 4G is not everywhere, so your not always in a 4G area, hence it switching back and forth. As I'm on Orange, I'll just wait until 4G becomes available on all Networks as it'll be a lot cheaper as well.

    Posted via CB10
    06-15-13 08:22 AM
  6. simonpater's Avatar
    Same here signal is terrible in Liverpool!!

    Posted via CB10
    07-20-13 06:50 AM
  7. bigglybobblyboo's Avatar
    Signal at the minute is all over the place. The majority of our phones at work are EE/Orange and it's very hit and miss. That said, we've a minority on O2 and they seem to be just as bad!

    Feel it, Swipe it, Love it. BlackBerry Z10...
    07-24-13 12:01 PM
  8. Simon Beddows's Avatar
    Yes, I keep losing signal altogether!! Goes to sos for 5 mind at a time. Getting annoying now!! Paying 46 a month for no signal. Struggling to get through to the f***ers!!!!

    Posted via CB10
    08-26-13 02:44 PM
  9. Argyle_86's Avatar
    Signal is bad as they failed to add enough back end haul on voice (huge problem in london), plus they have decommissioned some masts whilst upgrading them with improved signal. I find that most cities that are starting to push 4G are having problems with voice more than anything!

    Posted via CB10
    11-28-13 03:28 AM

Similar Threads

  1. Anyone having problems with Gmail, Push Email
    By Rayford Booth in forum Rogers
    Replies: 27
    Last Post: 04-04-13, 07:41 PM
  2. Replies: 5
    Last Post: 07-16-09, 06:08 PM
  3. Anyone having problem with viigo today?
    By thapharm in forum BlackBerry OS Apps
    Replies: 10
    Last Post: 04-13-08, 06:39 PM
  4. Anyone having problems with faceplate/housing?
    By siwelk in forum BlackBerry Curve 83xx
    Replies: 9
    Last Post: 03-09-08, 03:28 PM
LINK TO POST COPIED TO CLIPBOARD