1. anon(9249664)'s Avatar
    ...
    Last edited by genito66666; 01-08-21 at 12:13 AM.
    12-26-14 07:36 AM
  2. jaydee5799's Avatar
    I think the minimum for Viber is OS 10.2 I could be wrong but maybe your OS is not updated enough for it.
    12-26-14 08:34 AM
  3. MobileMadness002's Avatar
    Hello! I have an issue. Whenever i try to install viber, it says its unavailable for my device. I have a Cruve 8520 with the newest update for it. Running OS 5. Tried using different wifi, sim card for internet, nothing works. Please help!
    Well after taking the 2 minutes to locate it on BBAW, it clearly shows the 8520 as being compatible. What device does BBAW show as being active, it could be detecting another device if it is using the same BBID.
    12-26-14 09:49 AM
  4. anon(9249664)'s Avatar
    ...
    Last edited by genito66666; 01-08-21 at 12:13 AM.
    12-27-14 04:22 AM

Similar Threads

  1. Replies: 19
    Last Post: 02-09-15, 03:21 AM
  2. Why can't I install this app/software on my Playbook?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-26-14, 08:15 AM
  3. BlackBerry App Roundup for December 26, 2014
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 12-26-14, 06:40 AM
  4. Replies: 1
    Last Post: 12-26-14, 06:35 AM
  5. Snap v3 still in the works but not quite ready just yet
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 12-26-14, 06:22 AM
LINK TO POST COPIED TO CLIPBOARD