1. HaroldM's Avatar
    I recently bought a BB 7290 from someone on eBay. The lady has been real helpful as well but I'm out of ideas as is T-Mobile. She said that the BB worked fine last time she used it before upgrading to the 8800 model. The problem I'm having is I cannot get the BB 7290 to get a signal at all. No matter what I try. I called T-Mobile to no avail. They added the IMEI # on my account no luck. Tried updating the software on the BB. No luck there. Any ideas? Luckily the seller will take it back if I can't get it to work but I'd rather not have to as I've been waiting a while for a new BB to replace an older one that got stolen a year or so ago. Thanks in advance for any help. Oh one other thing. I can't even get Manual network selection to work. It finds no networks. And I know it's not my area because if I pop in the SIM card into my Motorola RAZR phone I get signal right away. Thanks again in advance.
    09-22-07 04:48 PM
  2. jcj1's Avatar
    would seem to be an antenna problem and can see about repair from RIM
    10-10-07 07:08 PM
  3. plinkous's Avatar
    ok now while i do know that i am new here.

    i do have one question for you, did you turn on the radio for this 7290?

    the reason that i ask is that when i got mine i fought with it for 2 days till i figured out that it would not get any signal till i turned on the radio.
    11-03-07 02:46 PM
  4. dojoe's Avatar
    Don't know if this works for all bb's but my blackberry 8320 was giving me no service problem so i just passed some rubbing alcohol on the board and i also heat up the area (RF test port )with a soldering gun and i got service back.Sometime the board has dried solder and prevents the parts from working. It just need a little heat..
    10-24-11 01:37 PM
LINK TO POST COPIED TO CLIPBOARD