1. imradlol's Avatar
    I've been wracking my brain over this...I'm trying to upgrade my 6710 from os 3.7 to 4.0. I downloaded the upgrade exe and installed it, but I can't seem to figure out how the heck to load it on. I've tried desktop manager 3.7 and 4.5 but I still can't get it working. I'm using a usb to serial adapter to connect it via dock to my windows xp laptop.

    Am I doing something wrong here?

    Posted via CB10
    03-08-20 03:52 PM
  2. Chuck Finley69's Avatar
    I've been wracking my brain over this...I'm trying to upgrade my 6710 from os 3.7 to 4.0. I downloaded the upgrade exe and installed it, but I can't seem to figure out how the heck to load it on. I've tried desktop manager 3.7 and 4.5 but I still can't get it working. I'm using a usb to serial adapter to connect it via dock to my windows xp laptop.

    Am I doing something wrong here?

    Posted via CB10
    You mean besides remembering this is 2020 and there’s no time machine available
    03-08-20 10:12 PM
  3. anon(5597702)'s Avatar
    Isn't it great to get a sarcastic reply when you're genuinely looking for help in the appropriate forum? (Oh wait, I guess mine was too!)

    But I'll actually try to address your question.

    Is there another system you can try? (preferably with an actual USB port). A different cable?

    This looks like a helpful albeit long video: . Hope it helps.

    Good luck!
    03-09-20 05:33 AM
  4. Chuck Finley69's Avatar
    Unfortunately, we’ve gone from answering 8700 questions, to 7290 and now 6710 so we’re getting similar issues and more.
    03-09-20 06:21 AM
  5. imradlol's Avatar
    Isn't it great to get a sarcastic reply when you're genuinely looking for help in the appropriate forum? (Oh wait, I guess mine was too!)

    But I'll actually try to address your question.

    Is there another system you can try? (preferably with an actual USB port). A different cable?

    This looks like a helpful albeit long video: . Hope it helps.

    Good luck!
    I'll give that a try thanks! And it's a serial only phone, no USB unfortunately which is why a usb to serial adapter is necessitated. I do have an old pc with an actual com port that I was going to try hooking the phone up to next to rule out the adapter causing the problems(even though it's worked perfectly fine for years programming cisco switches and routers).

    Unfortunately, we’ve gone from answering 8700 questions, to 7290 and now 6710 so we’re getting similar issues and more.
    And I know, messing with old blackberries is a sort of hobby of mine however. I'm weird i guess
    anon(5597702) likes this.
    03-09-20 08:29 AM
  6. Chuck Finley69's Avatar
    I'll give that a try thanks! And it's a serial only phone, no USB unfortunately which is why a usb to serial adapter is necessitated. I do have an old pc with an actual com port that I was going to try hooking the phone up to next to rule out the adapter causing the problems(even though it's worked perfectly fine for years programming cisco switches and routers).



    And I know, messing with old blackberries is a sort of hobby of mine however. I'm weird i guess
    So I hope you didn’t take any offense at my earlier comment. I don’t think you’re weird anymore than rest of us here on CrackBerry since we’re all fans. My own collection only goes back to 7200 series but I do miss the self important old days when it meant cutting edge club exclusivity.... ;-D
    03-09-20 09:45 AM
  7. imradlol's Avatar
    So I hope you didn’t take any offense at my earlier comment. I don’t think you’re weird anymore than rest of us here on CrackBerry since we’re all fans. My own collection only goes back to 7200 series but I do miss the self important old days when it meant cutting edge club exclusivity.... ;-D
    Oh none taken at all! Those days were far before my time but it's been a ton fun messing old bb's I come across

    Posted via CB10
    anon(5597702) likes this.
    03-09-20 05:32 PM
  8. Chuck Finley69's Avatar
    Oh none taken at all! Those days were far before my time but it's been a ton fun messing old bb's I come across

    Posted via CB10
    You just called me BlackBerry version of boomer and old.....

    LMAO
    anon(5597702) likes this.
    03-09-20 05:34 PM
  9. imradlol's Avatar
    You just called me BlackBerry version of boomer and old.....

    LMAO
    Hahahahaha that wasn't my intent at all my apologies! Some have said I myself am a bit of an old soul :P

    I did finally get this thing to update though. No idea what the he'll I did differently though. I downloaded both Rogers and att versions of the firmware , and even tried downloading version 3.7 to see if maybe I needed to be on that first. Once I installed the 3.7 update package the application loader showed that 4.0 was available for upgrading.

    Installed just fine and it's showing 4.0 in about! So who the hell knows. Maybe BlackBerry mis labelled their firmware? Or maybe 3.7 had some file that weren't in 4.0 package. I have no clue, just happy to have it installed. I even reached out to blackberry themselves out of desperation hahaha

    Posted via CB10
    anon(5597702) likes this.
    03-10-20 01:12 PM
  10. gsm_dealer08's Avatar
    oh, it's been a while since I visited this section of the forum. glad to hear the update went trough. I made a tutorial video a few years back on how to get the updates to work:

    it's of crappy quality but it works. Always uninstall anything Blackberry related from the computer then install Desktop Software v 4.5 or 4.7, install your OS file on the computer, delete vendor file and run Loader.exe
    if the loader does not show the programs already installed on the device, the connection failed. you should see the full list and versions of anything on the phone before the update can start.
    Last edited by gsm_dealer08; 04-23-20 at 02:20 AM.
    04-23-20 02:06 AM
  11. imradlol's Avatar
    Funnily enough I actually did come across your vid in my searching for a solution! Great vid that helped me go in the right direction!
    04-29-20 08:53 AM

Similar Threads

  1. New to me classic
    By MagicRat39 in forum BlackBerry Classic
    Replies: 9
    Last Post: 04-07-20, 07:13 AM
  2. Will my KEY2 still work on AT&T?
    By workerb in forum BlackBerry Android OS
    Replies: 3
    Last Post: 03-10-20, 08:55 PM
  3. solution to that '*@+" mute button!!!!!
    By notObamasBerry in forum BlackBerry KEYone
    Replies: 5
    Last Post: 03-09-20, 04:35 PM
  4. KEYone on TV
    By stellingbanjo in forum BlackBerry KEYone
    Replies: 5
    Last Post: 03-09-20, 04:33 PM
  5. So I think my key one is dying... Any ideas and how I could fix?
    By Stale Potato in forum BlackBerry KEYone
    Replies: 1
    Last Post: 03-07-20, 09:22 PM
LINK TO POST COPIED TO CLIPBOARD