1. anburnett's Avatar
    I just recently bought a 7290 from a friend. I used it one day, then it started clicking off saying no service or takes forever locating a network. Plus when it actually comes on to where it locates the GPRS. It allows me to make a call for about 2 or so min. before it drops it, and then won't allow me to be to send or receive calls.

    I have just updated the OS system, so someone help me. PLEASE!
    09-03-08 08:52 PM
  2. GregFF's Avatar
    Cmon man. Get a curve.
    09-03-08 09:04 PM
  3. pltaylor's Avatar
    some friend! I gotta VCR around here somewhere what cha give me for it? But seriously, I don't know but I wouldn't invest too much time and effort in it. Good luck.
    09-03-08 09:11 PM
  4. anburnett's Avatar
    Cmon man. Get a curve.
    My husband has a curve and when it comes time to upgrade I will, but until then I want to use this one. I know it isn't the most up to date thing on the block, but I like it. I just need help knowing what is going on.
    09-03-08 09:20 PM
  5. NightFire's Avatar
    My previous BlackBerry was a 7290. Sturdy thing and still works quite well, although my Curve is my primary. I cannot say that I have had that issue, though. Have you tried a new Sim card?
    09-03-08 10:51 PM
  6. whidbey96's Avatar

    I've had a 7290 for 10 months (bought it new) and suddenly had the same problem. "Searching for Network" then "No Service", the out of the blue, it starts working - but not for very long.

    I've upgraded the software to 4.1.377 and put in a new SIM card and no change.

    I'm all for upgrading, but not just yet. Is this thing cooked or can I bring it back to life?

    Last edited by whidbey96; 10-11-08 at 02:36 PM.
    10-11-08 02:33 PM
  7. Heresy's Avatar
    try this . go to options/network/network selection mode to auto. then go to advanced/host routing table/ then register it with the network again. also resend your service books too. hope this helps. i am a 7290 die hard user i stand by that phone. i literaly beat the $hit out of mine and it still works.
    One thing to keep in mind is that these phones dont seem to get as good signal as others....but nothing to really worry about.
    10-13-08 07:59 PM
  8. whidbey96's Avatar
    Hey Rip 32;

    Thank you for the advice.

    When I go to Options/Network and click on AT&T (the only network listed) the only options I get are Select and Close.

    I re-registered with the network. But I can obviously only do this at those times when this decides to work. When I did that, the enterprise icon went away. I don't understand why it comes and goes, but I have more pressing issues.

    I don't know what sending the service books is.

    And this thing works like it is possessed. I simply cannot recreate the scenario when the signal drops, nor can I do anything to bring it back - it just happens! I live and work in an area where signal has never been an issue. I might be stopped at a traffic light at the base of an AT&T tower and there would be no signal.

    It will be sitting in the holster on the mantle reading "no signal", then an hour or 10 minutes - whatever - later, it just comes back!

    I'm with you - I like simple and rugged and I would love to get the bugs out of this thing!!

    10-17-08 08:55 PM
  9. Heresy's Avatar
    To resend service books to your phone. Go here BlackBerry Internet Service and log into your BIS. In there you will see a link that says service books click it and resend service books. Other than that I would call customer service and tell them whats going on. If its only 10 months old they should replace it for you.
    10-18-08 07:58 AM
  10. alpha402's Avatar
    I'm having the same problem with my 7290. Out of nowhere it started to loose its signal randomly and now it won't get a signal period. I went to AT&T and they replaced the sim card but that did absolutely nothing. I've tried basically everything, a hard reset, a soft reset, take out the battery rearrange the sim card but all to no avail. I tried that host routing table thing that people have mentioned but all it says is "registration message queued. it will be sent once data coverage is available" apparently i cant send anything without a signal.

    I broke my samsung and was forced to go back to my 7290 and now this phone won't work either!

    I don't have a special bb plan because I just need it to text and make calls.

    Icing on the cake.... my motorcycle was stolen today this is just a great week
    11-04-08 03:40 PM
  11. whidbey96's Avatar
    It's comforting to know that it wasn't just me. I was never able to resolve the problem and when I missed a call for a job, I had to replace it. The 8310 is fancy, but also small - so I went with an 8700C - I hope the Intel processor and Edge technology will yield better results.

    To try to get the 7290 to work, I replaced the SIM card, I upgraded the software, I did hard and soft restarts more times than I can count - there was nothing I could do to resolve the problem and there was nothing I could do to create it.

    Last week, the phone went dead as it sat in the holster in my office. I left it alone - never touched it, didn't do a thing - three plus hours later, it came back. It never moved, I never touched it, I didn't do a thing!!
    11-06-08 10:49 AM
  12. Cracker Jak's Avatar
    Cmon man. Get a curve.

    Dont hate on the classic man my 7250 rocks!!!!!!!! I get good signal no dropped calls....o wait.....I have Verizon
    11-06-08 06:00 PM
  13. Carlos G's Avatar
    My brother found a 7290 for free ,turn it on in the battery indicator is displayed in red with a question mark (battery seems to be full loaded), also in the part where should appears EDGE an X appears, and says no service.
    Already ignited the radio.
    The phone does not recognice the battery.(in the status)
    Someone knows what is the solution?
    Thank you
    02-15-09 12:41 PM