1. Aokisensei's Avatar
    I've been having some problems with my 6230 (running 4.0.2.56) that I attempted to solve myself, ended up nearly bricking the thing, and then ended up back at square one.

    My initial problem was (and still IS) that I purchased this BB used and it apparently was connected to a BES and locked down. Full disclosure: I don't have a BB data plan, and I'm not trying to use the 6230's built-in email or browser, but I've heard users have had success using third-party apps like Opera Mini on plain vanilla GPRS data plans (which I DO have).

    Okay, so my problem is that I got Opera Mini installed, and on the first run, it attempted to connect to the internet, and I got asked permission for it to first make an http connection, then a socket connection...I was given the option and told it to allow all connections through, don't ask again. Then near the end I started this error:

    "The application operette$2dhifi$2dus has attempted to open a connection to a location inside the firewall and outside the firewall, which is not allowed by your IT policy"

    Followed by Opera Mini reporting that it failed to connect to the internet. My first instinct was to go to Options > Firewall and attempt to disable it (it was enabled when I got it)...no dice. There's no option to disable it. It won't let me change it. Then I looked up some info on other people having similar problems and being told to change something under Options > Security Options...and that menu doesn't even appear there. I'm apparently missing a few other menus there too.

    Okay, so then I read up on how to remove the IT Policy. I tried CrackUtil; that only works for OS 4.3 and up apparantly. I tried JL_Commander; no dice. I tried the wipe/policy.bin/registry edit/DM trick, and nothing.

    So then I get frustrated and decided to completely blank out the 6230's filesystem and just reinstall a new OS I downloaded from Cingular/ATT's site. I figured even though it was a branded version, it wouldn't have the same IT Policy. Well, the completely-blanking-out part worked fine. I tried to turn it on, and got a 507 error, indicating there was no OS installed.

    Then I started getting several different errors from DM and AppLoader when trying to reinstall the OS, including one about how I needed a "newer version", even when I was using the newest one. I tried this on DM 4.0, 4.3, and 4.7, by the way. I also tried installing both OS 4.0.2.56 and 3.7; no luck. AppLoader refused to work; it would get to "Connecting Boot ROM", and then error out. So in a last-ditch attempt, I connected through CrackUtil and started manually loading the OS files, one-by-one. Eventually I got it to a point where apparently enough was there that AppLoader recognized my 6230 as a Blackberry, and successfully did a wipe of my manual half-install, and installed 4.0.2.56.

    Okay, so now I'm back to a clean install of 4.0.2.56. And I still can't disable the firewall. And Opera still won't work, and is giving me that error about the IT policy.

    What do you suggest I do? Is there anything I can do to remove these restrictions?


    Also, what's the newest version of the OS that will run on a 6230?

    Thanks in advance.
    03-31-09 04:31 PM
  2. Heresy's Avatar
    That OS version seems to be the latest for that device. One thing i will note is if you do not have a BB data plan Opera mini isnt going to work anyway. I hate to send you to another forum but you might find this worth the read if your dead set on getting that device working the way you want Remove IT Policy - Page 2 - BlackBerryForums.com : Your Number One BlackBerry Community. Personally me I would get a used 7290 or 8700g from ebay.
    03-31-09 06:09 PM
  3. Aokisensei's Avatar
    Yeah, I read that page actually, and it didn't do me much good =/
    Ah well. Shame I can't get it working, there's really no other way? I thought the complete wipe and reinstall I did would have done *something.*
    04-06-09 08:14 AM
LINK TO POST COPIED TO CLIPBOARD