1. Roel Inso's Avatar
    I have my 9300 BB 3G curve, My earphone is coloud earphones.. everything was okay and im using the earphone for about 6 months. Yet, it stops producing sound when I had increased the volume on the phone while using the earphone, but on speaker mode it has sound and working as well.. I tried to do a hard reset on my phone many times and removing the battery still no work.. I have connected the earphone on iphone, Nokia, and Samsung phones but they are working well. I tried other earphones and they are working as well .. Someone please help
    02-25-14 04:27 AM
  2. pkcable's Avatar
    My guess it that something is wrong with the headphone jack itself. It maybe damaged. Have you tried while the headphones are plugged in wiggling them around a little (NOT a lot) to see if you can get it to work? This would indicate it's not a total fail just a loose connection. You MIGHT be able to repair. If you can't get it to work at all, the socket may be dead. Was it exposed to moisture? Was the device dropped at all? You might need to get it repaired or just live with it like that.
    02-27-14 03:12 PM

Similar Threads

  1. No slider phone for 2014? =(
    By artlu629 in forum General BlackBerry News, Discussion & Rumors
    Replies: 77
    Last Post: 05-23-14, 03:24 AM
  2. 10.2.1.2141 has roll out in UAE
    By glimer4 in forum BlackBerry 10 OS
    Replies: 18
    Last Post: 02-28-14, 11:26 PM
  3. Replies: 1
    Last Post: 02-26-14, 06:42 AM
  4. I stayed up till 2:30 in the home country of BlackBerry and now you tell me that there is no Z40 +
    By GRojasHruska in forum General BlackBerry News, Discussion & Rumors
    Replies: 12
    Last Post: 02-25-14, 07:47 PM
  5. BlackBerry Trade Has Flipped
    By ep1 in forum General BlackBerry News, Discussion & Rumors
    Replies: 9
    Last Post: 02-24-14, 09:59 PM
LINK TO POST COPIED TO CLIPBOARD