11-22-14 02:33 PM
123 1234 ...
tools
  1. AMorris71's Avatar
    Here's my perspective: The Q10 is working perfect for me as it fits my needs perfectly. Blend will be an amazing companion to an amazing phone. However, I'm not going to go drop a few hundred dollars to get a phone that works with Blend, but I'd pay $20 today for Blend to work with my Q10. So IMO, if Blackberry wants to say they are in the business for software solutions as much or more than hardware, here's your chance - don't tie this innovative software to new phones only.
    11-11-14 09:46 AM
  2. jmose's Avatar
    AMorris,

    That is an excellent point. Buy a new BB, get Blend for free. For those of us with old ones (Z10 here), charge us an 'app fee' of $10 or $20 to get Blend. That is the game-changer app for me. I don't particularly like typing on my phone. So, if I could run it from a real keyboard, I would be that much more productive.

    Jim
    AMorris71 likes this.
    11-11-14 10:30 AM
  3. jmose's Avatar
    In fact, that should be a POLL: For existing BB owners, how much would you spend to use Blend RIGHT NOW?
    1. Nothing - I don't want it
    2. Nothing - I deserve to get it for free
    3. $1.99
    4. $5
    5. $10
    6. $20
    7. Charge me $1 monthly.

    Does anyone know how to make a poll?

    Jim
    AMorris71 likes this.
    11-11-14 10:35 AM
  4. malingering's Avatar
    I'm using 10.3 now so the OS is not a major problem for me. My problem is BLEND. I want it nao..

    Posted via CB10
    11-11-14 10:42 AM
  5. kbz1960's Avatar
    AMorris,

    That is an excellent point. Buy a new BB, get Blend for free. For those of us with old ones (Z10 here), charge us an 'app fee' of $10 or $20 to get Blend. That is the game-changer app for me. I don't particularly like typing on my phone. So, if I could run it from a real keyboard, I would be that much more productive.

    Jim
    In fact, that should be a POLL: For existing BB owners, how much would you spend to use Blend RIGHT NOW?
    1. Nothing - I don't want it
    2. Nothing - I deserve to get it for free
    3. $1.99
    4. $5
    5. $10
    6. $20
    7. Charge me $1 monthly.

    Does anyone know how to make a poll?

    Jim
    I hope you're kidding. I wouldn't pay anything for it and that would be screwing your existing base once again.
    deezy87 and 3rdStone like this.
    11-11-14 10:51 AM
  6. jon4400's Avatar
    Funny how some are saying we're not entitled to 10.3. I guess when I buy an electronic device at the moment of purchase I should just forget about support.
    I am so sorry if I was unaware that the bugs were mine to fix.

    In all seriousness, a software update is to bring support to your purchase and make the product more secure and enjoyable. So YES, we are entitled to 10.3 as long as our devices are capable of running it. It's always been like that in the software business and it's not going to change now.

    Let's say you bought photoshop and use it for your daily activities and then found an annoying bug or a complicated setup. Wouldn't you be bothered that they kept delaying the software that comes with the much needed patches?

    My 2 cents.



    Posted via CB10
    kbz1960 and GRojasHruska like this.
    11-11-14 11:04 AM
  7. will308's Avatar
    That has bean my point all along. Blackberry does not care about the faithful. Once sold that is it. They do not feel the need to take care of us because we have a phone so "to bad to sad".
    rubbish that's not the case at all
    11-11-14 11:20 AM
  8. jmose's Avatar
    So, you'd be a #2 then. Note that I agree with you to an extent. I want Blend now, and I'd like it for free. But, my phone is 2 years old, and Blend isn't just a phone update. There must be development costs to get this working on the PC/Mac side, and BB could try to recapture these.

    My main point, though, is that I don't want to wait for Verizon to release 10.3.1 for my Z10. If that version isn't required for Blend, then, great, I'm willing to pay for Blend now.

    Jim
    11-11-14 11:59 AM
  9. Bluenoser63's Avatar
    If at least they lift the restriction off Blend.........!
    Blend needs 10.3 so how would that work? 10.3 has not been released officially for those devices. And for those people who want Blend now for paying for it, you still need 10.3 to be officially released so it is a moot point.
    11-11-14 12:14 PM
  10. RubberChicken76's Avatar
    BlackBerry seems to be a company of delayed releases
    Sure, but in the case of 10.3.1, they didn't actually "announce" anything.
    11-11-14 12:34 PM
  11. k-fos's Avatar
    Of course I would like it sooner (today), but I have a few other more important things "on my list" between now and January.
    11-11-14 01:00 PM
  12. Thesmartmale's Avatar
    Dude, seriously?

    First off, it's not like you're running around with an archaic OS and you desperately NEED the update. You WANT it, which is another matter altogether.

    The only people who really know about 10.3 are in this community... those who are not probably don't even know the update is coming, and do you think that they are saying that they are being "disrespected"?

    People really need to tone down the entitlement up in here.

    Lastly, did BlackBerry even confirm a release date?

    CB10 for BlackBerry 10: Z10 on Bell
    Yes, when you put up with 10.2.1 and it's bugs for a year you just wonder when will BlackBerry release another update, specially that this time it's taking a year not just 3 month just like all the previous updates.

    Posted via CB10
    11-11-14 01:06 PM
  13. Thesmartmale's Avatar
    Yeah, but every time Apple pushes out an update they break something...

    Posted via CB10
    And so does BlackBerry, but the difference is, when Apple breaks something they apologize and fix but BlackBerry doesn't do any.

    Posted via CB10
    kbz1960 likes this.
    11-11-14 01:07 PM
  14. Thesmartmale's Avatar
    I'm all for it, if this will help BlackBerry sell more Classics?! Our Time will Come. The Leaked 10.3.1 O.S. is fortunately fine for now (IMO), for those of us able or willing to use it. Besides, this will give BlackBerry more time to fix a few more of the bugs, which will help make 10.3.1 O.S. better than ever.
    Do you really think that will make classic sell? On what logic? The forum is full of 10.3.1 leaks, people will buy the classic cause they want one not cause it has 10.3.1

    Posted via CB10
    kbz1960 likes this.
    11-11-14 01:10 PM
  15. Thesmartmale's Avatar
    Sure, but in the case of 10.3.1, they didn't actually "announce" anything.
    Except they said " before year end" so they are late, unless there are two January's in 2014

    Posted via CB10
    11-11-14 01:13 PM
  16. bicyclexpress's Avatar
    I have been running the 10.3.1 leak on both my Q10 and Z10. It is gorgeous but....there are a fair number of minor bugs. I think these bugs are probably behind the delay.

    But, yeah, I echo the above sentiments about wanting Blend asap. It shouldn't, but it burns me up that one of my good friends has the passport and, thus, access to Blend. I am not normally a jealous individual, but in this case..i want it it!

    Posted via CB10
    user5240 likes this.
    11-11-14 02:54 PM
  17. Skyforever's Avatar
    Do you really think that will make classic sell? On what logic? The forum is full of 10.3.1 leaks, people will buy the classic cause they want one not cause it has 10.3.1

    Posted via CB10
    Not everyone thinks the same way. I'm sure people who buy the Classic will have various reasons for doing it. As for the leaked 10.3.1, it's a leak! bugs and all. I'm using "it", and can live with "it" (until the official one comes out anyway, or a better leak lol), but who could say that having the Official 10.3.1 O.S in the Classic would not be an incentive at all. I'm with BlackBerry on this one. Different strokes for different folks. I'm saying this could be relevant in some peoples thinking (it is my opinion). I believe it's the best approach. Enjoy your Berry.
    11-11-14 03:30 PM
  18. Thesmartmale's Avatar
    Not everyone thinks the same way. I'm sure people who buy the Classic will have various reasons for doing it. As for the leaked 10.3.1, it's a leak! bugs and all. I'm using "it", and can live with "it" (until the official one comes out anyway, or a better leak lol), but who could say that having the Official 10.3.1 O.S in the Classic would not be an incentive at all. I'm with BlackBerry on this one. Different strokes for different folks. I'm saying this could be relevant in some peoples thinking (it is my opinion). I believe it's the best approach. Enjoy your Berry.
    You do know that the first day the classic is out, the OS will be leaked! I'm pretty sure that no one thinks that way since the official will be in the forums anyway and the official will be pushed in January so yeah I won't go buy a classic and leave my Z10 just to get 10.3.1 or do you think people will change from touch keyboard to PKB and get a smaller screen and pay just to get 10.3.1 one month earlier? No other company does this.

    Posted via CB10
    kbz1960 likes this.
    11-11-14 03:55 PM
  19. AnimalPak200's Avatar
    Hopefully they leak a better version of 10.3.1 that doesn't have all the Passport bugs. They (AT&T and BlackBerry) pushed it to my wife's and my Passport (automatically) and it has made them much less stable. They should OTA slight revision to Passport users that are currently on 10.3.1.1016, or compensate me for the time required to downgrade using an autoloader and set up two devices from scratch to the state they were prior to the mistaken update.

    Or they can just leave us hanging dry for two months with flickering green screens.

    Posted via CB10
    11-11-14 03:56 PM
  20. AMorris71's Avatar
    And for those people who want Blend now for paying for it, you still need 10.3 to be officially released so it is a moot point.
    Not necessarily. Just because Blend has only been released with 10.3 does not mean it can't be released on earlier versions. You may very well be correct that it needs the underlying infrastructure of 10.3, but it's just as possible that it was a strategic decision to release with 10.3.

    I do agree with those that say it is the right move to offer it free for all existing BB10 customers. I'm just saying for me, I'd pay for it if need be.


    Posted via CB10
    11-11-14 03:56 PM
  21. Thesmartmale's Avatar
    Hopefully they leak a better version of 10.3.1 that doesn't have all the Passport bugs. They (AT&T and BlackBerry) pushed it to my wife's and my Passport (automatically) and it has made them much less stable. They should OTA slight revision to Passport users that are currently on 10.3.1.1016, or compensate me for the time required to downgrade using an autoloader and set up two devices from scratch to the state they were prior to the mistaken update.

    Or they can just leave us hanging dry for two months with flickering green screens.

    Posted via CB10
    They will leave you hanging dry BlackBerry needs a new mind when it comes to the way they manage updates, just horrible!

    Posted via CB10
    11-11-14 04:01 PM
  22. LuvULongTime's Avatar
    They have been pretty good lately with OS updates. I would not be surprised if the extra code added in for the BELT caused the delay. Once this goes in I bet future releases will be easier for them to deliver. And as already stated by other posters, no official date was ever given, so let's ease off on condemning BB.
    GRojasHruska likes this.
    11-11-14 04:08 PM
  23. RubberChicken76's Avatar
    Yes, when you put up with 10.2.1
    considering it was released at the end of January this year, and there have been updates since (I've had two or three), that's quite a trick.
    spikesolie likes this.
    11-11-14 04:54 PM
  24. 1magine's Avatar
    I'm sorry, but I have yet to see the first thing in 10.3.1 that makes me say I'm willing to give up some important functionality( Verizon tethering and Flash) because I need to have this over 10.3. In fact, I'm near certain that without flash, I will, for the first time since OS4, not update to the latest software.
    AllanQuatermain likes this.
    11-11-14 05:11 PM
  25. Bluenoser63's Avatar
    Not necessarily. Just because Blend has only been released with 10.3 does not mean it can't be released on earlier versions. You may very well be correct that it needs the underlying infrastructure of 10.3, but it's just as possible that it was a strategic decision to release with 10.3.

    I do agree with those that say it is the right move to offer it free for all existing BB10 customers. I'm just saying for me, I'd pay for it if need be.


    Posted via CB10
    Blend needs 10.3 libraries to function.
    Superfly_FR likes this.
    11-11-14 05:12 PM
123 1234 ...

Similar Threads

  1. "T" shortcut button and "Go to date" very buggy when in Calendar Month View
    By fridaybeatsmondayanygivensunday in forum BlackBerry Passport
    Replies: 2
    Last Post: 11-11-14, 06:13 AM
  2. Anyone on 10.3.1 can answer this?
    By The Big Picture in forum BlackBerry Passport
    Replies: 4
    Last Post: 11-11-14, 04:46 AM
  3. It's official! 10.3.1 in 2015
    By Glen Barnett in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 11-11-14, 03:56 AM
  4. How do I unblock sites in KSA?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 11-11-14, 03:33 AM
  5. Interested in Buying Iphone 6 plus
    By shobhitjhalani in forum Ask a Question
    Replies: 1
    Last Post: 11-11-14, 02:49 AM
LINK TO POST COPIED TO CLIPBOARD