1. cyf1's Avatar
    I have a BB 8120 it was originally on orange but I got it unlocked to t-mobile. I rang up t-mobile and had blackberry set up on my account, my BB messenger works fine but my browser only gives me the option of browsing using wi fi and not my networks browser?my friend seems to think its because it was originally on orange network my internet wont work on t mobile?thanxs in advance!
    09-26-08 06:21 PM
  2. SevereDeceit's Avatar
    Remove your battery while the device is on, the re-insert battery and see if you got it...
    09-26-08 06:30 PM
  3. Reed McLay's Avatar
    Welcome to CrackBerry.

    Have a look at this How to thread.


    http://forums.crackberry.com/f3/comp...ifi-how-47229/
    09-26-08 06:34 PM
  4. Branta's Avatar
    Make sure you check the APN and other internet settings which might still be pointing at Orange.

    Knowing how Orange castrated the BBMaps feature in the first release it would not surprise me to find some software was missing. This might require reloading the software, but this is not a major problem for most users. If you can survive without the missing browser for a short time there is likely to be a new software version released soon which you decide you want to load anyway so that would be the time to check this possible cause.
    09-26-08 07:22 PM
  5. Branta's Avatar
    Welcome to CrackBerry.

    Have a look at this How to thread.


    http://forums.crackberry.com/f3/comp...ifi-how-47229/
    Erm... Reed, the OP said WiFi works, its the cellular connection that's not working.
    09-26-08 07:23 PM
  6. Crackberrykills's Avatar
    Welcome to CB.
    09-26-08 07:46 PM
  7. Reed McLay's Avatar
    Erm... Reed, the OP said WiFi works, its the cellular connection that's not working.

    Doh!

    I see 8120 and the old brain said Wifi issue.
    09-27-08 11:19 AM
  8. bx2md's Avatar
    welcome to cb and i hope you could use your wifi with no problems
    09-27-08 11:21 AM
LINK TO POST COPIED TO CLIPBOARD