1. Twentytwo's Avatar
    Hi All,

    New to BB...have a (2nd-first defective) Storm, and find where it's battery is draining like crazy today...seems to go down without use very quickly...sorry if I missed a prior thread. Feel free to re-direct if same situation has taken place...The only thing I thought was the GPS was "on", but thats not the case (I believe!)
    Any help or advice is appreciated! My thanks!
    12-05-08 10:36 AM
  2. ajhedge's Avatar
    If the phone is new, you have to charge it completely and then run it all they way down till it dies, the charge to full again, you have to break it in, it will take some time till it hold its full potential.....if you still have problems and its under warrenty pitch the old battery and get a new one...thats the best answer i can give you, good luck...
    12-05-08 04:45 PM
  3. Twentytwo's Avatar
    Thanks...that could be the issue. Plus the update downloaded might also help. Appreciate your advice!
    12-06-08 12:55 PM
  4. dunerzr's Avatar
    turn display brightness down from 100% to 70 or 80%..this helped mine alot, and visually I dont see any difference...
    12-06-08 01:52 PM
  5. joe003's Avatar
    And.....

    12-06-08 05:22 PM
  6. thepaintedpony's Avatar
    Welcome to CB!
    12-07-08 02:11 AM
  7. BuddyL's Avatar
    Welcome aboard!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-07-08 02:17 AM
  8. b450hp's Avatar
    welcome to crack
    12-07-08 03:40 AM
  9. johnmorganjr1's Avatar
    Hello and welcome to CB.
    12-07-08 10:15 AM
LINK TO POST COPIED TO CLIPBOARD