1. CANADIAN1's Avatar
    Hi guys , im new here.

    I am not new to forums , so usually i will search for my answer before posting but dint find a solution.

    I have a blackberry 8100 from rogers , i dint include caller ID because i assumed if you save numbers in your adress book if one of them called it would display the name since it saved. But it doesnt it alwas display unknown number.. when i check in the log it shows who called.

    I read threads of this happening but din't find a solution , is it fixable? or a glitch with the pearl?
    08-31-08 12:38 PM
  2. benzworm's Avatar
    you need to call ur provider... they might have just accidentally taken your caller id feature off
    08-31-08 12:54 PM
  3. ScandaLeX's Avatar
    Hi guys , im new here.

    I am not new to forums , so usually i will search for my answer before posting but dint find a solution.

    I have a blackberry 8100 from rogers , i dint include caller ID because i assumed if you save numbers in your adress book if one of them called it would display the name since it saved. But it doesnt it alwas display unknown number.. when i check in the log it shows who called.

    I read threads of this happening but din't find a solution , is it fixable? or a glitch with the pearl?
    you need to call ur provider... they might have just accidentally taken your caller id feature off
    It wasnt taken off; he didnt add it assuming that the feature would work since they are numbers that are already stored in the phone.
    08-31-08 12:57 PM
  4. jeffh's Avatar
    ... i dint include caller ID because i assumed if you save numbers in your adress book if one of them called it would display the name since it saved. But it doesnt it alwas display unknown number.. when i check in the log it shows who called...
    I would have made the same assumption as the OP. Do you have the country code and area code set correctly? That will cause phone numbers not to be recognized.
    08-31-08 05:09 PM
  5. CANADIAN1's Avatar
    I would have made the same assumption as the OP. Do you have the country code and area code set correctly? That will cause phone numbers not to be recognized.
    where do i check to see what the country / area code are set at? im assuming its going to be somewhere in options?
    09-01-08 03:09 PM
  6. jeffh's Avatar
    Yes, look in: Green phone button / menu / options / smart dialing
    09-01-08 03:14 PM
  7. Troubleina's Avatar
    I'm going to go out on a ledge here with this explanation.

    when your incoming call is routed thru your carrier, if you don't have Caller ID, that info is not forwarded to you from the switch. Therefore, it will always show as unknown. It's kinda like translations. since you don't subscribe to it, they don't give it.
    09-01-08 03:23 PM
  8. bmcclure937's Avatar
    Welcome to CrackBerry!! I hope all the information provided has helped you with your issue...
    09-01-08 03:33 PM
  9. saechavarry's Avatar
    Welcome to Crackberry!!
    09-01-08 07:35 PM
  10. msnicolina's Avatar
    Welcome to Crackberry!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    09-01-08 07:41 PM
  11. jm2hill's Avatar
    welcome to cb
    your going to love your berry

    as someone said above me when it goes through rogers they hide whos calling and thats why even if you have the number it wont show up when they call

    if you want it to show up you have to add call id
    09-01-08 07:47 PM
  12. CANADIAN1's Avatar
    ^ ya i guess that makes sense.

    but i would assume this is for specific phones? because a friend with a krzr has it show up.
    09-02-08 05:24 PM
  13. jm2hill's Avatar
    possibly could be through specific phones unlikely however
    most probably they have the setting whether they know it or not
    09-02-08 10:46 PM
LINK TO POST COPIED TO CLIPBOARD