05-05-10 05:07 PM
36 12
tools
  1. rjdangerous's Avatar
    Not trying to start a flame war, I love my berry. I'm not a techie and wondering why the BB browser is so much slower than BOLT and OPERA? I did notice a speed increase in the 5.0 browser but still not enough to compare especially when loading full sites. Why can't they make it faster?

    I love the feel of the BB browser it's so smooth, zoom works so fast.. just that pages load so slow.
    05-04-10 10:08 PM
  2. Blacklac's Avatar
    Turn Javascript off and Prompt to enable Javascript on and it should be fast enough.
    05-04-10 10:10 PM
  3. rjdangerous's Avatar
    Turn Javascript off and Prompt to enable Javascript on and it should be fast enough.
    Even with it off some sites take over 30 seconds to load which is CRAZY when opera mini loads it in 9.

    No way can you "surf" the web when your backlight goes off before the page loads.

    Take the opera tech and through it into your browser RIM.. pleaaaase!
    05-04-10 10:41 PM
  4. grahamf's Avatar
    OS 6 has Webkit. just you wait.
    05-04-10 10:43 PM
  5. rjdangerous's Avatar
    OS 6 has Webkit. just you wait.
    Can I run OS 6 with my original tour?
    05-04-10 10:45 PM
  6. grahamf's Avatar
    Touch

    10
    05-04-10 10:46 PM
  7. amazinglygraceless's Avatar
    Throughout 5 different BBs I find the default browser to be better than any of the
    third party one. I hate Opera. Bolt is pretty good but still needs a good amount
    of work.

    The default browser loads pages (ALL PAGES) as fast or faster than Bolt and Opera
    (I have made no changes to the original config), pages render perfectly and I have
    yet to have a page that can't be rendered whether that is the Town, I work for,
    my bank, sites specific to my profession, etc...
    05-04-10 10:49 PM
  8. rjdangerous's Avatar
    The default browser loads pages (ALL PAGES) as fast or faster than Bolt and Opera
    (I have made no changes to the original config), pages render perfectly and I have
    yet to have a page that can't be rendered whether that is the Town, I work for,
    my bank, sites specific to my profession, etc...

    Not a chance in ****. I have tested a TON of sites and it's not even close.
    05-04-10 10:53 PM
  9. Blacklac's Avatar
    Then it must be your OS, the device itself or the mobile connection. Both my Storm 2 and Bold 9000 run the stock browser quite well. The only pain i see with it is that it often loads mobile sites (i usually leave the browser identification on Blackberry). I do not think it is "slow". I do use Bolt and Opera also, but I still think the BB browser is ok.

    I'm curious, what pages are taking longer than 30 seconds with Javascript off?

    My S2 just loaded nytimes.com in 15 seconds over Wifi, with Browser identification set to Firefox (so it loaded the full site, not mobile). I was under the assumption nytimes.com was a hard page to load. I think my BB did it great and quite fast. Even over Edge (2G) it only took 21 seconds to load fully.

    Ok, Crackberry.com took 1min 5 seconds to load over Edge. That is pretty bad, but CB.com loads slow on every damn browser I've viewed it on. Even my gaming rig PC over 20MB cable connection.
    Last edited by Blacklac; 05-04-10 at 11:13 PM.
    05-04-10 11:03 PM
  10. Rig415's Avatar
    Turn Javascript off and Prompt to enable Javascript on and it should be fast enough.
    Agreed... Java slows the H*ll out of the Browser.. Promting is the way to roll.. noticable difference...
    05-04-10 11:06 PM
  11. rjdangerous's Avatar
    Then it must be your OS, the device itself or the mobile connection. Both my Storm 2 and Bold 9000 run the stock browser quite well. The only pain i see with it is that it often loads mobile sites. I do not think it is "slow". I do use Bolt and Opera also, but I still think the BB browser is ok.

    I'm curious, what pages are taking longer than 30 seconds with Javascript off?
    How can it be my connection when opera loads them fast? Does my connection just dislike the BB browser? I have been through many OS, from 4.7 to official 5.0's to hybrids all the same. (exept 5.0 compared to 4.7)

    As an example try Call of Duty Series - PlayStation.com Forums , my BB browser goes black before it loads, opera in 7 seconds.
    05-04-10 11:09 PM
  12. Blacklac's Avatar
    How can it be my connection when opera loads them fast? Does my connection just dislike the BB browser? I have been through many OS, from 4.7 to official 5.0's to hybrids all the same. (exept 5.0 compared to 4.7)

    As an example try Call of Duty Series - PlayStation.com Forums , my BB browser goes black before it loads, opera in 7 seconds.
    Yeah, that site took about 1 minute to load over Edge connection, for me. Took about 40 seconds over Wifi.

    My Bold would probably be a little faster. Its browser seems to be slightly faster than my Storm 2. I assume that is due to the Bold having a beefier processor, but I don't really know.
    05-04-10 11:20 PM
  13. rjdangerous's Avatar
    Yeah, that site took about 1 minute to load over Edge connection, for me. Took about 40 seconds over Wifi.

    My Bold would probably be a little faster. Its browser seems to be slightly faster than my Storm 2. I assume that is due to the Bold having a beefier processor, but I don't really know.
    OK so it's not just me, that mod who posted above must have a super browser because he said ALL pages load faster on his.
    05-04-10 11:23 PM
  14. rjdangerous's Avatar
    thanks for trying that out black.
    05-04-10 11:24 PM
  15. amazinglygraceless's Avatar
    Not a chance in ****. I have tested a TON of sites and it's not even close.
    Maybe not on your end but please DO NOT try telling me what I am
    experiencing and has from my first BB (8100) til now.
    05-04-10 11:39 PM
  16. rjdangerous's Avatar
    Maybe not on your end but please DO NOT try telling me what I am
    experiencing and has from my first BB (8100) til now.
    Just find it VERY strange how your browser is sooo much faster than mine.
    05-04-10 11:46 PM
  17. amazinglygraceless's Avatar
    I haven't got a clue. I can only relay to you what happens on my end.

    ...and for the record I went to the link you posted: less than 15 seconds on 3G.
    05-04-10 11:53 PM
  18. rjdangerous's Avatar
    I haven't got a clue. I can only relay to you what happens on my end.

    ...and for the record I went to the link you posted: less than 15 seconds on 3G.
    Then you got something great going on because the other guy and myself (plus my other tours on account) all take well over 30 seconds.

    If you come across something you may have set different PLEASE relay it to me because I would love to use the BB browser, it's just to slow.

    I'm not sure what phone you have, but I'm going on the "assumption" most newer BB's the browser speeds are close.
    05-04-10 11:55 PM
  19. amazinglygraceless's Avatar
    I have a 9700. Not sure if my proximity to cell sites is a factor but where I live and
    work in Connecticut they are all over the place. I'm inclined to think not because
    when I travel there is hardly a difference.

    I did test the site on both the 9700 and e71x and the were pretty much close.

    Maybe you and I should do and compare speed tests.
    05-05-10 12:03 AM
  20. rjdangerous's Avatar
    I have a 9700. Not sure if my proximity to cell sites is a factor but where I live and
    work in Connecticut they are all over the place. I'm inclined to think not because
    when I travel there is hardly a difference.

    I did test the site on both the 9700 and e71x and the were pretty much close.

    Maybe you and I should do and compare speed tests.
    I have an app called "speed test" I think by extreme labs just ran it and says max speed 7444.61, d/l speed 5078.47.
    05-05-10 12:19 AM
  21. SharnKiwi's Avatar
    I do find Blackberry Browser loads fast when on 3G (850 MHz) and Edge, where as Blackberry Browser is so slow on 3G (2100 MHz).

    As for Bolt Browser - I found it is a little bit slower to load than Blackberry Browser.
    05-05-10 12:38 AM
  22. Blacklac's Avatar
    it's all in the browser settings. I have no idea what the default settings were. They could easily explain why amazinglygraceless loads that page so quickly.

    While THAT page was slow, a large majority of pages i go to are nowhere near that slow.

    Crackberry.com (non mobile) also takes near 1 minute for me.

    Browser Config -
    Support Java: Off
    Prompt Java: On
    Show Images: On
    Background Images: On
    Embedded Media: On

    General Properties -
    Font: 8
    Minimum Font: 6
    Font Style: Plain
    Default View: Page
    Image Quality: High
    Repeat Animations: 100 times
    Full screen view: off
    Javascript location support: off

    Besides turning Javascript off and Javascript Prompt On, and Image Quality to High, those are pretty much default setting, i believe.
    Last edited by Blacklac; 05-05-10 at 07:43 AM.
    05-05-10 07:38 AM
  23. albee 1's Avatar
    Other than font size, resolution, and column view my 8330 is setup the same as Blacklacs'. Stock browser loads Crackberry site in about 7 seconds running Sprints 3G. Don't have a clue what's up with OP's browser. Have you checked to see how many apps you have running in the background? Memory issues? Wish I could help.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-05-10 08:20 AM
  24. albee 1's Avatar
    I just had a thought. Menu/Options/Advanced Options/Browser Push. All my boxes are checked and all permissions are set to allow or auto. Loading all internet pages in 5-7 seconds.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-05-10 08:37 AM
  25. ba_hamilton's Avatar
    Then it must be your OS, the device itself or the mobile connection.

    My S2 just loaded nytimes.com in 15 seconds over Wifi, with Browser identification set to Firefox (so it loaded the full site, not mobile). I was under the assumption nytimes.com was a hard page to load.
    I have no issues with the BB Browser either. Most pages load in 4 or 5 seconds. I've never been to the NY Times web site and it just loaded in 7 seconds. I've done side by side test with the Droid Eris and the BB Browser loads pages just as fast, if not faster in many cases.

    I will admit that the browser was real slow with OS .3xx. But with .4xx and .5xx and available hybrids, I have no complaints. One can hope that it will only get better with 6.0 coming.
    05-05-10 09:37 AM
36 12
LINK TO POST COPIED TO CLIPBOARD