1. soradsauce's Avatar
    Okay, so, I've read pretty much all of the forums on the no BBM and e-mail problems, and tried all of the fixes. This is my last resort!

    I have an AT&T Torch that I unlocked. With the AT&T SIM in it, BBM and e-mail and third party apps all work fine, even with the network turned off, working only on WiFi (since I'm in the UK and don't want to get crazy charges!). However, the minute I switch to my T-Mobile UK SIM, everything except calling and the browser stops working. I'm a first time BlackBerry owner, so I don't have another phone to download the service books onto or from. This may be the main part of the problem, but it still seems weird that on my old SIM everything works just fine.

    Any help would be appreciated!
    10-08-10 08:57 AM
  2. weezul's Avatar
    just give Vodaphone a call, ask them to resend service books
    10-08-10 09:02 AM
  3. SteveyAsp's Avatar
    Okay, so, I've read pretty much all of the forums on the no BBM and e-mail problems, and tried all of the fixes. This is my last resort!

    I have an AT&T Torch that I unlocked. With the AT&T SIM in it, BBM and e-mail and third party apps all work fine, even with the network turned off, working only on WiFi (since I'm in the UK and don't want to get crazy charges!). However, the minute I switch to my T-Mobile UK SIM, everything except calling and the browser stops working. I'm a first time BlackBerry owner, so I don't have another phone to download the service books onto or from. This may be the main part of the problem, but it still seems weird that on my old SIM everything works just fine.

    Any help would be appreciated!
    Have you got BIS enabled on the T-Mobile Sim?
    10-08-10 09:15 AM
LINK TO POST COPIED TO CLIPBOARD