1. stasber's Avatar
    Hi Troops

    Couldn't find anyone else with a thread on this, so here's my dilemma.

    Gmail is king for me, which means I have a couple of domain email addresses that Gmail fetches and deletes from server, so I only use Gmail for ALL email sending, receiving and replying to. Gmail is great for doing what you want and being who you want. And the BB Gmail Enhanced Plug-In is pretty good imo.

    I have set up mailboxes on my BB for all accounts and have been experimenting with forwarding/not forwarding email to the accounts and can't overcome one issue.

    If I get incoming mail to Gmail for one of the other email addresses and I wish to reply, I see the dropdown box next to 'Send Using'... but there is only 1 option, i.e. just Gmail, and not the others. I don't see a way of adding an alternate address in the email setup, nor incorporating it from within my BB app, even though the other addresses are available "willing & waiting" - I don't seem to be able to integrate them in any way whatsoever.

    I sent a test message from my contact page on one of the other accounts, which instantly popped into that mailbox on the BB. Some 15 mins later it popped into my Gmail account, once Gmail had fetched it. I sent a reply from the other mailbox, and not a sign of it in Gmail, either on BB nor in the actual mailbox. All of which makes sense to me as Gmail wouldn't have known about my reply.

    So - anyone have any revelations about making my BB Gmail behave like real Gmail? I know I can bcc my Gmail account from the others but that'll only mess things up for me.

    Are there any reliable apps out there that'll link the different accounts so that I can reply from any, from within my BB Gmail inbox??
    09-10-10 05:27 PM
  2. usulsuspct's Avatar
    The solution I came up with works but isn't pretty. Basically involves creating an additional bis account for your one gmail acct. You will need to format the username on the second account like username+secondacct@gmail.com. This will let you specify another from address that will be available from your bb.

    The kludgy part comes in that with two bis accounts pointed to one gmail acct you will get dupe emails. To handle this you need to add filters to the bis accounts to isolate the messages to the various domains, this will prevent the dupes, and allow you to have multiple from addresses.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 05:34 PM
  3. stasber's Avatar
    Thanks usulsuspct.

    In principle this may be the solution, as I'd want a different name field and sig line for the second reply to address, which the second BIS account would allow me to set up.

    Edit...
    OK may need a little help as I can't see how I can create a second account. Either my device is already registered (i.e. setting up a new BIS), or my Gmail account is already set up on my current BIS, and I can't use a false one as it's invalid. Maybe my BIS services are more restricted than yours?
    Last edited by stasber; 09-10-10 at 05:57 PM.
    09-10-10 05:42 PM
  4. usulsuspct's Avatar
    Name the new bis account for the from address you plan on using for this account, for the username use your usual gmail username modified with as below:

    Username+newfrom@gmail.com

    Use your normal gmail password. This should be enough to trick bis into thinking this is a different account than you already have setup. As mentioned above you will then need to use bis filters to avoid dupes.

    This is all on ATT bis in North America.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 06:45 PM
  5. stasber's Avatar
    Yep that's what I thought you meant and I tried it but can't do it. I'm on 3 Ireland, which seems pretty locked down.

    From the home/main screen I click on Set Up Email, then need to enter existing email address and password, which is then checked - and comes back as 'invalid username or password' whether I use my already set up account, or enter a fake one. No other way round it. Same from desktop, same from handset.

    Plus I can't register the device with another BIS as "This BlackBerry(R) device is not registered with your wireless service provider."

    So I guess I'm buggered!

    Thanks for the suggestion. Any others are very welcome!!
    Last edited by stasber; 09-10-10 at 06:57 PM.
    09-10-10 06:54 PM
  6. usulsuspct's Avatar
    Hrm it's not a bogus gmail account. Gmail supports having this type of email address.

    So if your primary account is: johnsmith@gmail.com

    The second account would be: johnsmith+from@gmail.com

    More info on the + and . Can be found here:

    GMail Plus - A Smart Trick to Find & Block the Source of Email Spam - Digital Inspiration

    Good luck!

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 07:07 PM
  7. stasber's Avatar
    Ah OK I see... very clever. I misunderstood your intention there. Nice little trick that - bookmarked!!

    So, second account set up and a couple of basic filters - To contains gmail then don't forward, To contains domain then forward.

    This works as I'm expecting it to work so I can play with them some more (including 2 notifications, one of which (i.e. the new account) I'll disable.

    But my issue persists... my Send Using still shows only Gmail. This is after a battery pull, too (just in case).
    09-10-10 08:00 PM
  8. usulsuspct's Avatar
    When you set the new account up set the reply to be were your sending mail from.

    When you compose a new email there should be a drop down letting you pick from the two gmail accounts. Just pick which account, which sets the different reply to accordingly.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 08:05 PM
  9. stasber's Avatar
    That's exactly what I did, and nope the drop down is still just the one.

    But... something I might try out now is to set up the opposite filters on the original account (i.e. forward everything gmail & don't for domain), meaning that my emails would arrive in separate inboxes on the device, but should all still behave normally in my real Gmail inbox... Hmmm...
    09-10-10 08:10 PM
  10. usulsuspct's Avatar
    You should see the drop down when composing in the unified messages box, maybe it doesn't show from individual mail folders. (I have also never checked it from the gmail plugin.)

    Since you can't rely on any gmail filters within google, you will need to setup bis filters to:

    Gmail domain
    Not forward messages "From: domain.com"
    Forward by Default

    Personal Domain
    Forward messages "To: domain.com"
    Do not forward by default

    I have been using a similar setup with my google account for awhile now and has so far allowed me to handle multiple domains within one gmail account.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 08:15 PM
  11. stasber's Avatar
    Those are essentially the filters I set up - and simplified them having seen your example.

    Each individual mailbox now lets me compose & send new messages with a choice of Send Using - perfect.

    Replying or forwarding is a bit of a mixed bag, and I can't make sense of it yet.

    Whether I use the message list or individual mailbox, it seems that depending on some criteria in a particular message, sometimes I get a Send Using list of Default/Gmail/Domain, other times it's just Gmail/Domain, and other messages just seem locked to the one it was sent to.

    Still testing...
    09-10-10 09:20 PM
  12. usulsuspct's Avatar
    Hrm - is the inconsistency with messages that were already on the device? My experience is that replies to messages are linked to the account they came in on. New messages default, well to the default. It sounds like you are headed in the right direction.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 09:23 PM
  13. stasber's Avatar
    Yeah that's what I'm wondering.

    Looks like forwarding is the same as compose new.

    Given the subscription alert message, I can forward using both Gmail and Domain, but can only reply to Gmail (i.e. the one it was sent to). Not seeing "Default" anywhere.

    Just waiting on some test emails for my other domain. What doesn't help matters is that I'm having problems reaching my Gmail on the desktop (ISP denies all knowledge despite this and other sites' availability yoyoing all day for the past week). So then I can't refresh fetches from the other domain so the messages would hurry up.

    But I think we're getting there.
    09-10-10 09:37 PM
  14. usulsuspct's Avatar
    I see a default when I compose a new message, this default comes from Options->Advanced->Default Services.

    I don't think there is any helping the messages that are on your device they are forever linked to the account they were received on (at the time this was your only account.)

    Moving forward once your filters are setup correctly messages should arrive linked to the correct account allowing all replies to come from the appropriate address. You will only have the choice of account when composing a new message.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-10-10 09:43 PM
  15. stasber's Avatar
    I see what you're saying about Default Services (mine being set to Gmail...). I'm not seeing any Default option now (even on compose new), just the 2 accounts as set up.

    I agree with you on previous messages, seems very plausible. I've no probs with that, was just a bit confusing when rattling around with all this testing lark.

    And I also agree that moving forward, this is indeed the solution, "kludgy" as it is . Quite nice actually that I can keep them in separate inboxes but funnel them through Gmail as normal.

    Really appreciate all your help.
    09-10-10 10:08 PM
LINK TO POST COPIED TO CLIPBOARD