04-07-12 11:17 AM
63 123
  1. Helitack's Avatar
    Since I did the "fix", I have taken my device out of standby at least 400 times for using and testing purposes....didn't see the white screen anymore, for everybody that is having this issues, this fix really works!
    I am sorry to say that after 1 day I am now seeing the problem slowly begin to re-appear.
    I think it may be the connectors or plates, I am going to apply some conducting grease and see if it solves the problem.
    10-12-09 05:03 PM
  2. Dinadivas's Avatar
    Me too have a same Issues..
    but if I press the keyboard..,
    the screen Will back Normally
    10-12-09 07:58 PM
  3. brettrandall's Avatar
    I never would have believed it, but putting the electrical tape on the back of the LCD seems to have fixed this problem which has bugged me for months... I was getting white screen, static noise, sometimes the whole screen would even appear upside down. All fixed! Thanks all.
    12-01-09 08:06 PM
  4. dniym's Avatar
    I will try the electrical tape thing, but it sounds ridiculous that we have to resort to this to fix this problem. I still believe it has to do with a software bug. I hope it gets resolved soon b/c I can't tell who is calling me at times and that bloooooows.
    12-04-09 09:52 AM
  5. 701's Avatar
    See Cheetah's answer regarding my problem: white screen in his app. http://forums.crackberry.com/f83/new...38/index5.html
    My guess is that you don't lock your keyboard, neither you use Auto-Standby. Maybe you just press some lateral key twice, like I do.
    12-04-09 10:27 AM
  6. kevz65's Avatar
    did anyone ever manage to fix this? I have the same problem on my bold, the TV static noise thingy, its really annoying. Sometimes it messes the screen up so much i have to do a pull on the device. I have tried the electrical tape fix, it works for a few days and then it goes back to the problem...

    02-28-10 04:50 AM
  7. das3012's Avatar
    Hi guys, I'm having the exact same problem! Tried wipe and reinstall no go. Anyone has ever figure out what's causing this problem?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-13-10 11:05 PM
  8. GapBoyPCS's Avatar
    Oddly enough, I think I'm having the same problems.

    I noticed about two months ago I started getting the fuzzy screen. I figured it may have been due to an app I downloaded. This afternoon, my screen has gone totally white. The phone doesn't work, yet I was able to (luckily) perform a full data backup. I've wiped and reloaded the OS. Did several battery pulls. Now, I'm waiting for an overnight battery pull.

    If the overnight battery pull doesn't work, I'll see if I can play with this thing over the weekend. My gut feeling is that I may need to spring for a new one
    05-05-10 08:20 PM
  9. sibibip's Avatar
    Thanked bmbk so much for your tips...

    The only way solving this trouble is to cover the PCB under the LCD with electrical tape.... now the white screen / pixelate screen is Gone !
    08-25-10 07:35 PM
  10. neilrobi's Avatar
    Been having this problem for a while and it's got worse recently. Just fixed it with the insulating tape method. Looking good so far. Thanks.
    08-29-10 07:02 AM
  11. cbcastle's Avatar
    I put the tape just between the screen and circuit board but didn't clean the contacts or put the tape anywhere else. For me the white screen of death is gone, still getting the fuzzy screen but as soon as I touch a key this goes away. I might try cleaning the contacts and adding the extra tape at a later date to see if I can get rid of fuzzy screen, for now just having the white screen gone is excellent, thanks for the fix.
    09-09-10 01:30 PM
  12. omkar99's Avatar
    does any one has a solution to this??i am facing the same problem with my device..now how m i goin to even resell dis piece of crap..?
    10-07-10 05:00 AM
  13. SniffleZ's Avatar
    Do you cover the audio jack + usb port when covering the back pvc, or just navigate around it? Also is the OS reinstall necessary to see the changes or will it be known when you re - insert the battery?

    ASAP response much appreciated.
    04-07-12 11:17 AM
63 123