1. sengokubattosai's Avatar
    Hello all, the other day I broke my Pearl because I'm an *****. That being said, I had my old 8703e laying around so I switched back to that so I can have something to use until my contract is up in November. Anyway I am having trouble getting Blackberry Messenger to install. The download link that I use from my phone says if I don't have OS version 4.5 it will download an older version of BBM, but when I click on the link it tells me that my device does not meet the minimum requirements.

    Can anybody send me a download link to an older version that will work on my 8703e? I am running OS 4.2 on it if that helps at all.
    07-25-10 03:06 PM
LINK TO POST COPIED TO CLIPBOARD