1. jenlutar's Avatar
    I don't like my curve !! Since I've gotten it, nothing but problems with the blackberry messenger. It won't open. I turn off the phone, take out battery, let it sit, put battery back in ... then phone won't even turn on. I just get that little clock thing in the middle that just "thinks, and thinks, and thinks" ... It's VERY annoying. Anyone else out there have the same problem. Also getting major junk/virus e-mail into my account, but it isn't in my account on my home computer .... Very strange. It's crazy, and I don't know what to do !!
    01-11-10 10:23 PM
  2. Giox's Avatar
    How long have you had the Curve? Did you try removing then reinstalling BBM?

    Posted from my CrackBerry at wapforums.crackberry.com
    01-11-10 10:41 PM
  3. BergerKing's Avatar
    What version of BBM is on our device? The version you currently have might be outdated and needs to be upgraded.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-11-10 11:12 PM
  4. bluz's Avatar
    upgrade BBM and then try again.
    01-12-10 03:07 AM
  5. bsmith4293's Avatar
    I have been having problems with my BBM too. I've had the phone for about two months and never had the problem till I upgraded BBM. I uninstalled it and re installed it and it still does the same thing.

    What it is doing is lagging when your typing. It may not seem like its a big deal but its VERY annoying. Sometimes before I realize its not typing on the screen it will be 20 words behind me. Oh well what can you do. There is always going to be something up with a phone

    Posted from my CrackBerry at wapforums.crackberry.com
    01-12-10 07:57 AM
  6. Blknreal30's Avatar
    Has anyone had a problem with the BBM deleting itself? I have Sprint and called them due to the fact that the BBM deleted itself right out of the application folder. I went to use it and it was gone. BTW, I have the Curve 8530 and only had it for two days. Not only that all IM's were deleted and I've uploaded the new version of BBM and now I have to send out requests again for peoples pins. Has anyone had this problem or can anyone help? Sprint was no help at all. I even tried to sync it with Blackberry Desktop and now it is asking for a password and the password that I have on it is not working. Is this phone even worth all these issues? I might have to go back to my Curve 8330. I didn't have any problems like this.
    02-06-10 11:07 AM
  7. Nalinith's Avatar
    hmm, that's weird indeed. I would try taking it back to whom you bought it from and explain your problem, if you have insurance they may swap it out or help you get customer support. I'm not sure what would be causing this to happen and it could either be software or hardware. The clock should only be up for a couple seconds then switch to the blackberry loading bar screen. As far as Blackberry Messenger if completely re-installing doesn't help the situation, I'm not sure what could be the problem. I know sometimes people can fix their problems with a complete re-install of the operating system, but myself, I wouldn't try it unless I was sure I knew what I was doing.
    02-06-10 11:22 AM
  8. snakedoctor231's Avatar
    if you have joined a bbm group this may be the cause.when i first joined a bbm group i experienced some of the issues you have right now.what i did was joined the group and then wait until it loads all of the groups info(you should see the send/recieve icon going crazy for about 5 mins),then do a battery pull and when it loads wait 5 mins and do another battery pull.that being said bbm groups murdered my battery.......i had to leave the groups.
    02-06-10 08:07 PM
LINK TO POST COPIED TO CLIPBOARD