1. Techie2010's Avatar
    I have an unlocked T-Mobile BlackBerry 9700 and am using a Cisco Valet Model M10 wireless router. I am currently roaming internationally.

    But I am not getting any emails via the BlackBerry service and am not connected to the BB messenger.

    I am connected to the internet as I am able to browse the web and check my emails via the browser.

    My Wi-Fi Diagnostics Basic:
    WiFi - Network acquired
    UMA:Connection Preffered: Wi-Fi Preferred
    UMA Wi-Fi Available: Green check
    Connection: Red Cross
    Error Code: W006.7
    Status: T-Mobile Network error


    I have connected to several other Wi-Fi routers from different places and face the same problem.

    When I am back home I am able to connect to get emails and BBM through the Wi-Fi connection even though that is not a T-Mobile connection/SIM card.

    Can anyone help?
    08-21-10 08:22 AM
  2. dictoresno's Avatar
    what color is your wifi icon when connected?
    08-21-10 08:33 AM
  3. zeelob's Avatar
    Same thing happening to me here in NYC...I'm not getting emails and BBM is hanging when I try to send messages.
    08-21-10 08:45 AM
  4. Techie2010's Avatar
    The WiFi symbol is in Black and White. The "Wi" text is black in White background and "Fi" text is white in black background - I wonder if this helps.
    09-09-10 06:52 PM
  5. dictoresno's Avatar
    The WiFi symbol is in Black and White. The "Wi" text is black in White background and "Fi" text is white in black background - I wonder if this helps.
    no no no. when connected to a wifi network and have a positive data connection through BIS, the wifi icon will be bright and black/white. when no BIS data connection is present, it will be greyed out.
    09-10-10 12:45 AM
LINK TO POST COPIED TO CLIPBOARD