1. Illuminator321's Avatar
    I don't know WTF happened, but last night i turned off my bold then turned it on again and everything went haywire. My text msg icon disappeared (i can't send txt msgs), and same with my bbm and gmail email service

    Funny thing though, my BBM and Txt msging are still there. If i go to previously used applications i can access my bbm from there and everything is still active, and from there if i send an MMS to a contact, upon sending out the MMS it will take me to my txt msg screen......but this isn't the way things should be, it's incredibly frustrating, and i'm wondering if no one knows how to fix this if i can just "reformat" or restart my 9000 from scratch, even if it involved deleting all data and contacts on the phone.
    11-24-10 10:30 PM
  2. aznlgcy's Avatar
    I would wipe the phone and reinstall the OS.

    Here are the steps inc ase you need it:
    1) Use Desktop Manager to backup your phone
    2) Download the OS you require and install on your pc.
    3) Download BBSAK and install it
    4) Use BBSAK and select wipe phone under Backup/Restore
    5) Use BBSAK and select Load OS under Backup/Restore
    6) Use Desktop Manager after booting to restore your backup file.

    Good luck hope this helps
    11-24-10 10:43 PM
  3. Blacklatino's Avatar
    I would wipe the phone and reinstall the OS.

    Here are the steps inc ase you need it:
    1) Use Desktop Manager to backup your phone
    2) Download the OS you require and install on your pc.
    3) Download BBSAK and install it
    4) Use BBSAK and select wipe phone under Backup/Restore
    5) Use BBSAK and select Load OS under Backup/Restore
    6) Use Desktop Manager after booting to restore your backup file.

    Good luck hope this helps
    I agree. I would follow it if I had similar issues.

    OP, good luck. I'll assume that battery pulls didn't work after resending service books.
    Last edited by Blacklatino; 11-24-10 at 11:01 PM.
    11-24-10 10:58 PM
  4. Illuminator321's Avatar
    Hey i am following your instructions but everytime i try to load the OS I get this error

    "unhandled exception has occurred in your application. If you click continue the application will ignore this error and attempt to continue"

    so i press continue, and nothing happens!!

    it also says

    "object reference not set to an instance of an object"

    and here are the details


    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at BBSAK.os.Button1_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventAr gs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4952 (win7RTMGDR.050727-4900)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    ----------------------------------------
    BBSAK
    Assembly Version: 1.9.0.0
    Win32 Version: 1.9.0
    CodeBase: file:///D:/Program%20Files%20(x86)/BBSAK/BBSAK.exe
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    11-26-10 02:04 AM
  5. mandony's Avatar
    First delete all the BB OS on your PC

    Go to add/remove programs and find the BB OS program file: "Delete"

    Then, go to Program files: common files: Research in motion: delete the remaining OS files and 'removed files'

    Then, reboot the PC

    Follow the instructions given by ANZLGCY

    but ...

    DO NOT install the OS through the DM:

    Use the procedure to download the OS to PC

    Go to:
    program files: "common files": "research in motion": "apploader": delete the "vendor.xml" file: click "loader.exe"

    The OS should install correctly
    11-28-10 12:47 PM
LINK TO POST COPIED TO CLIPBOARD